Previous 1 2 3 Next 41 Replies Latest reply: Mar 1, 2014 9:20 AM by BDAqua Go to original post
  • pgf Level 1 Level 1

    I have a MacBook Pro (Mid 2010, Snow Leopard 10.6.8) and I bought a Freecom external HD Quattro 3.0, 3TB model, which have USB2.0/3.0, FW400/800 and eSATA connections. The enclosed HD is an Hitachi Deskstar 5K3000.

    If I connect the HD through USB2.0 the OS recognizes it as a 3TB HD. I can format it, create partitions, etc... with no problem.

    But if I connect the HD through the FW800 the OS recognizes it as a 2.2TB HD! No matter of GUID partition table and the like.

    I tried also to create 2 partition 1.5TB each using USB2.0 and then connect through FW800 but all I can see is just the first partition. And still the OS (and DiskUtil) recognizes it as a 2,2TB HD.


    I booted Linux Ubuntu 11.10 64-bit (through the Live CD) and I connected the HD through FW800. Linux recognizes the HD as a 3TB HD! I can format it, create partitions, etc.. using GParted with no problem.

    Partitions created with Linux are recognized (the whole 3TB) by Mac OS if I use USB2.0, but using FW800 the HD is always recognized as a 2.2TB capacity disk.


    I think this means that there are no hardware limitation, neither in the MacBook Pro nor in the external HD.

    It seems it's a problem in the FW800 software/drivers in Mac OS.


    Hope this help.

  • v8media Level 1 Level 1

    Interesting find! I suppose it could be that something is a bit off about the Firewire implimentation as well, but no way to know that. For my current uses, USB2 is fine, but if someone runs across an enclosure that shows 3TB with FW 800, let us know! I'm going to need one in a while.

  • torana355 Level 1 Level 1

    Yep you are having the EXACT same issue as i am with my Stardom enclosure. With usb it sees the full 3TB but with FW 800 it only sees 2.2TB. I ended up sending my Enclosure back as it did not work as advertised.

  • BDAqua Level 10 Level 10

    Good work, if I ever get any money again I'll investigate whether it's a FW anomoly or actually the FW chipset/firmware used in the external.

  • slow_runner23 Level 1 Level 1

    For those of you using OWC external enclosures, I found that there was a dip switch toggle in my OWC enclosure which allows Large Block Addressing.  Mine was off by default (i.e. limits to 2.2 TB).  Switching the dip switch to "1" solved my issue and now able to access the full 3TB using firewire connected to iMac. 

  • BDAqua Level 10 Level 10

    Wow, great tip/post, thanks a lot!

  • Siobhan Ellis Level 1 Level 1



    what type of enclosure did you have, and where is the dip switch?


    I have Ministack V2 & V3.





  • slow_runner23 Level 1 Level 1

    Mercury Elite Pro.  Red dip switch on the inside of the box on the board.  Realized this by reading the online OWC owners manual.  You may want to consult the ministack manual or assembly manual.


  • coconutstorm Level 1 Level 1

    This works!  I just received my Mercury Elite Pro, with a Seagate Barracuda 3TB drive.  When I first used it, it only showed up as 2.2 TB.  I opened the enclosure and saw a red dip-switch that was in the '0' (zero) position.  I switched it to '1' and it works now! 

    I just had to open Disk Utility after this change was made and remove and readd the partition.  3.0TB :-)

  • SlamSlam Level 1 Level 1

    How has everyone's experience been putting the computers to sleep?


    I'm using a Rosewill RX-358 V2 with a Samsung 2TB HD204UI "green" drive over USB2. When I put the Late 2011 MacBook Pro to sleep, the drive initially goes to sleep but then wakes back up moments later. And then never returns to sleep.


    I swapped in an older WD 320GB (WD3200JS) drive and it does the exact same thing. The WD drive, as far as I know, is not a green drive. So this leads me to believe the controller in the Rosewill enclosure doesn't play nice with Lion 10.7.2.

  • WandaTheWonderful Level 1 Level 1

    The specs for the Rosewill RX358 v say it only takes up to a 2TB.  Any problems with your 3TB since your post?!

  • SlamSlam Level 1 Level 1

    Just an update/aside:


    I was correct in assuming my problems were in relation to the controlelr in the RX-358 v2. In my opinion, this enclosure is not Lion-friendly (see my post above re: the issues I was having).


    I purchased an OWC Mercury Elite Pro:



    When I put the MAcbook to sleep, the drive goes to sleep.


    When I shutdown the Macbook, the drive will initially go to seleep but then wakes back up and stays up. I suspect this has to do with the Macbook sending power over USB. Or perhaps the "Eco" controller in my Samsung HD?


    I haven't tried it with Firewire yet.

  • darrylfromsaskatoon Level 1 Level 1

    Same problem here:

    3GB  Seagate Barracuda in Nexstar 3 enclosure w/ eSata and USB

    Via USB on MacBook Pro (below) does not mount and shows as ~800Gb in Disk Utilities

    on MacPro Desktop  running 10.6.8 it works fine.



    MacBook Pro

    OS X Lion 10.7.3 (11D50)

    2.33 GHz Core 2 Duo

    #GB RAM

    USB Bus:


      Host Controller Location:    Built-in USB

      Host Controller Driver:    AppleUSBUHCI

      PCI Device ID:    0x27c8

      PCI Revision ID:    0x0002

      PCI Vendor ID:    0x8086

      Bus Number:    0x1d

  • CanadaRAM Level 2 Level 2

    You say it works fine on the MacPro: through which interface, USB or eSAta?


    In every case I have seen, it is the enclosure's firmware on its bridge board which is at fault.

    When you use eSATA with an eSATA card, there is no need for a bridge.

    When you use USB or FireWire, the bridge board translates between the drive SATA interface and the USB or FireWire protocol.  The posts above which indicate it working on USB and not on FireWire reflects the fact that USB and FireWire use two different chipsets on the bridge board, so it isn't unusual that the performance can differ.

  • murray1784 Level 1 Level 1

    I can add a few more sad facts to the post. 


    I've tried this with two different brands of 3TB drives (WD Green, and Seagate Barracuda); two different LaCie FW-800 and a NexStar USB-2 enclosure; I've tried all of these combinations on OSX 10.8.2 and one of the drives and the USB-2 interface on OSX 10.6.8.  In all cases the drives show up as 802 GB in size in Disk Utility.  I have yet to find a combination of actions, settings, or partitions that make the total usable space anything larger than 802 GB.


    So it's probably not an issue with a cheep enclosure, a particular brand of disk, disk failures, or the latest OS.