Previous 1 2 3 Next 41 Replies Latest reply: Mar 1, 2014 9:20 AM by BDAqua Go to original post
  • coconutstorm Level 1 (0 points)

    You couldn't get this to work, even with the red dip switch in the enclosure?  I fixed 3 of my OWC enclosures in this way. 

  • murray1784 Level 1 (0 points)

    There are no dip switches anywhere on or in my LaCie or the NexStar cases.  It's likely I'll get an OWC case to put the 3TB drive to good use.

  • coconutstorm Level 1 (0 points)

    Ah gotcha.  Yes, in that case, I imagine that it's an issue with the chipset or something as you said.  Sad that those enclosures can't be put to good use with modern drives, but I guess you can keep them around for your smaller (older) drives. 

  • darrylfromsaskatoon Level 1 (0 points)

    darrylfromsaskatoon wrote:


    Same problem here:

    3GB  Seagate Barracuda in Nexstar 3 enclosure w/ eSata and USB

    Via USB on MacBook Pro (below) does not mount and shows as ~800Gb in Disk Utilities

    on MacPro Desktop  running 10.6.8 it works fine.



    MacBook Pro

    OS X Lion 10.7.3 (11D50)

    2.33 GHz Core 2 Duo

    #GB RAM

    USB Bus:


      Host Controller Location:    Built-in USB

      Host Controller Driver:    AppleUSBUHCI

      PCI Device ID:    0x27c8

      PCI Revision ID:    0x0002

      PCI Vendor ID:    0x8086

      Bus Number:    0x1d

    Drive was just too big for box / age of box. Worked fine in other box and 2TB still worked fine in this box so....

  • pgscores Level 1 (0 points)

    I'm having the same problem. Have two 3TB WD drives.  Using an KingWin EZDock2 which supposedly supports up to 3TB, with MacPro 10.6.8 and drive shows up as 800GB.   Tried it in the LapTop running Mavericks and same thing.   Also, tried with an Apricorn DriveWire on the Laptop...still sees the drives as 800GB.


    Any help would be greatly appreciated. 




  • BDAqua Level 10 (122,266 points)

    3 TB showing as 800 GB is the classic symtom of something not understanding the new Advanced Format of drives.


    Was it formatted on an older Mac or older Case beforehand?

  • pgscores Level 1 (0 points)

    It wasn't formatted before hand and was a 3TB Western Digital Desktop Drive.   I was using it in an KingWin EZdock 2 adapter (USB 2).   After reading this thread I went to Fry's and bought a USB 3.0 Dock Adapter (Vantec NextStar usb 3.0 hard drive dock) and Voila.  It sees all three TB.

  • BDAqua Level 10 (122,266 points)

    Thanks, seems the WZdock2 chipset did not understand Advanced Format's 4096 Byte sectors.

  • Tiagoromerobaptista Level 1 (0 points)

    Im having the same problem... 3TB seagate barracuda doenst show on Rosewill Enclosure ...only 800gb...


    Macbook pro 17 late 2009

    CPU 3.06hz


    1 ssd 512gb

    2 ssd 485gb (cd-rom substitute)


    i tested on a macpro 2009 and it directly on sata port onboard and it

    works fine, the 3TB are visible and im able to initialize the disk.

    back again on the enclosure usb 2 connection on mac ... only shows 800gb.

    also i did visited seagate website and the support for this issue on MAC OSX support not avaialable.


    Any sollution for this?

  • BDAqua Level 10 (122,266 points)

    You need another enclosure that handles Advanced Format & big drives.

  • Tiagoromerobaptista Level 1 (0 points)

    I´ve request support on Rosewill website, because the product specs says support up to 2TB disk...

    lets see what they say... if doenst.. what enclosure should I bought to handle with this 3TB disk?



  • BDAqua Level 10 (122,266 points)
Previous 1 2 3 Next