9 Replies Latest reply: Jul 18, 2013 2:00 AM by 8383
theoqaat Level 1 Level 1 (0 points)
I just created a new Numbers document. It has 3 pages.

In the footer I display (page number) of (page count).

I would expect to see "1 of 3", "2 of 3", "3 of 3".

What I get is "1 of 1", "2 of 1", "3 of 1".

What do I have to do to get the page count to count the number of pages?

Thanks

MacBook2.1, Mac OS X (10.4.10)
  • Level 8 Level 8 (41,790 points)
    Here I get :



    For the hundred times, when something behave wrongly,

    try to run the app from an other user account.

    If it behave the same, the problem is a global one, there is something odd in the set of files shared by every account.

    If it behave flawlessly, it's that something is wrong in the original account.

    In this case,
    quit the app,
    move the preferences files :

    <startupVolume>:Users:<yourAccount>:Library:Preferences:com.apple.iWork.Numbers. plist
    <startupVolume>:Users:<yourAccount>:Library:Preferences:com.apple.iWork.Numbers. LSSharedFileList.plist

    on the Desktop
    restart the app.

    If it behave well, one of the preferences files was corrupted and the app rebuilt a clean set.
    You may trash the old ones.

    If it continue top fail.

    You return to the thread and describe exactly what you made
    telling us exactly
    which is the version of the running app
    which is the version of the running operating system
    I'm puzzled by what is written in your message because iWork '09 isn't supposed to run upon 10.4.10

    Yvan KOENIG (VALLAURIS, France) vendredi 18 février 2011 21:43:52
  • theoqaat Level 1 Level 1 (0 points)
    Thanks for the response.

    Interestingly, while I was editing the sheet, the problem corrected itself and the page count is now correct. Don't know why.

    I have now converted 5 spreadsheets into numbers documents.

    Sometimes, the new document initially shows the page count as 1 for all pages. Sometimes, the page count starts out correct.

    Obviously, something that I do (or the way in which I do it) affects the way the page count is displayed. But, however the page count starts out, every sheet ends up with the page count correct.

    That's sufficient for my purposes.
  • Level 8 Level 8 (41,790 points)
    Are you really running 10.4.10 ?

    Yvan KOENIG (VALLAURIS, France) samedi 19 février 2011 16:24:11
  • theoqaat Level 1 Level 1 (0 points)
    Not a useful response - to a non-technician.

    Found the problem to be self-correcting, anyway.
  • Level 8 Level 8 (41,790 points)
    The iWork '09 requirements are :



    so, the question "Are you really using 10.4.10 ?" *_is relevant_*

    Yvan KOENIG (VALLAURIS, France) samedi 19 février 2011 19:01:52
  • linda2009 Level 1 Level 1 (35 points)

    Hello. I was searching the boards today, because I was having this same issue.  I couldn't figure out why when I chose Insert, Page Count in the footer, it was always coming up "1" - Yet, Insert, Page Number would be correct.  This is what I would get in footer:

    Page 1 of 1, Page 2 of 1, Page 3 of 1, Page 4 of 1, etc.  Should have been: Page 1 of 5, etc.

     

    Not finding a "fix" here besides starting troubleshooting with creating a test User Account (which is okay), I decided to do some more troubleshooting first, and I discovered something.

     

    I found my fix.  I don't know if it's what was happening for you, but this fixed it for me.

     

    Insert the Page Count from the Menu in the footer.  Make sure the Inspector is open.  Go to the Sheet Section.  In the middle is a Page Options section.  For me, the "continue from previous sheet" was checked.  Instead, I checked the second option "Start at" and chose "1."  That worked for me.

     

    I started this spreadsheet from a csv document, but I tried starting one from a blank template and "continue..." was also selected.  Seems like it's the default?

     

    Hope this helps someone else who is having this issue.

    Have a great day!

  • linda2009 Level 1 Level 1 (35 points)

    It also seems to help if you Save the file.

  • 8383 Level 1 Level 1 (0 points)

    It's a bug I think.  Page count is actually using Total pages from all sheets count. !!!

  • 8383 Level 1 Level 1 (0 points)

    A bit of research and I think I have this cracked.  You need to set the first page of the sheet you are working with to 1 and not have it continue from previous.  Have a look in Sheet Inspector and then Page Numbers.

    I now have a two sheet document with 3 pages in first sheet and 4 pages in second sheet and they all show correctly.  If you want the pages from all sheets to be counted then use the continuous setting.