8 Replies Latest reply: Jun 22, 2011 10:52 AM by PDXgeek
Chief Tarun Level 1 Level 1
I have Mac OS X 10.6.6 and two Windows machines(one xp and one 7) and I want to be able to exchange files between them on my home network so I can edit files on any computer and then share it back to the others so I can work on any file on any cpu. Is that possible, and how? Thanks.

iMac 27" Core i5 Mid-2010 Model, Mac OS X (10.6.6), iPhone 4, and iPad
  • Kappy Level 10 Level 10
    The following may help:

    File Sharing With Snow Leopard- Sharing OS X 10.6 Files With Windows 7
    How to mount a Windows shared folder on your Mac - Lifehacker
    How to Share OS X Folders with Windows 7
    Mac OS X- Setting up Windows File Sharing
    Windows Sharing for the Mac
    Connecting Mac OS X to Windows PCs
    GUIDE to Networking Windows with OS X
    Set Up Your Home Network, Windows 7 Edition - PC World


    Simple guide to Leopard/Windows Home Networking

    Written by Intercepter121 and originally posted on the Apple Discussions here.

    If your network complies to the minimum requirements described below you should be able to share resources without any need to enter commands in the terminal to modify configuration files in your mac.

    1. A decent router
    2. Mac Os x 10.5.1 installed on your macs
    3. Windows XP or Vista
    4. Number of network devices <10
    5. Some network printers or drives (NAS)
    6. A decent ISP offering a good DNS service

    General Settings
    If your router offers DHCP and any of the device has power saving features there is a risk that the IP addresses are renewed. This can be problematic as the devices keep changing IP addresses. As this is your network is strongly recommended to reserve IP addresses to the MAC (Machine Address Code) of the various devices so that they can power on and off and still keep the same IP.This simple suggestion will greatly improve the browsing of the local network.

    Accessing Windows Resources from Leopard with no authentication

    1. Check the settings of the PC and ensure the IP addresses on the local LAN are trusted
    2. Activate sharing on the desired devices ensuring the shares are read and write. If you use Vista ensure password protected sharing is disabled.
    3. Try to access the windows share from another windows computer if available to confirm no authentication is required

    1. Go into system preferences->security-Firewall check that the setting is not on allow only essential services. Recommended settings is allow access to specific
    2. Go back into system preferences network. On the tab location click edit locations. Duplicate Automatic and call the new location Home. Now select the Home location and go into Advanced-WINS. In the workgroup field enter the same value that is on the other windows computers for example HOME. Now press enter then go back to the main screen. Select Edit locations and delete the location automatic. Now edit your location Home and rename it Automatic. This workaround is a leopard bug described here.
    3. Give 5 minutes to allow all the other machines to broadcast their IP address and the other computers should appear on the left side of your finder window. You can now select the shares you want to connect. As no authentication is active if you are prompted with a user name just press OK.

    The procedure to access a NAS is the same as above, just ensure permissions are set to files are read/write for anyone to avoid confusion.

    NOTE: There is no need to activate SMB sharing if you don't want to allow the PC to read folders on your MAC

    After you have followed all the steps you don't see any windows PC.

    Identify the IP address of the machine you want to connect. In finder select Option+K and enter SMB://IPADDRESS. If you can connect you have a name resolution problem. Go into your router configuration and ensure that the option DNS assigned by ISP is selected and you don't have services like Open DNS in use and fixed IP addresses in that field. Apply the changes and reboot the router. You should start seeing windows PC in finder shortly after.

    Your ISP DNS service is poor and you must use Open DNS or similar
    If you are forced to use services like open dns you have the risk that the router propagates the DNS servers to your machines. As the implementation of SAMBA in Leopard effectively blocks the MAC to be a master browser for performance reasons you end in a situation in which tiger machines connect and leopard ones don't see a single share. Let's fix it.
    1. Go into System Preferences->Network then advanced DNS if you see here the IP addresses of the open dns servers this is the case. Unfortunately you will be forced to change the hosts file.
    2.Ensure you have reserved IP addresses to all your machines so that they always get the same IP.
    3. Now login into your mac as administrator and go into utilities=>terminal.
    4. Issue the following command sudo pico /etc/hosts
    5. Now scroll down and enter all the IP addresses and computer names of any device you want to browse
    6. Reboot your MAC
    The windows devices will now appear in finder and you will be able to connect with Option+K.

    You cannot access shares even entering the IP address
    You have not reserved IP addresses to each machine. Go into your router LAN set up and make sure that is the case.

    Accessing Leopard resources from Windows
    1. Go into system preferences->security-Firewall check that the setting is not on allow only essential services. Recommended settings is allow access to specific
    2. Go into System preferences->accounts and click on Guest flag the option Enable guest account to access shared folders
    3. Now into System preferences->sharing select file sharing and then options here flag SMB and select the user that has to be logged into the computer when the share has to be accessed. Ensure that the folder you want to share has read/write or whatever permissions you like it to have set for Everyone

    You should now be able to see your MAC in the windows network resources and access the shared folder with a double click without any password request.

    You don't see any MACs from Windows

    Check the firewall settings at the start of this post. Then go back to the Network configuration hit advanced and then TCPIP check is using DHCP and not a fixed address. Then check the sharing is set as above with SMB clicked. If SMB is not set you won't even see your mac from windows.
    You see the MAC and the shared folders but you can't read or write on it
    Ensure you have set the guest account to access shared folders. Then check on the sharing preferences that there is at least one folder with read permission for everyone. The classic case here is Dropbox that leopard sets as read and write for the user of the MAC but no access for other users. You try to click on drop box and receive an error but when you actually try to write a file you can do it. Check the permissions on the subfolders of the share as those permissions will prevail on the home shared folders


    You may want to do more complicated things, but first ensure you can actually share files without security in place so you can identify the root cause of your possible problems

    I want to password protect my windows shares: once you have done the relative set up in windows vista and ensured you can connect from another windows machine you will need to use user name and password of the Vista user to connect.

    I want to password protect my MAC shared folders: Go into user account and disable guest access to shared folders is no shared folder has to be accessed without password otherwise leave it checked. Create a new user for sharing (better than giving away your password) so that this user only accesses the folders you want to share. In System preferences network select file sharing SMB and flag only the new user you have defined. Then go back to the folder section and set the permissions you like on the folder you want to share for this newly defined user.

    Good Luck
  • Chief Tarun Level 1 Level 1
    Alright, I'll try some of these links and tips out. Thanks.
  • PDXgeek Level 1 Level 1

    ok, I've got a problem. I've set up everything correctly as far as I know.  This worked flawlessly with my old Macbook, but now I'm using a macbook from work and I can see the macbook on my WIN machine, but it's empty, and I cannot see the share.  If I goto the Macbook system preferences and set sharing so that 'everyone' can read/write the shared folders, then I can navigate them on my PC, but otherwise...no dice.


    Yes my WIN profile and the user I set up on the Macbook for sharing both have the same name and password, 'WIN7'.  I can provide more detail but wondering if anyone knows what the issue is.  If I try and map a network drive from the WIN side and enter the Macbook IP, it says the drive is not accessible, 'network access denied'.

  • PDXgeek Level 1 Level 1

    ok, resolved....although it makes no sense. Go figure.


    1) I KNOW that my PC login and the user I set up on Macbook have the same username(WIN7) and the same password.


    Nevertheless, when mapping the network drive I tried checking '...with different credentials' and typed in the same info and got in...no clue why.


    Can't see the macbook under 'Network' but could map the drive.


    One thing I noticed that was odd....in the Users panel of Macbook System Preferences, the username for the shared account is 'WIN7' but if I get info on the shared folder the username is in lowercase, 'win7'... not sure if that mattered but made note of it.  Also, I believe I used the lowercase version in the credentials window when mapping the drive on the windows side.

  • ds store Level 7 Level 7

    The Easy Way is to use something like DropBox for small files and large files of 4GB file size or less use a external USB 2 drive or thumb drives formatted FAT32 (MSDOS in Disk Utility)


    If you have file sizes in excess of 4GB in size then you need to have


    1: The external hard drive formatted exFAT (Disk Utility)


    2: Free exFAT support installed for the XP machine from Microsoft (Vista and 7 are ok)


    3: All Mac's on 10.6.5 or later as that's when the support for exFAT was added.



    You really don't want to network PC's and Mac's together, the headaches of malware just come right onto your Precious Mac.

  • PDXgeek Level 1 Level 1

    I have to disagree. I want access to my macbook files(my main computer) from my desktop when I'm at home without having to move files around. Networking is simple once it's set up and as soon as my macbook enters the Wifi network it's visible from my PC.


    I have 400GB+ of files on the macbook I want quick access to...so using Dropbox is not practical when there's a free option via sharing.


    And I've never had a case or heard of a case of PC malware making its way to my mac....

  • ds store Level 7 Level 7

    PDXgeek wrote:


    I have 400GB+ of files on the macbook I want quick access to...


    +400 GB of files? And all on the Mac?


    You certainly are living dangerously.


    If your using those 400GB of files all the time, there should be a copy on the PC. (as well as seperate backup)


    If your changing all those 400GB files on your Mac all the time, it's rather simple to let backup software update the files on the PC when it changes.


    Having a always on network is dangerous, especially with a PC which esseantially becomes a tool for hackers on your network.


    Your Mac is the most secure device on your network, but you have it set dead last in the chain of security.

  • PDXgeek Level 1 Level 1

    My macbook is my primary computer...of course it's full. That's typical for anyone with a Macbook as their primary I would think.


    And of course it's backed up via time machine to an external nightly. And so is the data drive of the PC.


    But you're suggesting instead of sharing my macbook to my PC I should sync my macbook to my PC?


    Other than locking down my Wifi network with a solid password, should I really be that worried about security? I'd be more concerned about my security using Dropbox after last week's news from them, lol.