7 Replies Latest reply: Feb 19, 2011 11:07 PM by Alexander66
Alexander66 Level 1 Level 1 (0 points)
Ok, I have an 09 Macbook Air running 10.6.6 that has worked flawlessly for 2 years, and then, all of a sudden 2 weeks ago, the Wifi just stopped working. _It can't find any networks at all!_ There are just no networks coming up
It works fine when it is connected with an Ethernet cable (Which I'm on now), but not with Wifi. I also have an iPad, iPhone 4, iPod Touch and a Toshiba laptop connected to the network without any problems. This is driving me crazy! Help?

Macbook Air 13", Mac OS X (10.6.6)
  • Michaelworks Level 3 Level 3 (695 points)
    Run Disk Utility and repair permissions. If that doesn't fix it, go into Network Preferences and run through diagnostics there (Apple has how to's). I don't know if the Hardware Test detects bad airport cards, but you might try. Sometimes electronics go bad.... it may mean a trip to the Genius Bar. Good luck!
  • Assisg Level 1 Level 1 (0 points)
    My friend you are not the only one, there are many online complaining about this problem and apple is not doing something about it. Tried all but now it is about 2 months that I have no WIFI.
    Very bad reputation for apple, MBA without WIFI is useless, 1 USB port: use it for ethernet or external disk ?
    Can anyone please solve this problem?
    assis@tei.se

    Many thanks to all of you who are trying to help.
    Assis
  • Alexander66 Level 1 Level 1 (0 points)
    Update
    Ok, this is getting weird. I was looking online for similar problems and someone suggested going into network preferences, advanced, TCP/IP and turning Configure IPv6 off. I did this and the internet worked! It was back to how it used to be!
    That is until an hour later, when it couldn't find the network again!! Grr
    Is that at all consistent with a faulty or broken Airport card?

    Thanks for the replies too, I am about to try them now.
  • Alexander66 Level 1 Level 1 (0 points)
    No dice on the repair disk permissions. Attempting the diagnostics. Maybe I'm doing it wrong, but the 2nd step for the Airport diagnostics is to select the wireless network to join, which, because of my problem, I can't do.
    Maybe a trip to the Genius Bar is in order
  • Michaelworks Level 3 Level 3 (695 points)
    What wireless are you trying to connect to? You might want to see using istumbler if there are neighboring wi-fi's on the same channel. If you select the airport at the top of the screen (right) do you see other networks? Somebody could have moved in nextdoor... also check to see if your wi-fi router has any firmware updates.
  • Alexander66 Level 1 Level 1 (0 points)
    Thanks for your help, but still no answer. I have created a temporary solution for the time being by creating a network bridge on my Toshiba that I use for Xbox Live and connecting the MBA to that using an ethernet cord. It will have to do before I can find time to go to the Genius Bar.
    Thanks
  • Michaelworks Level 3 Level 3 (695 points)
    NP. Hope you figure out what is wrong and get it working. Peace out!