8 Replies Latest reply: Sep 18, 2013 5:38 AM by arirablsup
lucky coyote Level 1 Level 1 (0 points)
I've have an ongoing spreadsheet I update and save every few days for the past year. Today when I try to save it I get an error message "document cannot be saved" but I'm unable to find out why. When I try to save it with another name to another location, I receive the same error. Any clues?

iMac, Mac OS X (10.6.6)
  • Barry Level 7 Level 7 (29,220 points)
    Hi Lucky,

    Welcome to Apple discussions and the Numbers '09 forum.

    Is there any more to the error message than that? The exact message, if there is more, might help someone determine more precisely what's going on.

    My initial guess is that there's some corruption in the file.

    Meantime: go to the Finder, locate the last saved version of the file, click (once) on it to select it, and press command-D to make a duplicate of it.

    Or Use Time Machine to locate and open a recent version of the file. (I'll refer to this as the 'duplicate' )

    Can you then open the duplicate in Numbers?
    Can the duplicate be edited (single change), then Saved As...(with a new name)?
    Can you then perform the rest of the recent edits on the duplicate, then Save?

    If those steps are successful, you'll now have a working copy of the file.

    Others will likely add to this, which is at best a partial solution.

    Regards,
    Barry
  • lucky coyote Level 1 Level 1 (0 points)
    Barry

    Thanks for the tip. The exact error message is "the document could not be saved". I made a duplicate as you suggested and it too gives me the same error message when trying to save, even without making a single change.

    I resorted to copying each table out of the document into a new document and will work with reformatting it. Not sure why it wasn't possible to drill down into the error to at least see what the cause was....
  • Level 8 Level 8 (41,790 points)
    This is an oddity which surface from time to time and never got an explanation.

    You may try to export as Excel then import the Excel document.

    Yvan KOENIG (VALLAURIS, France) jeudi 24 février 2011 16:17:23
  • eric_j_s@comcast.net Level 1 Level 1 (0 points)
    I have the same issue. When I go to save a previously saved numbers ssheet, it gives me the same 'do not have permission.' message. I try to save to another name. Same thing. I try copying the file and saving to a new entry. Same thing.

    Is it possible, then, that the original file sent was corrupt and it seems whenever I now create a new, unrelated .numbers file, it too, cannot be saved as anything, Excel or Numbers.

    If anyone has insight, please feel free.
  • buck5000 Level 1 Level 1 (0 points)

    I have the exact same error with an Excel 2011 for Mac spreadsheet that I created on this computer and have only edited on this computer.  All of a sudden it started giving me the "This document could not be saved" error, with no further info.  Resaving under a new name did not work, but resaving it as an Excel 97-2004 Workbook (.xls) does.  I tried saving it back to an Excel 2001 .xlsx doc, but the same error started again. I am not doing anything terribly complex with this sheet, nor is it too massive.  Help?

  • ianfromcoogee Level 1 Level 1 (0 points)

    Thanks for that, worked a treat for me too - whew ;-}

     

     

  • Barry Fass-Holmes Level 6 Level 6 (11,900 points)

    This is a different Barry adding what worked for me in case someone else encounters the "could not save" error and finds this thread.

     

    The error, in my experience with it, probably is due to a file corruption rather than a permissions problem. My problem .numbers file had the correct permissions, likewise its enclosing folder. Disk Utility repair permissions did not modify the problem file nor its enclosing folder hierarchy.

     

    After several unsuccessful attempts to save the problem file (due to the error), Numbers finally quit unexpectedly.

     

    After reopening and modifying the problem file's contents, it then saved (and auto-saved) properly.

     

    Lucky Coyote's strategy of copying the problem file's contents to a new file and saving to a new filename probably is a user's best shot at recovering work done in the problem file after the last successful save.

     

    Hope this helps!

  • arirablsup Level 1 Level 1 (0 points)

    I also got this weird "cannot save" error - without any explanation. Saving as xls instead of xlsx did the trick. When I re-opened, it asked about links, and I realized that my problem came from copying a sheet from another file. After breaking the link I had no more problems.