4 Replies Latest reply: Oct 2, 2014 6:31 PM by John Callahan1
LittleBitAHelpPls Level 1 (0 points)
Home office:
MacBook Air running 10.6.6
New Canon MX870 printer
Windows Vista Desktop
NetGear wireless router

I recently purchased the Canon MX870 as reviews indicated that it was an Apple friendly printer. I've attempted to reinstall the software a several times with different combinations of a wireless set-up and a LAN set-up, but I have not been able to add the printer as a Network printer. The printer works perfectly from the Vista Desktop and is visible via the Windows network and is visible on the NetGear attached devices view.

-- The printer is visible from Canon Tools and Safari from the MacBook --

I currently have the wired connection to the NetGear Router. Canon has network utilities. When I run the Canon IJ Printer Utility, I can see the MX870 printer. It shows network settings. The IP address matches my network and it is correctly listed as a "Wired LAN". I can even access maintenance features to show ink levels.

When running Safari - I clicked on the Bonjour printer and I am able to connect to the printer and update printer settings.

-- I am not able to see the printer in the system preferences -> Print & Fax -> Add a printer --

The printer list is empty. It's driving me crazy. When going through the normal Canon installation process, everything looks good until I try to add the printer.

-- Other stuff --

I've downloaded the apple drivers (2.4.1?)
I've downloaded the latest Canon drivers
I've deleted the printer files and reinstalled

I can perform a normal setup with a USB connection and print perfectly, but that defeats the whole purpose of me getting the new printer


MacBook Air, Mac OS X (10.6.6)
  • PAHU Level 6 (15,920 points)
    The MX870 has two components - the printer and the scanner. The printer uses a Canon proprietary protocol called 'canonijnetwork' to advertise the printer on the network. The scanner uses Bonjour. So with the device connected via wireless or Ethernet you should at least see the scanner when you select to Add a printer and have the Default view selected. If the scanner component is not appearing then this is odd, as the printer is visible via the Bonjour view within Safari. If this is so then I suggest you try a reset of the printing system and then try again.

    1. Open System Preferences > Print & Fax
    2. Move your mouse over the Printers list
    3. Hold down the Control button and click the mouse
    4. Click the "Reset printing system ..." popup
    5. Restart your Mac

    Note that this will remove all print queues in Print & Fax but not your installed printer drivers.
  • LittleBitAHelpPls Level 1 (0 points)
    Your recommendation worked perfectly. I was able to add the printer and have printed a test doc.

  • jva50 Level 1 (0 points)

    Here it is March 2013 and I have had this problem so many times that I bought another printer so there would be at least one reliable machine in my home office.


    I've called Canon at least three times to have this resolved and each time, they have helped, but only temporarily. This solution worked immediately! Thanks so much. I've printed it out and will keep it at hand should the problem recur.



  • John Callahan1 Level 1 (15 points)

    Just wanted to thank you for this invaluable advice that I have used over and over again.

    You are a lifesaver (of that wretched MX 870)!

    Thanks again