1 2 3 Previous Next 33 Replies Latest reply: Jun 5, 2013 11:07 PM by centuri50
KB- Level 1 Level 1 (0 points)
I have just installed Aperture 3.1.1 Academic version.
I imported a few pictures before setting up my real library.
I try to delete a project or a picture and they go to the trash as expected. I try to empty aperture trash but nothing happens. the files remain in the aperture trash and the osx trash is unchanged.
I removed all preferences, repaired permissions, reinstalled Aperture, restarted and repaired permissions several times. created a new library... I still can not empty Aperture trash when there is a single version, or master, or project.
What am I missing?!
I can trash the entire library from the finder, but that's not too helpful once I start really using it.

MB Pro, Mac OS X (10.6.6), Aperature 3.1.1
  • 1. Re: Can not empty Aperture trash
    Frank Caggiano Level 7 Level 7 (23,830 points)
    Emptying the trash works. How are you doing it and what messages are you getting?
  • 2. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    either with the menu:
    Aperture>Empty Aperture Trash

    Or with the comand-shift-delete.

    I get no message. The file just remains in the trash. If I use the keyboard the menu flashes quickly which is normal but the file remains in the trash and nothing ends up in the osx trash. Very strange. It just does nothing.
  • 3. Re: Can not empty Aperture trash
    Frank Caggiano Level 7 Level 7 (23,830 points)
    So you're not even getting the popup asking if you really want to empty the trash?
    What if you right click on the trash, does it come up with the +empty aperture trash+ menu item?

    You wrote that you repaired permissions. Did you also try to repair the library? What happens if you create new empty library, add a few things to it and then try it? You might also want to try it as a different user to see if that changes anything.
  • 4. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    no pop up at all. I can right click and get the empty aperture trash option. It just won't empty.
    I've tried several libraries. The current one has only three pics. a raw, a jpeg and a matched pair. I guess that is really 4 but looks like three. I've put various combos in the trash with the same non effect.

    I'll try creating another user and login in that way.

    I did have trial version 2 and 3 installed and had to trash my prefs and pro - i forget the file that was in the proapps folder. I had to do that before it would launch properly. I don't know if that was related. That is why I deleted everything and re-installed. I'm doing this exercise before I move my iPhoto and iView libraries and folders. I'm not eager to loos files or be stuck with trash.
  • 5. Re: Can not empty Aperture trash
    Frank Caggiano Level 7 Level 7 (23,830 points)
    So when you place things in the trash the *Aperture->Empty Aperture Trash* goes from being grayed out to being black, correct? So it sees things in the trash. Crazy thought if you delete a regular file with the finder does that file show up in the System Trash? Thinking of some sort of weird permissions problem on the file system.

    What drive is the library on? Internal or external? and if external what are its specs, connection type, format etc.
  • 6. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    I created a new user, opened aperture, imported several photos from an SD card.
    Selected the default untitled project created by the import and deleted one of the pictures. command-delete.
    I selected the Aperture trash. There was the deleted picture. invoked Empty Aperture Trash via menu, keyboard and right-click, all to no avail.

    No pop up asking me if I really want to delete or do anything. Just can't empty the trash. I can put pictures back away and such. So the other trash functions work.

    Any ideas?
  • 7. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    The system trash works fine.
    the Empty Aperture Trash recognizes when it has something in it or not. I can put things back. I just can't empty it. From the finder I can drill down to the file in the masters folder and trash the file there but that doesn't update the database and would be a real mess to deal with in a real situation.
  • 8. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    Sorry, I forgot to mention that the library is on the internal HD and I am not running our of space.
    I have used a library in the Pictures Folder and created one on the desktop. Same results.
  • 9. Re: Can not empty Aperture trash
    Frank Caggiano Level 7 Level 7 (23,830 points)
    The only time I have heard of Aperture having problems similar to what you are describing was when the library was on a separate volume, either an internal disk that was split into multiple volumes or an external disk and there was permission problems with the trash.

    On the boot volume each user has a .trash file in their home directory but on other volume there is a volume wide trash. Even though it looks like files deleted from other volumes are all in the same trash they are in different trash files and the OS makes it look like there is one system wide trash.

    Wish I had more to offer but I'm out of ideas. Hopefully someone else will jump in.

    good luck, let us know how it turns out.
  • 10. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    I'm still stumped.
    I deleted Aperture from the Applications folder and ran sudo pkgutil --forget com.apple.pkg.Aperture from the terminal. Reinstalled from the DVD which has version 3.1
    Tried with that after software update had an error and it still will not empty the aperture trash.

    Is anyone aware of anything that might interfere?
    Thanks....
  • 11. Re: Can not empty Aperture trash
    Frank Caggiano Level 7 Level 7 (23,830 points)
    One last thing I can think to try would be to run Disk Utility's *Repair Permissions* on the HD just to rule out some strange interaction between Aperture and the system trash.
  • 12. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    Disk Utilities Repair permissions has no effect. Still can't empty Aperture Trash.
    Re-installed again and downloaded the update again. Nope.
    Any help is welcome!
  • 13. Re: Can not empty Aperture trash
    CorkyO2 Level 4 Level 4 (1,290 points)
    Not sure if there is a difference with the Academic version or not, but there are a couple of things you can look at if nothing else works:

    1 - Move the contents of these folders to the trash and reboot (note - I suggest you just try moving any Aperture related folders / files first).

    /Library/Caches
    /System/Library/Caches
    /Users/<youruser>/Library/Caches

    Also, move the following folders to the desktop:

    /Library/Application Support/Aperture
    ~/Library/Application Support/Aperture

    These are both empty folders to start with and will be recreated when you load Aperture again. They both are used to hold Plug-Ins and the one in your Home folder contains different setting files that are created when you make settings in Aperture.

    If this sorts the issue, then you can restore any of the 'Plug-Ins' as needed, the rest of the files can be deleted as Aperture will recreate those.



    2 - If that does not help, then back when my username was 'CorkyO', I posted two rather long-winded comments at the link below concerning removing all trace of Aperture and then reinstalling (in this case it was for AP2):

    http://discussions.apple.com/thread.jspa?messageID=11110145


    One of the main points is running the Terminal command to view hidden files / folders and gain access to: '/private/var/db/receipts' and removing any files related to Aperture. This combined with the rest of the procedures should remove all trace of Aperture and allow you to start from scratch.

    Note - the procedures in #2 are only recommended if you have a system backup and have exhausted all other 'easier' options to resolve the problem. Since your problem seems to be Aperture related only, the removal of Aperture cache and support folders may resolve the issue.

    Good luck and remember to backup first.
  • 14. Re: Can not empty Aperture trash
    KB- Level 1 Level 1 (0 points)
    removing the Caches did not do the trick - I'm hesitant to remove all of the contents of the folders for fear of what it might do to other apps and things I'm working on. I did remove all aperture caches.

    I will try another clean install later. I did not remove all the invisible receipts before.

    I'll have to set this aside 'till next week or it will take over my life and work.

    This is frustrating. I do have good backups and have not done any real work with Aperture yet so have no fear of loosing pics. I discovered the problem just checking it out.
1 2 3 Previous Next