Previous 1 2 3 Next 40 Replies Latest reply: Oct 19, 2014 4:12 PM by BONAIRE SHARKB8 Go to original post
  • ryanesc Level 1 Level 1 (0 points)

    I am having a similar problem. It started after I paired a bluetooth headset for use with skype calls. Now, lion will periodically, without prompting or warning, switch the output and input audio device to the bluetooth headset and I will no longer hear any audio from my iMac speakers. And since my bluetooth headset is not always connected, I get the added insult of being interrupted by a an error dialog stating

     

    A Bluetooth audio error occurred.

    There was an error connecting to your audio device. Make sure it is turned on and in range. The audio portion of the program you were using may have to be restarted.

    Stop using headset

     

    In this case, it shouldn't have anything to do with the physical headphones jack as I do not use it at all. Apple, as this is happening many times a day, I'd really appreciate an acknowledgment of the issue and a fix.

  • THBofSF Level 1 Level 1 (0 points)

    I'd agree id has nothing to do with the headphone jacks in both our cases. I've plugged headphones into this machine maybe once in 2 years (and not recently).

     

    Since my reply last week and shutting off bluetooth I have not had a single incident, so I'm fairly sure that's the cause for me.

  • timotrocks Level 1 Level 1 (0 points)

    Hey guys,

    i think i've found the cause to our troubles.

    Today, i finally went to the apple store, and after checking it, the lady said that it is due to a faulty logic board (moterboard). It is a hardware issue and not a software issue. So, if your com automatically switches from internal speakers to headphones and digital out for no reason at all, you should really go to the shop to have your com checked out.

     

    Tim.

  • toni j. Level 1 Level 1 (10 points)

    Have you tried removing the device from your computer and re-pairing? This corrected the problem I was having with my macbook pro.

  • spicytim Level 1 Level 1 (0 points)

    This is going to seem... unorthodox, but hear me out. I've been having this exact problem in Windows 7. If this is a hardware problem then it doesn't necessarily matter which OS you're using because they may react similarly.

     

    Anyway, it just switched over to digital/sp-dif audio by itself again so I went looking for a solution, found this thread and after reading a couple of your posts I thought, "Well, if this is just the digital audio port thinking it's plugged in due to dust or something then I'll just disable it." Sure enough, after unplugging/plugging in the 3.5mm sound came back (which it wouldn't do before, it would require a restart) and I'm willing to bet it won't happen again with digital audio disabled, but we'll see.

     

    I don't know if you can disable the digital/optical audio port in OS X, but if you can it may cause it to ignore the optical switch and solve the problem. Otherwise the toothpick trick might be your last hope.

  • adamgx Level 1 Level 1 (0 points)

    I'm having this exact problem on 2010 macbook pro, toothpick didn't work.  Did anyone get anywhere with it? 

  • adamgx Level 1 Level 1 (0 points)

    In answer to spicytim's logical suggestion, it seems like disabling the digital audio output is unfortunately not an option in OS X: https://discussions.apple.com/thread/1439838?start=0&tstart=0

  • cjt823 Level 1 Level 1 (0 points)

    I habe this same problem!  The sound output continues to switch from bult-in output(ispk) to headphones...ive tried the toothpick thing and nothing works

  • DCMac101 Level 1 Level 1 (0 points)

    I was having the same problem. I plugged into the sound input jack, following the suggestion above (spicytim?) and another thread in the Apple support forum, and that took care of the problem for me. I have never used the headphone jack or the sound input jack, so maybe dust or movement was triggering some internal switch.

  • alexanderfromcalgary Level 1 Level 1 (0 points)

    I'm afraid it happened to me since I last updated something in my mac cause there was an update. I think I'm going to have to reinstall Mac OS but I'm saying you might have to do the same. However it wont me easy for you as you are not on mountain lion. Which means you can't easily repair it without Guarantee a loss of files.

    But it's one way to get it fixed. Another way is to through it into the apple genus and see if they can fix it at the apple store...

  • CombatVet070808 Level 1 Level 1 (0 points)

    I've googled and tried every method to fix this issue (just finished resetting the PRAM). out of desperation, I tried the "tooth pick" method; didn't work. For some reason, I got the urge to jam a few cotton swabs into the headphone jack, (the kind you use to clean your ears), and VOILA! the freakin thing worked. guess it DID just need to be cleaned. the digital output stopped switching back and forth and i've now got sound...so far so good. hope that did the trick. anyways, thought i'd share. good luck!

  • CombatVet070808 Level 1 Level 1 (0 points)

    nvm...went right back to malfunctioning. temporary "fix," I guess.

  • Ravara16 Level 1 Level 1 (0 points)

    ello to all.

    I also had the same problem.

    I tried to delete the file "AudioMIDISetup.plist" and nothing.

    I tried with the stick and nothing.

    I tried the stick and pull the jack and nothing.

     

     

    I decided to restart the mac. Press the option key. Select my partition where I have installed Windows 8.

    I went into Windows 8 and went to the properties of sound and was through there that decided everything. Her sound output devices all changed. When you put the headphones the speakers activated when pulled activating the digital output ... What I did was go deactivating and activating as would placing each output device in place.

     

     

    I went back to restart the mac, I went straight into Mac OS X 10.8 was settled and ready.

     

     

    I was pleased (by not having to spend money on a logic board), but I was sad because I solved the problem by one who has always been for me an "enemy."

  • alittlelight Level 1 Level 1 (10 points)

    Woke up to the same problem this morning. Got a toothpick and an alcohol swab, tore off a bit of the swab and wrapped it around the end of the toothpick then used that to clean out the port. It seems to be working again...for now.

  • Yoronivan Level 1 Level 1 (0 points)

    Having the same problem. Tried all of the above with no progress.

    If this is the Apple Support Community,

    where is the Apple support?