Previous 1 7 8 9 10 11 Next 308 Replies Latest reply: Feb 3, 2016 9:37 PM by vespasian76 Go to original post Branched to a new discussion.
  • Digitalclips Level 1 (0 points)

    Good work kitinji.


    What exactly is left out in safe mode that is enabling 16 GIGS in OS X I wonder?  Something that loads normally that isn't in safe Mode has to be the clue.  I wonder if comparing the boot files a 13" 2010 MBP that does work with a virgin installation on a 15" that doesn't might give yet another clue.

  • bfer Level 1 (0 points)

    Hi kitinje,


    good work!

    now, we just need someone to help us getting the 13" EFI and extensions. Anyone?

    Will Apple be kind enough to deliver a new EFI addressing this?

    follow the link and put your request:


  • swistak Level 1 (0 points)

    I would suggest trying to overwrite the stock spd table with the one that is identical to the stock memory (especially the memory timings!!!) I remember this has helped me a while ago when upgrading the blackbook ram

  • kitinje Level 1 (0 points)

    Thank you, this is a very good hint. I read that Thaiphoon burner is working on macbooks pro but it seems we will have to install windows first since it is a windows only application (and see if it boots with OWC modules).

    You know of any other software??

  • swistak Level 1 (0 points)

    combination of CPU-Z and SPD tool should do the trick.


    What I did is save the tables from the stock modules first and then write them to the new sticks one by one. Afterwards they have miraculously worked on the blackbook


    Was going to try it myself on my Mid-2010 2.8 MBP (I really don't see how it wouldn't work) but had no time...


    If it is any encouragement, your progress so far mimics 100% my experiences with black macbook - I could boot in safe mode and any other os than OSX, but normal boot would not work, unless the SPD tables defaulted to stock macbook settings.


    If that fails, my guess would be it's got to do with the built in, on CPU die memory controller - perhaps disabling integrated graphics (how?) would solve that? As far as I understand when OSX boots in safe mode, it disables quartz and all hardware graphics acceleration, looking into disabling the onboard graphics in nvram could also be helpful.


    Just make sure you back up your SPDs and double check everything you do, don't nuke your expensive RAM!


    [edit] Also, use thaiphoon burner to generate the new SPD and write it to your ram with SPDtool, that should help you ensure that you don't mess up the hex editing and removes one place where something could go wrong. Free version of thaiphoon allows you to generate new spds and write them to a file, but does not allow you to write them to the EEPROM, SPDtool however, can take the thaiphoon spd table and write it to the EEPROM just fine


    [edit #2] also, what is your macbook spec? It is probably unlikely, but perhaps there are differences between the CPU models??


    [edit #3] Also, have you tried -f flag for nvram? it forces the extensions cache to rebuild, could probably be useful?


    Apple have also released a SMC update just yesterday, perhaps that could change things?

    Please keep me updated, because I've been toying around with the idea of buying the cheapest DDR3 16gb kit and just messing around with it

  • bfer Level 1 (0 points)

    Hi kitinje, swistak,


    MacBook Pro mid 2010 i7 2.66, OSX 10.8.2. Did update the SMC and doesn't enable the 16gb but was able to boot with one 8GB module, after a few moments kernel panic... Thinks it may be possible to boot with one 8gb module to windows and do the programming.


    Do you have any positive progress to report?

  • kitinje Level 1 (0 points)



    No progress yet but im willing to try to overwrite the SPD table as swistak indicated. It will take me a couple of days because i have to free up some space for bootcamp and reconnect the optical drive that I replaced with an additional HD. For some reason Im unable to install windows on bootcamp using an external dvd-drive.


    I'll keep you updated!

  • kitinje Level 1 (0 points)

    Bad news,


    I read stock SPD and wrote down all the timings using thaiphoon burner.

    But i can't do the programming of the 8GB modules because i get a BSOD whenever i try to boot into windows. (It happens in safe mode and with just a single 8GB chip as well).


    How can we do the SPD flash?? Using 8GB chips I can boot into linux and into osx as well (using maxmem argument).

    Do you know of any SPD flashing software that does NOT require windows???

  • swistak Level 1 (0 points)

    What version of windows are you running? Have you tried win co? Perhaps you have access to another machine? I don't know of any unix spd flashing software

  • kitinje Level 1 (0 points)

    News again!!


    I was able to boot into windows with 12 GB (1x4GB + 1x8GB).

    # I could not boot with the 8 GB chip alone and not with both 8GB chips.


    I used thaiphoon burner. I verified the timings: the only difference was in

    tRFC where 8GB modules had 160T instead of 86T. I wrote the new SPD to the chip.













    And even more strange: CPU-Z reports 160T as the adopted tRFC so that should be equal to booting with both unmodified chips. I guess the system is using the highest tRFC of the 2 modules.


    that's weird.... what should i do??


    I was thinking about reflashing both but Im afraid of Mac not starting up.

    What do you suggest?? We could be close to a solution maybe?


    And what if I use higher timings???


    Your help is needed!

  • kitinje Level 1 (0 points)

    16 GB work in windows, but not on osx.

    And I correct what I stated before: 2x8GB Unmodified chips can boot fine in windows while single chips alone don't.



    These are the timings for both chips:




  • kitinje Level 1 (0 points)

    I could flash SAMSUNG 8GB 1066Mhz chips SPD (M471B1G73AH0-CF8) on OWC 8GB chips. It does not solve any problem. I can boot into Windows with 16GB but can't boot into OSX.

    I see no difference from stock timings: 7-7-7-20 and tRC 17. (only difference is tRFC 160T vs 86T, but i cannot post using 86T on 8GB chips).


    I did not flash stock SPD on OWC modules, cause it is likely that 8GB will not post or be recognized as 4GB chips. I also tryed to set higher timings: 8-8-8-24 but same result, Windows can boot, OSX is causing KP.

  • bfer Level 1 (0 points)

    Hi kitinje,


    excellent work.

    Well this takes us to the same point… boot.efi and/or kernelcache.

    thinking how to get this done. any idea if it is possible to edit the efi or the kernelcache?

    Ideas and positive suggestions are welcome!


    from Corsair CM3X8GSDKIT1066 Memory kit (2x4GB)


    Speed Rating

    PC3-8500 (1066MHz)

    SPD Speed


    Tested Speed


    Tested Latency


    SPD Latency


  • kitinje Level 1 (0 points)

    I believe that the main problem is likely to be the integrated intel graphics that cannot handle 8GB chips, while there should be no problems with NVidia GPU:


    - Windows boots fine with 16GB: it uses NVidia as default video card.

    - Same applies to other operating systems(Ubuntu).

    - When I use just a stick of OWC 8GB, i can boot untill the GUI is loaded, and it is pretty clear that there are some problems with the graphics:  flickering, and mouse not responding properly -> all this results in a KP after a while.

    - When we boot osx in SAFE mode, 16 GB are recognized but hardware accelerated graphics is disabled at boot: is not just because of the loaded kexts, smth else is going on.



    Is there a way to DISABLE integrated graphics at boot???? (i.e Kernel flags????)

  • Digitalclips Level 1 (0 points)

    Not sure if it acts at start up early enough in the boot process but there is an application called gfxCardStatus that can do this when running and can be set in users Log Items to start automatically.




    In addition attaching the MBP to an Apple external screen auto starts with the NVidia card.  I wish I'd thought of that before returning my 16 GIGs!

Previous 1 7 8 9 10 11 Next