Skip navigation

Macbook Pro (2010) 16gb memory

170867 Views 256 Replies Latest reply: Mar 19, 2014 5:04 PM by ThetaSigma312 RSS
  • Digitalclips Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2012 3:08 PM (in response to caseno7358)

    Wow, that surely does mean, as you say, the hardware is OK with it and it's something else going on here.  I hope someone sees your post and comes up with a patch for Mountain Lion to enable the extra RAM ...

  • hackintosh1800 Calculating status...
    Currently Being Moderated
    Dec 8, 2012 5:10 PM (in response to port77)

    Hey guys! I am new here and I have been grounging around with the 16gb in a 13" 2010 macbook pro issue too. :

     

    Here is what I have found:

     

    My 2010 mbp 13" started its life with 4gb of ram. I quickly purchased 8 and ran into the 1333mhz clockdown issue with the 320m... no biggie, exchanged it for 1066, works solid. Then, browsing ebay, i disovered that 16gb 1066mhz kits are about $54... I jumped on it.

     

    -I was running windows 7 64 bit and os x 10.6. Ram shipped, i immidiately took my computer apart, took it to the garage to give it a blow with the air compressor ( was getting dusty again, especially the fan), and plugged the ram in.

     

    First boot: os x begins booting, freezes. Thats it. **** it

    second boot: windows 7 fully boots, all 16gb are visible! great! runs, but freezes after 10 min. Repeat, same issue...damnit!

     

    Reinstalled my 8gb.

     

    So, i read about a recent EFI upgrade, so i got 10.8... so i could do it. Did the efi update.

     

    16gb in, windows begins booting, freezes. crap

     

    mountain lion kernel panic all over the screen. darn.

     

    I took one 8gb stick out, same as above.

     

    Now, this is where it gets interesting. So I thought, ok i ll rma the ram, but before that lets try a 8gb stick and a 4gb stick... bingo.

     

    Os x 10.8 boots no problem, runs stable. windows 7 boots no problem also stable.... So thus, the 2010 mbp is fully capable of 16gb of ram, its now up to apple, to remove the false restriction.

     

    12gb runs FINE. pic for proof.

     

    spec.jpg

  • caseno7358 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 9, 2012 11:48 PM (in response to port77)

    I knew I wasn't crazy for suspecting some kind of "programmed" limitation! I hope someone comes along and helps us out.

     

    Now my Toshiba Qosmio X305 with a Core 2 Duo is running fine with 8GB of RAM on 2 DIMMs, but when I even put in ONE of the 8GB DIMMs, it wouldn't even post to BIOS. This is a clear example of a simply hardware incompatibility. If the hardware physically doesn't support it, the motherboard won't even recognize it and the machine just won't power up, period.

     

    With the 16GB installed on my MacBook Pro, it still loads the EFI and everything. If our 2010 MacBook Pros didn't physically support the 16GB RAM, I doubt it'd even turn on.

     

    I also know that there is someone out there who's moral conscience is burning and now duty bound to reply to this with something like:

     

    "The 2010 MacBook Pro only supports 8GB RAM. Read your owners manual. If Apple wanted you to install 16GB RAM, they would have supported it. Using unauthorized RAM is not covered under AppleCare, etc... If you want more RAM, buy a new MacBook Pro" Yadda yadda yadda...

     

    Yes, I can read an owners manual and understand that what we're trying to do may not be supported officially by Apple.

     

     

     


  • hackintosh1800 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2012 7:18 PM (in response to caseno7358)

    I hope no one says that! I like having A GRAPHIC CARD, the main reason why I don't want any new 13" mbp.

     

    Anyways, its not a hardware incompatibility, its definately a soft block, as with different efi versions the computer behaved differently with 16gb.

     

    Also, my mbp is out of warranty, and looks and works like new.

  • caseno7358 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 11, 2012 8:52 PM (in response to hackintosh1800)

    I'm in agreement with you. I have a 17" MacBook Pro (which you can't even GET brand new anymore).

     

    This takes me back to just before I owned a MBP and ran Snow Leopard on my Toshiba Qosmio. That required EFI mods galore.

     

    I don't know much about EFI modding myself, but it'd be nice to see someone out there find an EFI mod around this soft block.

     

    Maybe there could be a DSDT mod or string injection to force support/recognition?

  • shavou Calculating status...
    Currently Being Moderated
    Dec 12, 2012 2:43 AM (in response to caseno7358)

    So guys...I got my 2x8GB and I tried to install them on my macbook pro early 2010 and nothing workerd. Actually the laptop does boot but it get stuck at black screen with many codes on that....

     

     

    Now, dear hackintosh1800, could you please explain me how to try with the EFI update?! The thing is that my laptop has already instaklled the latest EFI available so I think I am actually stuck!

     

    Please....guys help me!

  • stedman1 Level 8 Level 8 (49,850 points)
    Currently Being Moderated
    Dec 12, 2012 2:47 AM (in response to shavou)

    There is no "Early 2010 MacBook Pro" but the Mid 2010 model will only accept 8gB of RAM.

     

    Maximum Memory     8.0 GB

    Memory Slots     2 - 204-pin PC3-8500 (1066 MHz) DDR3 SO-DIMM

  • shavou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 4:44 AM (in response to stedman1)

    My dear stedman,

     

    first of all my macbook pro is an early 2010 model, or at least that's how Apple calls it (http://support.apple.com/kb/DL1492).

     

    Second, thanks for the information about the maximum ram supported by my mac but...do you think I wasn't aware of that?!  Would I write to a thread called "Macbook Pro 2010 16 GB memory" if I was not looking for extra help??!

     

    ..probably you have not even read the title of the thread...

     

    Thanks for your science anyway.

    Cheers*

  • Benjamin2102 Level 1 Level 1 (100 points)
    Currently Being Moderated
    Dec 12, 2012 4:51 AM (in response to macbig)

    macbig wrote:

     

    Your wasting your money. Your MacBook will only recognize 8GB.

    Thats not entirly true. I was recently reading somthing from some Highlevel in the community that MBP's are upradeable to 16GB of ram.  but you have to do it yourself.

  • shavou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 7:25 AM (in response to Benjamin2102)

    Dear Benjamin,

     

    could you please advise me on how to make my mac upgradable to 16gb of ram?!

     

    Thanks a lot in advance!

  • stedman1 Level 8 Level 8 (49,850 points)
    Currently Being Moderated
    Dec 12, 2012 7:54 AM (in response to shavou)

    Well good luck with your 16gB upgrade then.

  • caseno7358 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 12, 2012 9:16 PM (in response to stedman1)

    The Early/Mid 2010 MBP (you know, that one released in April 2010 or more specifically the MacBook Pro 6,1) OFFICIALLY per Apple ONLY supports 8GB of RAM.

     

    SO! Per Apple, the MacBook Pro 6,1 has a documented maximum capacity of 8GB of RAM. OFFICIALLY, this conversation should be over. Everyone here insisting that the MacBook Pro 6,1 only officially supports 8GB of RAM is 100% completely and totally correct.

     

    The issue hackintosh1800 and myself are discussing is not what Apple officially tells us the machine supports. We know that the MacBook Pro 6,1 only OFFICIALLY supports 8GB RAM. It was right there in our owners manuals when we bought the machines. It's in the support documentation. Several people here have generously reminded us of this right here in the forums.

     

    The issue we are talking about is whether this is a physical hardware incompatibility, e.g. the logicboard and chipset simply does not mathematically support the 2x 8GB RAM sticks I put in there, versus a soft block, e.g. the EFI was programmed by Apple to only allow a max of 8GB RAM. Similar to CPUs, kind of. Is the CPU limited to 2.0Ghz because it physically gets to hot and melts itself OR has it been limited to this speed by the BIOS and thus can be overclocked.

     

    More simply, let's say I have a car that cannot go any faster than 65mph. Is my car's speed limited because the engine simply is not powerful enough to go any faster OR has someone installed a speed limiter/governor. (the metaphors are endless here)

     

    Hackintosh1800 and myself have both successfully gotten the machine to turn on with one or both of the 2x 8GB DIMMS installed.

     

    I bought this: http://www.amazon.com/gp/product/B006DI9PG8/ref=oh_details_o00_s00_i00

     

    I couldn't get it to boot into Windows 7 or OSX with latest EFI, but I could boot into Fedora 17 and it showed 15.6GB RAM installed and had no problems. We're trying to determine if the machine is really just unable to accept 16GB RAM or has Apple purposely limited the machine to 8GB RAM. If the incompatibility is as simple as the hardware cannot accept 16GB RAM, then this conversation is futile. If it's a soft block, e.g. Apple simply does not want us to have 16GB RAM for whatever reason, then maybe the EFI can be unofficially modded to allow the machine to use it (someone out there is likely horrified at such a suggestion).

     

    The issue for me surround the installation of 16GB RAM seems to be Apple's hardware checking. On start up, Fedora 17 noted specifically that the installed RAM failed the EFI hardware check, but let me boot anyways and work without issue. It's 10:45PM CST and I don't feel like taking my MBP apart again to reinstall the 16GB RAM. I plan on returning the RAM to Amazon, but I could install it again and video what happens for show and tell I guess :-/

     

    For what it's worth, it is important to note that the RAM I purchased has a latency of 9-9-9-24 and limited to 1333mhz, the same latency of my 8GB RAM (2x 4GB DIMMS). I've read that even trying to install 8GB RAM at some latencies on our models have caused instabilities.

     

    My suspicions of a soft block from Apple actually begin with the current Corsair 8GB RAM I installed after I purchased it. The RAM was 8GB (2x 4GB DIMMS) clocked at 1333mhz. Interestingly, the documentation says that my machine supported a max clock speed of 1066mhz and, of course, OSX shows 8GB RAM installed, clocked at 1066mhz, BUT when I boot into Windows 7 Enterprise, it shows 8GB RAM installed clocked at 1333mhz. If the hardware supposedly only supports 1066mhz, then why does Windows clock my RAM at 1333mhz? Windose is a pissy OS. If my RAM is trying to run faster than the hardware supports, it would throw a BSOD and die.

     

    We're just expressing our concern that there might not be any physical hardware issue and the Apple Police may be just trying to play nanny with our machines.

  • ceejay3k Calculating status...
    Currently Being Moderated
    Dec 13, 2012 8:26 AM (in response to caseno7358)

    Have you tried the 12gb method? Putting 1 8gb module and 1 4gb module and seeing if the Apple OS would boot then?

  • caseno7358 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 13, 2012 9:44 AM (in response to ceejay3k)

    I have not, but I'm willing to.

     

    It almost seems like the more I unscrew the bottom cover, the looser these dang screws get :-)

  • hackintosh1800 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 8:54 PM (in response to stedman1)

    How dense are you? I clearly said I am running 12gb as of my last post WITH NO CRASHES OR ERRORS, on a 2010 mbp. So it clearly is NOT a hardware issue.

     

    If you can't do anything but quote mfg specs, please don't post. I am very well aware what apple says, and I am also very well aware of what OEM intel chipsets ( like the one inside a mbp) support.

     

    Now, to get both 8gb modules running, does anyone know if its possible to say flash the hardware id on the ram to a 4gb module while retaining full 8gb in operation?

1 ... 3 4 5 6 7 ... 18 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.