14 Replies Latest reply: Dec 22, 2005 9:34 AM by Tom Graves
R_Man Level 1 Level 1 (0 points)
I have been unable to display images/picture when visiting Forums run on vBulletin e.g. www.mbworld.org. The same problem occur when using Safari, or Firefox or I.E 5 for Mac. I know this is not the website or my Internet Provider problem as I have no problem viewing/displaying images from my PC, which is connected through the same network.
Could it be something on security/firewall that I may have accidental switched on or off?

PowerBook G4, Mac OS X (10.4.3)
  • Tom Graves Level 7 Level 7 (20,615 points)
    Hi, welcome to Apple's user-to-user discussion forums.

    I see images in the posts in the mbworld forums using Safari 2.0.2, Firefox 1.5, and IE 5.2.3 under OS X 10.4.3.

    I do remember someone complaining about not seeing particular images in mbworld forum posts. It turned out that the posts contained dead links to those images (the images are stored on sites such as PhotoBucket and Flickr).

    Are you not seeing any images in the mbworld forums? Can you give a link to other forums you are having this problem with?

    Have you tried using these forums in a new user account? If not, do so to see if your problem is account or system related. To create a new account, open System Preferences and click on Accounts. You may have to click on the padlock and give your admin name and password to create an account. Click on the plus sign in the lower right corner to create the new account. I see no reason to give it a password. You can delete this account later using using the minus key, although I have kept my second account to use for testing (the user folder only takes up 32 kb).
  • R_Man Level 1 Level 1 (0 points)
    Thanks for the reply and advice. I did not reply immediately to your post as I live on the other side of the world. I thought I would not get any reply at all.
    I have taken your advice and enter the Forum using a newly created user account. Still have the same problem. FYI, I normally go to the "Picture thread" in the forum to view images that was posted. I know its not a dead link issue as I can see those photos from the PC in my office (I would not want to do that too often). The images that I could not view are only those that is attached in the postings (not images on the top part of the Forum or images of the sender). The posting just appear blank (not red"x" or blue"?" displayed).

    However, your advice does help. At least (I think), now I know its not an issue with my Powerbook. BTW I use Safari 2.0.2, Firefox 1.0.7 and IE for Mac (there's only that one outdated version).
    I did not mention that I access the internet through a home-network using Airport Express. I will try to fiddle with the set-up to see whether theres a problem there.

    I have also searched the vBulletin website and other google search to find an answer but still no luck.
  • Tom Graves Level 7 Level 7 (20,615 points)
    No problem on the time it takes to get back to anyone in these forums - everyone has their own time zone, work schedule, etc.

    I have not fully explored the mbworld site and I do not see the Picture Thread. To save time, can you tell me where the it is, or copy the url and past it in a reply?

    The fact that images are not showing up in a new, clean user account indicates that the problem is at the system level, and not just a problem with a configuration in your user account. I want to look at the picture thread you mentioned first before thinking of what to do next.

    Also, the problem is obviously not browser specific because you are having the problem with all three browsers you tried.

    I also connect to the Internet using a wireless connection. That shouldn't be a problem, especially if you are not having problems with other web sites. If you want, you can reset your modem and router/access point. Unplug them both and then, after a minute or so, plug the modem in first and then the router/access point. If your access point is also an ethernet router, you could connect your computer to it using an ethernet cable to bypass and potentially rule out the wireless connection as well.
  • R_Man Level 1 Level 1 (0 points)
    http://www.mbworld.org/forums/showthread.php?t=3385

    Also, I've tried to access the same site using IE, with "scripting error alert enabled" (Preferences, Web Browser, Web Content, Active Content...). There seems to be a lot of Java Script error reported displaying the above thread. Dont know whether this is relevant to the problem of displaying images.
    Thanks.
  • Tom Graves Level 7 Level 7 (20,615 points)
    Just a quick update to let you know I am having problems with the thread you linked to in both Firefox and Safari. I will look into it and see what I can find and post back later.
  • Jpfresno Level 4 Level 4 (3,020 points)
    Hi R_Man,

    You're working w one of the pro's; thanks be to Maestro's who devote their spare time to those of use w less knowledge or w faster draining memory banks.

    FWiW: I got "Page not found ..." when clicking on 2 of the jpegs.
  • Tom Graves Level 7 Level 7 (20,615 points)
    The topic you link to opens up to the oldest posts first. These posts are from 2002 and it looks like most of the people no longer have the photographs where they were when they made the original posts. There are a couple of photographs visible, showing that some of the links are still valid. When I jump to the Last page, I see photographs for all the recent posts.
  • R C-R Level 6 Level 6 (16,590 points)
    In Safari's "Activity" window (Window menu -> Activity) you can see all the items it tries to load to build a page, with either their file size or an error message. This page generates several "not found" errors & one "Can't connect to host" error for image files, confirming the earlier conjecture about broken links.

    I guess it is possible these images were cached on the PC, explaining why you could see them there.

    The Activity window is a nice feature of Safari. It shows you the IP address of each item it tries to load. You can even double-click an item & Safari will try to open it by itself in a new window.
  • Tom Graves Level 7 Level 7 (20,615 points)
    Thanx for mentioning that the images are probably cached on the pc. I didn't mention that and it does seem to make the most sense as to why they are appearing there.

    Yes, the Activity Window is very nice and useful. You can also download components using the Activity window by Option-Double Clicking on what you want. I still wish that Safar had a Properties window for pages similar to Firefox and some other browsers. They include information that you cannot get from the Activity window.
  • R_Man Level 1 Level 1 (0 points)
    Gee thanks for the tip. I've never use the activity window before.
    I guess the old cache must have been the reason for the PC being able to display those images. I have no access to my work PC right now, so I could not verify yet. And at the same time, right now I'm getting the "unable to connect" to that website, so I am going to leave the issue here.
    Just for information, this is my second try replying to this post cause I just had a crash report from Safari. I had only this page open on Safari and a page on Firefox when the crash happened. The top part of the crash report is at the bottom of this post.
    Also just to mention, that the vBulletin posting is slightly wierd, in that some of the images does not come with a link! It is normally displayed directly below the messages (in Safari, right clicking the message area does not result in any indication that there's an image, i.e. it is not really attached?). Am I making sense here?
    Thanks anyway.

    "Date/Time: 2005-12-23 00:27:02.396 +0800
    OS Version: 10.4.3 (Build 8F46)
    Report Version: 3

    Command: Safari
    Path: /Applications/Safari.app/Contents/MacOS/Safari
    Parent: WindowServer [69]

    Version: 2.0.2 (416.13)
    Build Version: 1
    Project Name: WebBrowser
    Source Version: 4161300

    PID: 223
    Thread: 0

    Exception: EXCBADACCESS (0x0001)
    Codes: KERNINVALIDADDRESS (0x0001) at 0x6f724672

    Thread 0 Crashed:
    0 <<00000000>> 0xfffeff20 objcmsgSendrtp + 32
    1 com.apple.WebKit 0x9544cbfc -[WebFrame(WebPrivate) _checkLoadCompleteForThisFrame] + 308
    2 com.apple.WebKit 0x9549fcb0 -[WebSubresourceClient signalFinish] + 76 "......
  • R_Man Level 1 Level 1 (0 points)
    Something unrelated to the topic, but the Mac is selling like hot cakes! Just been in one of the local distributer to find out about an iMac G5, they are out of stock until next year! My friend who is looking for a Mac mini also could not get his hand on a Mac mini! He tried to find one from other distributers (theres only like 2 or 3 local distributers), all could not offer one!
  • Tom Graves Level 7 Level 7 (20,615 points)
    Also just to mention, that the vBulletin posting is slightly wierd, in that some of the images does not come with a link! It is normally displayed directly below the messages (in Safari, right clicking the message area does not result in any indication that there's an image, i.e. it is not really attached?).


    The difference is caused by how the poster coded his post. He could have used in "img" tag to show the image in the post or he could have provided a link to the image.

    An inline image:


    And here is a link to the same image.
  • R_Man Level 1 Level 1 (0 points)
    Thank goodness I could view that in-line image you posted. So that must have solved my question, I can view the image, the problem I reported has nothing to do with my set-up, but website related.
    Sorry if I had taken too much of your time. Thanks.
  • Tom Graves Level 7 Level 7 (20,615 points)
    You are very welcome, and, no, you did not take up too much of my time. That's what these forums are for.