Previous 1 2 Next 25 Replies Latest reply: Apr 3, 2012 2:57 PM by johankytt
Ivanthehackerful Level 1 Level 1 (0 points)
I have just installed xcode 4 on my MacMini. I am new to developing and just today have started learning objective c. when i open xcode 4 it gives me an error:

Internal Error

Xcode encountered an internal logic error. Choose "Continue" to continue running Xcode in an inconsistent state. Choose "Crash" to halt Xcode and file a bug with Crash Reporter. Choosing "Crash" will result in the loss of all unsaved data.

and also when i click on the show details button it gives me this:

ASSERTION FAILURE in /SourceCache/DVTFoundation/DVTFoundation-215/Framework/Classes/PlugInArchitectu re/DVTPlugInManager.m:215
Details: (extensionPoint) should not be nil.
Object: <DVTPlugInManager: 0x2000a3c20>
Method: -_extensionsForExtensionPoint:matchingPredicate:
Thread: <NSThread: 0x200020600>{name = (null), num = 1}
Hints: None
0 0x000000010092e613 -[IDEAssertionHandler handleFailureInMethod:object:fileName:lineNumber:messageFormat:arguments:] (in IDEKit)
1 0x000000010006d974 _DVTAssertionFailureHandler (in DVTFoundation)
2 0x000000010001b2b7 -[DVTPlugInManager _extensionsForExtensionPoint:matchingPredicate:] (in DVTFoundation)
3 0x000000010001b23d -[DVTPlugInManager sharedExtensionsForExtensionPoint:matchingPredicate:] (in DVTFoundation)
4 0x0000000100a2a771 __61+[IDEDocumentController THREAD_allOrganizerSourceExtensions]_block_invoke0 (in IDEKit)
5 0x00007fff889bbc65 dispatchoncef (in libSystem.B.dylib)
6 0x0000000100a2a704 +[IDEDocumentController THREADallOrganizerSourceExtensions] (in IDEKit)
7 0x0000000100a2b162 +[IDEDocumentController _organizerSourceExtensionForDocumentType:] (in IDEKit)
8 0x00000001009286f0 -[IDEApplicationController _openFiles:] (in IDEKit)
9 0x00007fff81c0f9d6 -[NSApplication(NSAppleEventHandling) _handleAEOpenDocumentsForURLs:] (in AppKit)
10 0x00007fff81adc00d -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] (in AppKit)
11 0x00007fff82e78f62 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] (in Foundation)
12 0x00007fff82e78d92 _NSAppleEventManagerGenericHandler (in Foundation)
13 0x00007fff8841a323 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) (in AE)
14 0x00007fff8841a21c dispatchEventAndSendReply(AEDesc const*, AEDesc*) (in AE)
15 0x00007fff8841a123 aeProcessAppleEvent (in AE)
16 0x00007fff86e45765 AEProcessAppleEvent (in HIToolbox)
17 0x00007fff819e104b _DPSNextEvent (in AppKit)
18 0x00007fff819e07a9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (in AppKit)
19 0x00007fff819a648b -[NSApplication run] (in AppKit)
20 0x00007fff8199f1a8 NSApplicationMain (in AppKit)
21 0x0000000100000eec

Can anyone help? Or can they at least tell me the problem. Thanks, Ivanthehackerful.

MacMini, Mac OS X (10.6.6), iOS 4 iPod Touch 3rd Generation, MacBook Pro 5G.
  • Bob Lang1 Level 5 Level 5 (4,080 points)
    Hi Ivan

    Like all complex applications, Xcode sometimes has its wobbles, but they usually go away if you close down Xcode and restart it. If you continue to get problems every time you run Xcode then if can often be fixed by cleaning the cache files.

  • Ivanthehackerful Level 1 Level 1 (0 points)
    Hi Bob Lang1, I am a complete beginner at Xcode and was wondering, how do i clear Xcode's cache. It won't run properly. When I go to Xcode, it comes up with the error. I click on continue 3 times and then click on the Xcode icon and it comes up with the screen at the beginning. I select one of my projects and suddenly that window disappears and when i click on the Xcode icon again it goes to the same window. Also in the status bar at the top, there is no File, Project, or anything like that. All there is is the Apple logo and Xcode. And also, when I click on the Xcode in the status bar, nothing happens, although it is definitely highlighted.

    So, what do I do now. I have a backup of the Xcode installation file burnt to a cd just incase I need to reinstall Xcode.
  • Bob Lang1 Level 5 Level 5 (4,080 points)
    Hi Ivan

    You can clear the caches manually, see:

    Or you can use Snow Leopard Cache Cleaner (very cheap shareware, with a long free trial period), or Onyx (free) to do it for you. Google will find both of these applications.

    If that doesn't work, then I'd delete the preferences file (~/Library/Preferences/

    If that doesn't work, then I'd de-install all developer tools, download a new clean version and re-install.

    Good luck

  • Axello Level 1 Level 1 (0 points)

    With me all the above (cache-flush, preferences-purge) didn't help.

    What DID help in the end was removing the 'xcuserdata' from the XCode project package. Apparently there were some corrupt user-dependent setting there.

  • Tim Fall Level 1 Level 1 (65 points)

    I just upgraded to Lion and upgraded to Xcode 4. Everytime I open Xcode 4 I get the same "Xcode encountered an internal logic error. Choose "Continue" to continue running Xcode in an inconsistent state.  Choose "Crash" to halt Xcode and file a bug with Crash Reporter. Choosing "Crash" will result in the loss of all unsaved data." error.


    The details show a problem with "iPhonePlaceholder". Could this be something from the older version?


    UNCAUGHT EXCEPTION (NSInternalInconsistencyException): Couldn't load plug-in '' while firing fault for extension 'Xcode.Device.iPhonePlaceholder'

    UserInfo: {

        NSUnderlyingError = "Error Domain=DVTPlugInErrorDomain Code=2 \"Loading a plug-in failed.\" UserInfo=0x40015aa80 {, DVTPlugInExecutablePathErrorKey=/Developer/Platforms/iPhoneOS.platform/Develope r/Library/Xcode/PrivatePlugIns/IDEiPhoneSupport.ideplugin/Contents/MacOS/IDEiPho neSupport, NSLocalizedRecoverySuggestion=The plug-in or one of its prerequisite plug-ins may be missing or damaged and may need to be reinstalled., NSLocalizedDescription=Loading a plug-in failed., NSFilePath=/Developer/Platforms/iPhoneOS.platform/Developer/Library/Xcode/Priva tePlugIns/IDEiPhoneSupport.ideplugin, NSLocalizedFailureReason=The plug-in \\U201d at path \U201c/Developer/Platforms/iPhoneOS.platform/Developer/Library/Xcode/PrivatePlu gIns/IDEiPhoneSupport.ideplugin\U201d could not be loaded.  The plug-in or one of its prerequisite plug-ins may be missing or damaged., NSUnderlyingError=0x40039d3a0 \"The bundle \U201cIDEiPhoneSupport\U201d couldn\U2019t be loaded because it is damaged or missing necessary resources.\"}";


    Hints: None


      0  0x00007fff8290c96a __exceptionPreprocess (in CoreFoundation)

      1  0x00007fff8a074d5e objc_exception_throw (in libobjc.A.dylib)

      2  0x00000001007c9c98 -[DVTExtension _fireExtensionFault] (in DVTFoundation)

      3  0x00000001007b47f9 __38-[DVTDispatchLock performLockedBlock:]_block_invoke_0 (in DVTFoundation)

      4  0x00007fff89599afd _dispatch_barrier_sync_f_invoke (in libdispatch.dylib)

      5  0x00000001007b47a9 -[DVTDispatchLock performLockedBlock:] (in DVTFoundation)

      6  0x00000001007c9a45 -[DVTExtension _valueForKey:inParameterData:usingSchema:] (in DVTFoundation)

      7  0x00000001007c99ab -[DVTExtension valueForKey:] (in DVTFoundation)

      8  0x00000001007c9167 +[DVTDevice _knownDeviceLocators] (in DVTFoundation)

      9  0x00000001007c8cea -[DVTDeviceManager startLocating] (in DVTFoundation)

    10  0x0000000100cfe07a IDEInitialize (in IDEFoundation)

    11  0x0000000101072c0b -[IDEApplicationController applicationWillFinishLaunching:] (in IDEKit)

    12  0x00007fff89d42716 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 (in Foundation)

    13  0x00007fff828b551a _CFXNotificationPost (in CoreFoundation)

    14  0x00007fff89d2e9cb -[NSNotificationCenter postNotificationName:object:userInfo:] (in Foundation)

    15  0x00007fff8111d6c8 -[NSApplication finishLaunching] (in AppKit)

    16  0x00007fff8111d27d -[NSApplication run] (in AppKit)

    17  0x00007fff8139b52a NSApplicationMain (in AppKit)

    18  0x00000001007aceec (in Xcode)

    19  0x0000000000000002

  • Tim M. Moore Level 1 Level 1 (5 points)

    I also had the "iPhonePlaceholder" crash. Trashing the "/Developer-old" directory and re-running the Xcode installer seems to have fixed it.

  • Tim Fall Level 1 Level 1 (65 points)

    I'll give that a try.


    I get the feeling that the installer tries to pull in configuration and other files from previous Xcode versions when it runs. Trashing the old install and re-installing may make it use a fresh install. Wouldn't that make it not carry over the previous configuration files?

  • Tim M. Moore Level 1 Level 1 (5 points)

    I wouldn't expect it to store any configuration directly in the /Developer directory (should go under /Library or $HOME/Library) but I can't be sure. I really only use Xcode for building with homebrew, and don't have any Xcode projects or configuration that I needed to keep.

  • Tim Fall Level 1 Level 1 (65 points)

    I agree that it is unlikely there are configuration files stored there. What I was assuming might be possible is that the presence of the /Developer directory might cause the Xcode 4 installer to assume that a previous version was installed (and therefore do additional tasks). I don't know if this is the case.



    In any event, removing /Developer-old and reinstalling has cleared the error.

  • Dave Sag Level 1 Level 1 (0 points)

    I'm getting this exact same error.  Will try zipping my old dev folder and nuking prefs etc and let you know how that goes.  Nice work Apple.

  • Dave Sag Level 1 Level 1 (0 points)

    Deleted the old xcode and the new one and reinstalled from scratch and now it works.

  • kwispy quitter Level 1 Level 1 (0 points)

    I had those files missing too.. I installed the latest iTunes, and got Xcode to work!

  • Andreas Schuderer Level 2 Level 2 (215 points)

    I had the same problem and typed in Terminal:


    sudo tmutil disablelocal

    sudo /Developer/Library/uninstall-devtools --mode=all

    sudo /Developer-3.2.2/Library/uninstall-devtools --mode=all

    sudo tmutil enablelocal


    Then I deleted the folders "Developer" and "Developer-3.2.2".


    Then I reinstalled xcode using the installer on the launchpad. Now it works.


    P.S.: The first and last line disable and re-enable local snapshots (a feature of time machine). I had the problem that the mtmd proces claimed a whole core and caused my macbook pro to heat up enourmously. The tmutil commands fixed this. The third line was necessary because xcode installer had made a backup of my previous xcode version. Leave this line out if not applicable.

  • cragini Level 1 Level 1 (0 points)

    Thanks, Andreas.  Same problem, and your instructions worked for me.

Previous 1 2 Next