Previous 1 2 Next 18 Replies Latest reply: May 16, 2011 2:17 PM by Old Toad
Nick Rooney Level 1 Level 1 (30 points)
Upgraded from '09 to iPhoto '11 (from the retail package) on a 24" iMac 2.16GHz. It was slow, buggy and crashy. Every time I opened iPhoto it made my computer completely unusable. Most times I would have to just press the power button as nothing would work.

I decided to do the rebuild due to suggestions from this forum.

I held option+cmd when starting iPhoto and checked every box. That was about 2 hours ago. It has been sitting at the "Rebuilding Library Database" popup for the last hour or so. The progress bar is blank with "Rebuilding Library: 29289 Versions restored." above it. A wheel is spinning in the iPhoto main window.

I'm very worried about holding the power button down, but I don't think anything is happening.

24" iMac 2.16GHz, Mac OS X (10.6.6), Apple TV, 1G+2G Shuf, iPod Mini, iPhone 4
  • Old Toad Level 10 Level 10 (128,745 points)
    How large is your library? A full rebuild can take a while if you have lots of photos. You do have a backup copy of your iPhoto 09 library that you can fall back to if this rebuild crashes and burns, right?



  • Gary Gamble1 Level 1 Level 1 (5 points)
    Nick,

    Sorry to tell this to a fellow Texan, but if you have the White 24" iMac with the NVIDIA 7300 Graphics Card, there is no solution except to revert to iPhoto 8.1.2 (iLife 09). We have been at this since November and Apple will not fix the problem with iPhoto 9.1.1.

    Gary
  • Nick Rooney Level 1 Level 1 (30 points)
    You've got to be kidding me. No I do not have a backup. I did, but then Time Machine decided to erase everything - yes, everything - on my backup drive a couple days ago. So now I'm really in a bind.
  • Gary Gamble1 Level 1 Level 1 (5 points)
    Nick,

    You might want to search the threads regarding recovery from the from the Master folder residing in the Picture folder on 9.1.1. You might also note Terence Devlin's recommendation of iPhoto Library Manager and its "rebuild" function. It worked great for me, but your first priority should be using a backup for what exists, then the recovery of your pictures, if possible.

    Gamcom
  • Old Toad Level 10 Level 10 (128,745 points)
    There's a very good chance that your photos are safe and sound inside the iPhoto Library package.

    First Control-click on the library and select "Show Package Contents" from the menu.
    Next open the Masters folder and check its subfolders to see if your photos are there. If they are there then you can try the iPhoto Library Manager rebuild suggestion. If that doesn't work you'll have to start from scratch with a new library as follows:


    1 - launch iPhoto with the Option key depressed and create a new library.
    2 - drag the Masters folder from you current library into the open window of the new window.


    You will still have your original library for additional fix attempts. If you have an external HD you can use a backup application like Synk or Synk Pro to make +incremental backups+ to your library as many times a day as you see fit. After the first full backup only those new or changed files will be copied. It very fast. There are several backup applications that can do incremental backups. Just Google or search at MacUpDate.com for backup.

    Did you check the Time Machine forum regarding your TM problem?
  • Nick Rooney Level 1 Level 1 (30 points)
    Thank you all for your help. Here is what I've figured out:

    My photos are safe. They are in the iPhoto '11 library.
    The problem is iPhoto '11 causes my system to freeze up when running.
    I can't rebuild for that problem.
    The freezing up is related to the graphics card overheating as stated above.

    In a nutshell: I either need to start my library over with iPhoto '09, Aperture 3 or buy a new Mac. None of those sound exciting to me.
  • Old Toad Level 10 Level 10 (128,745 points)
    Nick:

    Keep pummeling Apple with bug reports on this. It is widespread and pressure has to be brought to bear on the developers to find and apply a fix.


    Let Apple know via http://www.apple.com/feedback/iphoto.html, everyone who's experiencing this problem. I'm sure Apple is aware and working on the problem but it can't hurt to keep them appraised of yours and others concern.

    Message was edited by: Old Toad
  • Gary Gamble1 Level 1 Level 1 (5 points)
    Old Toad,

    Your responses have been terrific for all of us, and certainly appreciate your input, but there appears to be no solution to the problem with the iMac (White) and graphics card from NVIDIA. The engineers have all of our information for a very long time.

    Apple will NOT take responsibility for compatibility with 9.1.1. A new replacement graphics card? I think NOT. A new firmware fix? I think NOT. If the engineers have not solved this problem since last November, do you really think a fix is coming. NOT. Aperture, or a new computer is the only solution if you want to keep moving forward. If NOT, then stay with 8.1.2.

    I will be replacing my old friend, the white relic in the near term.

    Thanks again,

    G
  • Old Toad Level 10 Level 10 (128,745 points)
    We can only hope. I have no idea how long it would take to create a firmware fix. There is probably a lot of negotation going on between apple and NVDIA regarding who's at fault, etc. It is a crappy situation.

    If I were in that situation I'd get the originals (now called Masters) out of the iPhoto 11 library and create a new iPhoto 09 library and work with that till a solution is found. Done right, when a fix is found one could fixe the existing iPhoto 11 library and import just those new photos that were added to the iPhoto 09 library and thus save the keywords, etc. from the 11 library.
  • Andrew Mitchell Level 1 Level 1 (5 points)
    "In a nutshell: I either need to start my library over with iPhoto '09, Aperture 3 or buy a new Mac. None of those sound exciting to me."

    Couldn't agree more, but some suggestions for you:

    Option 1: start over with iPhoto '09. This is what I did, and now that I'm over the shock of what Apple did to my computer (and me), I'm quite happy. Quite a lot of information was still there (keywords, surprisingly!), but no folders and smart albums, and no MobileMe Gallery. The Gallery just needed rebuilding, though, and it was back again. But, you know, my '09 (22,000+ photos) needed a good cleaning out anyway! I'm having quite a lot of fun re-doing bits and pieces. I'm using Keyword Manager, which is so much faster than '09's keyword feature. I'm not sure that I would "up" to '11 now, even if they fixed it for us (which I don't think they will ever do - we are the forgotten - they can't even post a "we are working on it" somewhere? Shameful.)

    Option 2: Aperture. Don't, as your computer doesn't have the guts to run the program. Been there, tried that. Constant spinning balls and occasional crashes. Looked very nice on the few occasions it worked, though. Lightroom will work fine on your machine, however.

    Option 3: new Mac. I agree; I'm very fond of my white beast and have no plans (or money) to buy another just because Apple dumped a program on us without checking it first. I don't think of my machine as "old" at all, so why should they?

    Conclusion: take a deep breath, bite the bullet, follow the instructions posted for reverting to '09, and jump back into '09. In a few weeks, all will be calm again.

    Good luck!
  • Nick Rooney Level 1 Level 1 (30 points)
    There is hope folks!

    Took old faithful to the genius bar today... and iPhoto '11 is working like a champ!

    The tech said it shouldn't be the graphics card, since everything else is running fine. He booted up into the "root" prompt (never seen before so don't know technical name). Ran some hard drive restore things and there were some errors that could not be fixed through Disk Utility.

    The issue with iPhoto '11 was, upon opening, it started consuming 110-114% of the CPU (verified in Activity Monitor). This is what caused everything to come to a screeching halt and freeze.

    He ran the above stuff after trying to rebuild the library.

    After that iPhoto was consuming about 4% of the CPU. Needless to say, it was humming along like it was original software.
  • Gary Gamble1 Level 1 Level 1 (5 points)
    Nick,

    Do you recall exactly the steps taken by the Genius Bar? I would like to follow up, since this has been a problem since last November, with no solution coming from Apple. We are running the same White iMac 24.

    I wonder if the 9.1.1 problem has anything to do with my running Parallels/Windows 7. Unlike previous post, I am running 8.1.2, along with Aperture (leaving files in "current position), and both app's are running just fine. Have over 22,000 pic's in the library. Everything else running AOK.

    Thanks for your response.

    Gary
  • Nick Rooney Level 1 Level 1 (30 points)
    I don't know exactly what was done since I don't know what all he was doing, but I was watching and can give you a good idea of what was done. Hopefully you (or someone) knows the technical terms.

    1. Tried to rebuild iPhoto library (only first box checked on the pop-up).
    2. Waited a couple minutes and force quit iPhoto, then reopened.
    3. Opened Activity Monitor to see what CPU % was being used by iPhoto.
    4. I told him I had done "Repair Disk Permissions" in Disk Utility, so he didn't try that.
    5. He put a thumb drive in and went to an app with the Smart Car as the icon, that said "SMART" on it. I have no clue what that did.
    6. Rebooted the computer to a black screen with white text that came to a "root#" prompt (I think it was root#). Reminded me of the C:/ prompt on a PC.
    7. Typed in something like "fksk - chk" (that's wrong, but something like that).
    8. That started a deep repair on the hard drive. He said this does more than "Repair Permissions" or "Repair Disk".

    *NOTE: he had to use the original iMac keyboard and mouse, since the root screen only operates devices with drivers that were originally installed back in 2006 (for my Mac anyway). The new keyboards would not work.*

    9. It got done, and it froze up when trying to restart, so he held the power button down.
    10. He started Activity Monitor again, started iPhoto, and all was well.
    11. Opened the SMART app from his thumb drive again (still not sure what it did).

    He said going home and doing an erase on the Mac, and reinstalling from my Time Machine backup would lessen the chance of this happening again. I've done that, and everything seems to be running great. He said that could have been done and it would have fixed the issue without all of the above steps.

    If you plan on doing that, know that you should de-authorize and deactivate apps like iTunes, Photoshop, etc.
  • Old Toad Level 10 Level 10 (128,745 points)
    What the Genius did was boot into single user mode, Mac OS X: How to start up in single-user or verbose mode, and run the File System Check, fsck, which is a command-line utility to verify and repair a disk. More about fsck can be found in this Apple document: Resolve startup issues and perform disk maintenance with Disk Utility and fsck.

    Here's how I go about running the File System Check from the Single User Mode:


    To start up in single-user mode

    1. Restart the computer.

    2. Immediately after the startup sound, press and hold both the Command (⌘) and "s" keys on your keyboard. The computer will display a series of text messages, at which time you may release these keys.

    When the computer has started up, it will display a command line prompt (#). The computer is now in single-user mode.

    How to Run the File System Check from the Command Line

    Once you have reached a command line, follow these steps to use fsck:

    1. At the prompt, type: fsck -fy (NOTE, there is a space between the k and the “-”)
    The fsck utility will go through five "phases" and then return information about the disk's utilization and fragmentation. Once the check is finished, if no issue is found, you should see "** The volume <name of volume> appears to be OK."

    If fsck alters, repairs, or fixes anything, it will display the message:

    **** FILE SYSTEM WAS MODIFIED ***

    2 - IMPORTANT: If this message appears, repeat the "fsck -fy" command until this message no longer appears. It is not unusual for your computer to require several "passes" of fsck, because first-pass repairs may uncover additional errors. Run it until you get two consecutive times with an "OK" result.

    3. When fsck reports that no problems were found, type: reboot

    4. Press Return.




Previous 1 2 Next