Previous 1 2 3 4 5 6 Next 348 Replies Latest reply: Nov 6, 2011 6:28 AM by MAW01 Go to original post
  • NickMac77 Level 1 Level 1 (0 points)
    No joy with iOS 4.3 I'm afraid. The songs on my iPhone now show up as a share in iTunes and I can play them on my Mac. However, the remote app just will not connect to the library on my Mac. It can see it, just refuses to connect.
  • sftobos Level 1 Level 1 (10 points)
    Well it is broken again. All worked great for a 1/2 hour then I updated the ATV 2. All continued to work well. I was able to see library on ATV and I could stream music to the ATV as well as movies. I streamed a movie from my Iphone to my ATV still no issues.

    I then went upstairs to test the ITUNES stability and quit Itunes and restarted it. Boom. All is broken again.

    So it has something to do with ATV leaving a port open. It is as simple as that. I just can't figure it out.
  • Gpuck Level 1 Level 1 (0 points)
    Had this same issue, followed this article and rebuilt my library problem solved. http://support.apple.com/kb/ht1451
  • NickMac77 Level 1 Level 1 (0 points)
    Gpuck you are a star! That has worked a treat, the Remote app is working fine again.

    It must have been the transfer of my old library from my PC to the Mac that caused the problem. Weird, because it played and looked fine in iTunes itself.

    I have lost some cover art, but I can live with that, it'll keep me out of mischief putting it back.

    Many thanks, you've saved me so much pain!
  • jklick Level 1 Level 1 (0 points)
    Spent another hour on the phone with Apple Care tonight and sent a data capture image to the Apple software engineers. They told me to check back in 48 hours.
  • NickMac77 Level 1 Level 1 (0 points)
    Actually no, spoke too soon... ;(

    Worked fine for about 10 minutes, now playing up again.

    Can't be just because I've downloaded some cover art. This is driving me mad.
  • Pete Kroner Level 1 Level 1 (10 points)
    Just got my Macbook Pro and it still is charging. I'm looking forward to flawless performance from it!
    On the other hand what should i expect since I'll continue to use my G5 which supports an Apple TV1 AND an Apple TV 2 on different TVs with a Airport Extreme? Can I use two macs on the same Apple TVs?I'm almost afraid to try...
  • sftobos Level 1 Level 1 (10 points)
    Nick. I feel your pain. Works for minutes and you think you are home free then boom it crashes. I have lost my mind over this. At least Apple is asking for the data.
  • sftobos Level 1 Level 1 (10 points)
    Gpuc. We have all tried to rebuild he library. Works for 10 minutes then it crashes. Maddening.
  • nic//ssdp Level 1 Level 1 (0 points)
    I have been having the same issue as everyone else on here with my new 15 inch MBP and new 2 gen. AppleTV. I decided earlier this week to return my AppleTV but have been following this discussion for updates. I plan on buying a new AppleTv when they decide to fix this problem.

    In response to Gpuck, I have tried to follow this support article. I found it on a separate forum earlier last week. I thought at first it worked. I then bought a movie from iTunes, tried to play it, and it broke again. I tried this multiple times. I called apple support on Thursday. We ran the capture data both before and after I rebuilt my library. The advisor told me he would be in touch within three days but still no reply.

    Are you still having problems?
  • Justin1985 Level 1 Level 1 (0 points)
    Same problem here. New 13" Macbook Pro won't home share with my ATV2. It will show up under "Computers" and even show some album art, but when I try to go into the menu it either can't connect or it reads "There are no xxxx in this folder". I actually got it to play a video once after restarting iTunes multiple times, but then it broke again. Doesn't seem to be any rhyme or reason to it. I've tried all the solutions in this thread and nothing seems to work. Guess I'll call Apple tomorrow.

    So frustrating! Especially when my old Macbook worked so well with it.
  • Gpuck Level 1 Level 1 (0 points)
    I spoke too soon. I am in the same boat as everyone else, it has stopped working again. I am also talking with an Apple support person. By the way, one maddening comment the support person said, "we take the support discussions with a grain of salt." I mentioned several time that there were others that were having this exact same issue and he didn't even want to acknowledge it. He just saying it is supposed to work. I will be escalating this.
  • A. Clark Level 1 Level 1 (0 points)
    This thread shows me I'm not going crazy. I, too, have a new MBP (2011) with a 2nd Gen Apple TV that fails to recognize the library. Frustrating, as I have been re-booting, disconnecting, reconnecting, sharing, un-sharing, and cursing at Apple, just as many others of you are.

    However, I may have a simple solution for some of you: delete all empty libraries from your music folder and change the name of your primary library to "iTunes" if it is named something different. This worked for me, and now my Apple TV sees my entire library just fine.

    Here's the backstory on how I learned this simple fix: First, I noticed that many of you have migrated iTunes libraries from previous computers. I do also, and further, mine was actually in a folder titled "iTunes Lossless" since I've ripped my CDs losslessly.

    Before iTunes first started up on my new MBP, I had already copied my lossless library into the music folder. Nevertheless, it created a new library titled "iTunes" in my music folder alongside my "iTunes Lossless" library. This got me wondering whether the Apple TV was only looking for a library inside a folder called "iTunes". So, I decided to try deleting that newly created library and re-naming my lossless library folder to simply "iTunes". Once I did this, my Apple TV instantly saw everything in my library - music, movies, TV shows, rentals, podcasts, etc.

    Hope this helps all of you frustrated folks out there.
  • NickMac77 Level 1 Level 1 (0 points)
    Thanks, I tried renaming my library to just "iTunes", but it has no affect on getting the remote app to connect.
  • NickMac77 Level 1 Level 1 (0 points)
    OK, so I was getting paranoid about the state of my transferred library and I decided to try and rule it out.

    Stopped iTunes, moved the entire iTunes directory out of the way to iTunes_backup and restarted iTunes. iTunes loaded up in its vanilla state, creating a new iTunes folder in the process. Then I imported one album of music into this new library, so it was created entirely on my new MBP.

    It got me excited again as it appeared to work at first, but shutting down and restarting iTunes caused the same connection issues to re-appear.

    So, I'm pretty sure it's not my library that's at fault. It looks like a fundamental bug somewhere.
Previous 1 2 3 4 5 6 Next