Previous 1 2 3 Next 348 Replies Latest reply: Nov 6, 2011 6:28 AM by MAW01
themacbear Level 1 Level 1 (5 points)
Just wanted to pass along my experience with a new 17 inch MacBook Pro quad-core. They don't seem to play very well with Home Sharing. Picked mine up at the Apple store on Friday. Set up Saturday, and at first all seemed well. Was able to stream to my Apple TV 2nd gen just fine. Then, later in the day, although the Apple TV could see the name of my iTunes library, it wouldn't connect to it, or sometimes, would report that "There are no movies in this library". I tried every solution I could think of, but no dice.

Apple phone support were great, but couldn't diagnose the problem. They had me do data capture to send to Apple engineering. Took the MacBook back to the Apple Store. The very helpful Genius there was able to reproduce the problem on the store's network with an in-store Apple TV. A replacement maching was offered, and we tested the new machine before I left. Same result. Brand new iTunes library with only 6 songs in it would not stream to Apple TV, and iTunes could not be controlled with other iOS devices. So, refund for now. The folks at the store were really great though, so at least it wasn't a bad experience.

I've notice two other people in the "Using iTunes" forum reporting the same problem. In all cases Airport base stations were the networking equipment being used. I expect if this is a widespread issue, some sort of update will be offered.

My question is, are any other new 2011 MacBook Pro owners having the same issue?

MacBook Pro 17 Early 2011, Mac OS X (10.6.6)
  • wifiguru Level 2 Level 2 (230 points)
    Did you try this with an older Mac and can you confirm that worked well with Home Sharing ?
    What was your network configuration like ? Were both the Apple TV and the new Mac connected wirelessly to the same wireless network ? Is the environment clean or did you have a lot of wireless networks around ?
    Which Base Station and security mode were you using ?
  • themacbear Level 1 Level 1 (5 points)
    We have two other MacBook Pros in the house. Both work perfectly with Home Sharing. Network configuration is standard for the Simultaneous Dual Band Airport Extreme. Tried with interference robustness turned on, too. Tried on a 5 ghz band only. Tried with mixed band. Tried with guest networks enabled. All no dice. All machines confirmed to be on the same network. The Apple TV is connected directly to the router via ethernet. The new MacBook Pro had no trouble surfing the net or downloading files. In fact, it was lightning fast. iOS devices just can't connect reliably to stream or control it. Security mode was tried with WPA, WPA2 Personal, and with no security in place at all. There are other networks around, but they certainly don't interfere with the other two laptops we have. And, as I said, two different machines showed the same flaw in an Apple store, where only one network was present. (granted, I know lots of devices are connect to an Apple store network)
    I should also mention, if I didn't, when the MacBook was connect directly to the router, problem went away completely.
  • nyctravis Level 1 Level 1 (0 points)
    I'm having the exact same problem. My old computers (both PC's) did home sharing just fine with the Apple TV. Got a new MacBook Pro when they came out last week and have had nothing but problems getting the Apple TV to work with it. Sometimes it's just an error message saying the content can't be played and other times it says there is no library. Seems others are having this problem too as noted on MacRumors forums at http://forums.macrumors.com/showthread.php?t=1101492
    I've rebuilt my library twice, which has taken me so many hours to do. Finally on the second rebuild from scratch it seems to be working but I'm still rebuilding my playlists, etc. Very frustrating.

    Message was edited by: nyctravis
  • Sam4397 Level 1 Level 1 (0 points)
    I am having major problems with home sharing on my NEW loaded up 2011 Mac Book Pro. I am VERY frustrated. They have replaced it twice already and I am on my 3rd one in a week. No, I am not kidding. The folks at the Apple store were/are stumped. When you pay 3500 for a Mac Book, you should expect that every application should work. At first, they suggested that I just "wait" for a software update to fix the issue. I was a bit reserved about that suggestion.

    Problem:
    My iTunes works on the actual Mac Book. It even streams to my airport express stations all around my home. The problem is that my library cannot be used in home sharing. My other computers recognize my computer, but I cannot share with it. The same applies to when I try and control my library on the 2011 MBP with my iPad or iPhone. It sees the library, but won't play it. This frustrates me. When I took it in to the genius bar, they immediately discovered that I had a bad hard drive as well.... the second time I had it exchanged, they found that I had a bad motherboard. I am frustrated because I love Mac. I would suggest that anyone interested in buying a Mac Book Pro to be leary. It is a smoking fast machine though.
  • Sam4397 Level 1 Level 1 (0 points)
    It is in fact the new MBP as the issue. All of my others Macs actually work on the home sharing network.... just not the new one. Apple has replaced my new MBP twice already. :/ It has already become a known problem. Others have shared the same issues from the store I buy from. I am sure it will get resolved soon.
  • themacbear Level 1 Level 1 (5 points)
    I am glad to hear that this has now become a "known problem". When I called AppleCare on Sunday, it was the first time the senior tech had heard of it. Also the first time the Genius at the Apple Store had encountered it. Now, at least, with others experiencing it, it will most likely get some swift attention from Apple. I'm sure they'll have an update out soon. Hope so, at least. I really want to re-purchase!
  • Gnufist Level 1 Level 1 (0 points)
    After updating to iTunes 10.2 today I can no longer play movies in iTunes from my Home Sharing server on my new 2011 17" 2.3 GHz MBP. That worked before I updated iTunes, it just took a while to start, but now I can see that my network interface is not even downloading for buffering. It just plays for a second and then nothing.

    Update: After a few restarts of iTunes this is no longer an issue.

    Message was edited by: Gnufist
  • themacbear Level 1 Level 1 (5 points)
    I'm hearing reports that the iTunes 10.2 update issued yesterday fixes the Home Sharing problem. Can anyone confirm this? If so, I'll be reordering my machine today.
  • matthewhaag Level 1 Level 1 (0 points)
    Still occurring. 10.2 fixed it for a day. Now music plays from iTunes to Apple TV, but I still receive error when loading video.
  • earlgreyson Level 1 Level 1 (0 points)
    I, too, am experiencing this problem. I've narrowed it down a bit. When iTunes starts with any sort of sharing enabled it opens IPv4 and IPv6 TCP sockets to listen for connections. About 7-9 seconds after starting the IPv4 socket gets closed for whatever reason.

    I really hope Apple gets around to fixing it soon. In the meantime I've found a workaround. Unfortunately you have to do it every time you restart iTunes.

    1) Disable sharing (iTunes -> Preferences -> Sharing)
    2) Disable Home Sharing (Advanced -> Turn Off Home Sharing)
    3) Re-enable Sharing and/or Home Sharing.

    This seems to work for me as long as I keep iTunes running. After you turn off sharing (steps 1 & 2) it closes the sockets. When you re-enable it in step 3 they open back up and stay open as you'd expect.

    You can watch all this happening by opening Terminal.app and running the following:
    while true; do clear && lsof -i -n -P | egrep '^iTunes|^COMMAND' && sleep 1; done

    I tried dtrussing iTunes while it was creating and tearing down sockets, but there were no obvious errors. Really frustrating.
  • flur Level 1 Level 1 (0 points)
    I have this same problem on a brand new 13" i7 MBP. I have a 2007 Macbook and a 2009 MacPro - all running the same 10.2 update of iTunes. Only the new MBP has an issue - the ATV tries to connect, spins for a long time, then returns with no content found.
  • McGus135 Level 1 Level 1 (0 points)
    I have the exact same problem with my new 2011 MBP 17" w/ SSD. I sent feedback to Apple to get this issue some attention since I'm seeing other people are affected too.

    I migrated everything over to the new MBP from the old MBP 17" and thought maybe that might be contributing to the issue; however, the old MBP is still working flawlessly with my Apple TV and all my iOS devices (with Remote app) with Home Sharing and AirPlay.

    With the new MBP and iTunes 10.2, if I turn off Home Sharing I can see my library disappear from the Computers tab of Apple TV and from the Remote App on my iPad and iPhone. If I turn Home Sharing back on in iTunes, my library shows back up in those places. So I know iTunes is communicating with my other Home Sharing devices--those devices just won't connect to the library. Very frustrating.

    One piece of interesting behavior though: I can AirPlay audio to my Apple TV, but not video. When I select a video source to stream, the Apple TV goes to a black screen with the spinning gear; the gear just keeps spinning and spinning though. On the old MBP, an AirPlay-streamed video would come up on the Apple TV in a few seconds.

    I think this might be some combination of the new build of Mac OS X 10.6.6 that shipped with the 2011 MBPs and the new iTunes 10.2. OS X Build 10J3210 is on my new MBP, which is a different build from the one being delivered through Software Update to those with older hardware.

    Maybe when iOS 4.3 is released (which includes new features for AirPlay) the iOS devices will work correctly. That would mean a new Apple TV update would be necessary as well. I guess time will tell.

    I've tried everything I could think of to maybe find a solution that I could bring to the table here, but nothing worked. If anyone finds a permanent solution after encountering this problem, please let us know.

    Cheers

    Message was edited by: McGus135
  • MacNewbie82 Level 2 Level 2 (195 points)
    Hi guys,

    I am having somewhat of a similar problem as well with my new MBP, however mine is with the Remote App for my iPhone. It will not connect to my iTunes library, even though I have it paired correctly. If I close iTunes and reopen it it will connect for about 10 seconds, and then it drops and just says searching until I finally get a message saying to check my network settings.

    This doesn't happen with my older 2008 MacBook, which I replaced with the new Pro. Seeing as how we are having issues with Apple TV and such, it makes me believe it is something with the network settings on the new MBP's.
  • matthewhaag Level 1 Level 1 (0 points)
    MacNewbe,

    You're not alone. I'm also having problems with the Remote App on my iPhone connecting to Apple TV since I upgraded to a new Macbook Pro. Apple TV is also not streaming videos from my computer.
Previous 1 2 3 Next