Skip navigation

exFAT mounting problem

20934 Views 12 Replies Latest reply: Mar 30, 2014 7:55 AM by Chris0071 RSS
aixxo Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 28, 2011 11:50 AM
Hi, I'm trying to mount an exFAT harddrive via usb. The disk is recognized and show in the disk utility, but i cannot activate it. The only error I get is in the Console :

28.02.11 20:38:36 kernel exfat: bytes per cluster (4194304) > MAXBSIZE (1048576). Can't mount.

Any chance of getting access to the drive? It mounts perfectly under Windows 7.

Thanks!
Regards,
aixxo
Macbook Pro, Mac OS X (10.6.6)
  • Kappy Level 10 Level 10 (221,025 points)
    Currently Being Moderated
    Feb 28, 2011 11:53 AM (in response to aixxo)
    Do you know if OS X can read an exFAT formatted drive?
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; 11" MBA, Mac OS X (10.6.5), iMac C2D 17"; MB 2.0 Ghz; iPad 32G; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Kappy Level 10 Level 10 (221,025 points)
    Currently Being Moderated
    Feb 28, 2011 12:03 PM (in response to aixxo)
    I know it has the format option, but did not know if it also had read capability.

    A problem I've often come across in the forums is that sometimes a drive formatted on one platform does not work correctly on the other. It isn't just limited to the Mac or to a PC. I have no idea if a solution has been found other than trying to format on the other platform. Wish I had more to offer.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; 11" MBA, Mac OS X (10.6.5), iMac C2D 17"; MB 2.0 Ghz; iPad 32G; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • the-wanderer Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 24, 2011 10:09 AM (in response to aixxo)

    where did you get this information?

  • NetEagle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2011 3:41 PM (in response to aixxo)

    You da man! That was it. Thanks for the info.

  • lmcurley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2011 4:54 AM (in response to aixxo)

    Perfect thanks. I got it working too with 1024, had issues with 4096 cluster size.

     

    Thanks for the link. Hopefully Apple will improve exFAT soon.

     

    I have a 3TB USB drive and want to use with Mac and Windows, exFAT was the only real option.

     

    NTFS can be used with Mac, but not with all Macs as requires that plugin installed. Where as exFAT can be used with any 10.6.5 Macs which is perfect.

  • merfi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 7:23 AM (in response to aixxo)

    Thanks so much for the solution.

  • Antares88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 11:28 AM (in response to aixxo)

    Hi, i have a similar problem only using USB 3.0 with external hard drive although Disk Utility won't recognise this drive. Disk was formated in exFAT, 1024 cluster size. Works fine on Win7 through USB 3.0 and USB 2.0 port.

     

    Tried pretty much everything. Is there any chance to make this external drive and mac combination work?

     

     

    Thanks, Nino!

  • iMteQx Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 26, 2013 9:06 AM (in response to aixxo)

    Thanks to the guy; aixxo I also resolved this issue.

     

    Once again; if you're formatting the drive in Windows to ExFAT you need to change the clustersize to: 1024 to get it visible in your OS X.

  • matt.simmons344 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 27, 2014 3:56 PM (in response to aixxo)

    I couldn't find anything to back your theory up but I tried it and it completely solved my problem! Thanks! and for any other PC to Mac converts out there - if you have an NTSF external HD and want to make it exFAT compatible for both your PC *AND* Mac, just do what this man says lol

  • Chris0071 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2014 7:55 AM (in response to aixxo)

    I am runing Mavericks and I tried formating one drive in Exfat and a USB 3 thumb drive and both of them when I try to copy large files on them they crash while in the middle of the transfer and it unmounts the drive and says the drive was not ejected properly. Then When I unplug the drive and plug it back some times the drive wont event show up in finder. I can see it in Disk utility but it looks as if the partition has gone. Some times the only way to reuse it is to format it again i Exfat, but then the problem happens again. Has anyone had this problem in Mavericks. I am using a Macbook pro retina display upgraded model late 2013.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.