Previous 1 2 Next 23 Replies Latest reply: Nov 8, 2013 1:13 PM by bonnie amos
SoulSearcher Level 1 Level 1

I've read previous posts on this issue, including the replies to "You Tube not working ONLY in Safari", posted Feb 24th.

My macbook pro - Safari Version, 5.0.3 (5533.19.4, )- is working fine, but for some reason my iMac Safari, with same software and settings has decided not to play Adobe Flash Player.

I have uninstalled Flash player and reinstalled many times

I have deleted cookies as per Carolyn Samit's suggestion using renmoval tool at

I have emptied Safari cache several times

I have done a permissions repair

I have restarted the iMac many times

I have even tried loading an older version of flash player plugin

I have turned off the extensions tab in Safari preferences

I have unhid the develop Menu, and selected another User Agent with no success.

Still, evey time I load a page with flash content I get the message:

*Please install the latest version of the free Adobe Flash Player. Download now.*

*For help with Flash, see Adobe's Flash Player Support page.*

I've dowloaded the latest version of Flash player three times, but stiil no resolution.

*Any other suggestions would be gratefully received.*

iMac, Mac OS X (10.5.8), 2.4Ghz
Solved by andyBall_uk on Mar 2, 2011 4:58 PM Solved
tried to trash the Home/Library/Internet Plug-ins fileah yes, my mistake, sorry for the confusion.If you're comfortable with Terminal, use the following to show any possibly invisible files therels -Ah ~/Library/Internet\ Plug-InsI checked Home/Library?launch agents to find...ok, so move those to the desktop, or somewhere, then logout/in - reverse that if no difference.mail will not attach a document (plug-in missing)...that used to be commonly, if oddly, cured by resetting java preferences to default via Utilities-Java Preferences-General-Restore Defaults (and the Network tab too for good measure)I have TechTool Pro. Could this help?5+ years since I used it, but checks can't hurt, although since a new account is ok, I doubt it'll find anything relevant.
Reply by andyBall_uk on Mar 1, 2011 8:50 AM Helpful
that's a shame eh - but to move forward, you'll have to reveal what you found in the plugins folder, and whether or not a new account showed any active plugins.
Reply by MickeyPP on Mar 3, 2011 2:47 PM Helpful
I seem to have had the same problem which harassed me for the past 3 days. I solved it. First let me say that if you want YouTube, use Firefox or Chrome. They'll probably do it fine. I suspect Safari has issues with Flash Player.My result: First I uninstalled Flash Player. Rebooted. downloaded an older version of FlashPlayer. Go to Follow uninstall and install instructions to the letter. I used the archive download for 'Flash Player 10.1'. I think Safari doesn't take too kindly to the latest versions. That's OK, I don't take too kindly to Safari.Good luck

All replies

  • Klaus1 Level 8 Level 8
    Which iMac?

    Try running Safari in 32 bit mode.
  • andyBall_uk Level 7 Level 7

    you should start with Safari-Help-Installed Plug-Ins.... then see if Flash and other plugins are listed there - assuming that Safari-Preferences-Security-Enable Plug-Ins is checked On
  • SoulSearcher Level 1 Level 1
    Thanks. How would I do that?
  • SoulSearcher Level 1 Level 1

    Plugins is checked on in Safari preferences.

    When I go to Safari help - installed plug-ins, it goes to this blank page:


    So ... ?

    Thanks for getting on the case.
  • andyBall_uk Level 7 Level 7
    it goes to this blank page...

    ok, no plugins are working -

    Check firstly that the plugin files exist - paste this into safari's address bar & press enter
    /Library/Internet Plug-Ins/

    look in that folder - there should be several .plugin files, including Flash, usually.

    If that checks out - test Safari in a a New User Account & depending on the result, we'll know whether to look for a system-wide reason, or (perhaps more likely) something in your usual user account.

    If a new account behaves normally by showing a result in Safari-Help-Installed Plug-Ins,then switch back to the regular user, and start by quitting Safari & moving this file to the desktop

    then try it again.
  • SoulSearcher Level 1 Level 1

    All done. Sadly, no joy. Still no flash video. Still no installed plug-ins showing.

    Thanks for the tries so far.
  • andyBall_uk Level 7 Level 7
    that's a shame eh - but to move forward, you'll have to reveal what you found in the plugins folder, and whether or not a new account showed any active plugins.
  • SoulSearcher Level 1 Level 1
    Apologies, my last message was not clear.
    Yes, the new account revealed the following plugins:

    Adobe Acrobat and Reader
    VivX Webplayer
    Flip4Mac Windows media plugin
    Flip4Mac Windows web media plugin
    iPhoto Photocast
    Java Plug in 2 for NPAPI Browsers
    Quartz Composer plug in
    Quicktime Plug in (web)
    Quicktime plug in
    Real Player plug in
    Shockwave flash 10.2 r 152
    Sibelius scorch
    Switchable Java Plugin for Web Kit
    Verified Down load plugin

    I now also cannot imbed attachments into my mac mail messages - part message comes up "ssing Plug-" so it appears to be "missing plug-in". Very strange.

    Do I now replace the: file?

    Hope this helps us move forward. Many thanks.

    Message was edited by: SoulSearcher
  • andyBall_uk Level 7 Level 7

    so you've done extensions, done the safari plist
    it works in a new account, so perhaps there's an account-specific add-on (beyond an extension) stopping all plugins from working.

    Anything in
    ~/Library/Internet Plug-Ins/ ?

    that's in your home folder

    ~/Library/InputManagers/ ?

    anything in System Preferences-Accounts-Login Items ?
  • SoulSearcher Level 1 Level 1

    Do I put the file back now?

    When I go to library/internet Plug Ins, they sometimes show, but usually show empty!

    Library/input managers does not exist.

    System Preferences-account-login items:

    System events

    Thanks for the help.
  • andyBall_uk Level 7 Level 7

    there's the one in your account home... which is usually empty, duplicates here can cause problems.
    ~/Library/Internet Plug-Ins/

    and there's the one which is available to all users...
    /Library/Internet Plug-Ins/

    Copy/paste those paths to be sure which is which, if needs be.

    When I go to library/internet Plug Ins, they sometimes show, but usually show empty

    Um, that'd be a puzzle for sure - is that the home or main one? & what's in there when you can see things?
  • SoulSearcher Level 1 Level 1
    OK, well spotted!

    The one in my account home is empty.

    The one available to all has the following content:

    Disabled Plug-Ins
    Flash Player.plugin
    Flip4Mac WMV Plugin.plugin
    Flip4Mac WMV Plugin.webplugin
    Quartz Composer.webplugin
    QuickTime Plugin.plugin
    QuickTime Plugin.webplugin
    RealPlayer Plugin.plugin

    Do I replace the file which you asked me to remove in an earlier post?

    Thanks for keeping on the case.

    Message was edited by: SoulSearcher

    Message was edited by: SoulSearcher
  • andyBall_uk Level 7 Level 7
    Do I replace the file which you asked me to remove in an earlier post?

    it'd only be helpful if you had previously made a number of changes in Safari-Preferences... the file contains those settings & a few others, but a new, default one has already been created, so I'd leave it unless you've a pressing reason to replace the old.

    Just in case there's anything invisible in it, I'd trash the Home/Library/Internet Plug-Ins/ folder (the empty one)... it's a stretch to be sure, but better to exclude that possibility.

    Also, although they appear unrelated - remove the login items & logout/in. You can right-click on each beforehand to see exactly where they are in Finder.

    Also check in these folders which may exist in your Home/Library/

    it's empty by default, but files can be added which make apps or scripts run automatically.
  • andyBall_uk Level 7 Level 7
    I forgot to ask (again) - did you add any software, or did anything else change, around the time that you noticed Flash had stopped working ?.
Previous 1 2 Next