Previous 1 2 Next 23 Replies Latest reply: Nov 8, 2013 1:13 PM by bonnie amos Go to original post
  • SoulSearcher Level 1 Level 1 (0 points)
    OK

    I've left the com.apple.Safari.plist file out.

    I tried to trash the Home/Library/Internet Plug-ins file but a message popped up saying "Internet Plug Ins can't be modified or deleted because it is required by Mac OS X"

    I removed the login items and logged in and out.

    I checked Home/Library?launch agents to find:

    com.apple.FolderActions.enabled.plist
    com.apple.FolderActions.folders.plist
    com.apple.SafariBookmarksSyncer.plist

    Should I remove or trash them?

    Because mail will not attach a document (plug-in missing) I went back to my new account to check and see if I could attach a document there. I could. Flash player also loads into Safari.

    The computer has been shut down by two of three power failures recently. No new software has been loaded around the time of failure.

    I have TechTool Pro. Could this help?

    Thanks again for your continued support and advice.

    What next?
  • andyBall_uk Level 7 Level 7 (20,495 points)
    tried to trash the Home/Library/Internet Plug-ins file
    ah yes, my mistake, sorry for the confusion.
    If you're comfortable with Terminal, use the following to show any possibly invisible files there
    ls -Ah ~/Library/Internet\ Plug-Ins


    I checked Home/Library?launch agents to find...
    ok, so move those to the desktop, or somewhere, then logout/in - reverse that if no difference.


    mail will not attach a document (plug-in missing)...
    that used to be commonly, if oddly, cured by resetting java preferences to default via Utilities-Java Preferences-General-Restore Defaults (and the Network tab too for good measure)



    I have TechTool Pro. Could this help?
    5+ years since I used it, but checks can't hurt, although since a new account is ok, I doubt it'll find anything relevant.

  • SoulSearcher Level 1 Level 1 (0 points)
    Andy, you're a genius!

    Tried terminal (tentatively because not really comfortable). I made sure typing was exact with a paste, pressed return and there was nothing to show.

    Launch agents were moved, but before I returned them I reset Java preferences to default as you suggested and presto Mail now attaches the files and Flash Player is now working as well!!! Brilliant

    I'm so grateful for your help in solving the problem.

    Very many thanks. Much appreciated. You're very generous with the time and help you give others.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    too kind - I'm sorry not to have had you do the mail/plugin/java thing previously... this is the first time I've seen it related to browser plugins, despite the 'plugin' connection. Live & learn eh - I wonder quite how java settings affect plugin recognition ?
  • MickeyPP Level 1 Level 1 (5 points)
    I seem to have had the same problem which harassed me for the past 3 days. I solved it. First let me say that if you want YouTube, use Firefox or Chrome. They'll probably do it fine. I suspect Safari has issues with Flash Player.

    My result: First I uninstalled Flash Player. Rebooted. downloaded an older version of FlashPlayer. Go to http://kb2.adobe.com/cps/142/tn_14266.html. Follow uninstall and install instructions to the letter. I used the archive download for 'Flash Player 10.1'. I think Safari doesn't take too kindly to the latest versions. That's OK, I don't take too kindly to Safari.
    Good luck
  • Ernesto Trajano Level 1 Level 1 (0 points)
    Just for the record... I've had the same problem. In the Java Preferences app, only Java 6 was enable. I restored the java settings to the default value, but I reordered the options and placed Java 6 in the first position (I need Java 6). It worked like a charm! It seems that it nor recomended to unable Java 5 (32/64 bits).

    Thanks for the help. I would never discover such a thing.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Thank you Ernesto - not a one-off, it seems.
  • Augsburg57 Level 1 Level 1 (0 points)
    I had the same problem with my 2007 Macbook - YouTube would not play in Safari. It played in Firefox just fine. I have the most current versions of OS X, Safari and Flash installed. I tried uninstalling Flash and reinstalling. Did the same with Safari. The problem began after installing DivX and then uninstalling because I did not like the banner DivX inserts. A finally went to the Apple Genius Bar at a local retail store. The problem is Safari must run in 32-bit for Flash to work.

    If you have this problem playing YouTube in Safari, control click Safari in Finder (in the Applications list). Then click Get Info. When Get Info opens, the 32-bit box should be checked. Mine was not. Once 32-bit was checked my YouTube videos started to play correctly again. In my case everything works with 32-bit checked and "open in Rosetta" in unchecked.
  • bonnie amos Level 1 Level 1 (0 points)

    I did all this and more and still did not work.  Here is what worked:  Open Safari (top left beside the "apple"), open preferences, check the box "Internet plug-ins...Allow plug-ins.   Then you can open "Manage website settings....do you see Adobe...thats it, now YouTube should work.

Previous 1 2 Next