Previous 1 2 Next 19 Replies Latest reply: Mar 13, 2013 7:07 AM by Kertzy
MarkPek Level 2 Level 2
Trying to order prints from Aperture (after some pretty clunky signing into my Apple account) I got an error message that said only "There was a problem -- LOCALIZE."

Anyone know what that means or how to deal with it?


MBP 15" i7, 2.8GHz, hi-res, non-glare, Mac OS X (10.6.6), iPod Touch 4G, iPod Nano 5G, Aperture 3.1.1
  • boloman Level 1 Level 1
    I live in Canada and just received the same error

    There was a problem -- LOCALIZE

    Shocking you still don't have an answer in nearly 3 weeks?

    Running the latest versions of Aperture and OSX
  • MarkPek Level 2 Level 2
    Anybody know about this?
  • Tobias_2Beers Level 1 Level 1

    I have the same problem - from germany :-(

  • Mechmess Level 1 Level 1

    Same problem... USA. I don't think it has anything to do with your actual location. I can't believe this has been up for so long and Apple hasnt addressed it. Pretty crappy support if you ask me.

  • Frank Caggiano Level 7 Level 7

    Keep in mind that this isn't Apple support here. We're all just users like yourself, volunteering our time.


    If you have a problem that isn't being addressed here (or even if it is) you can always contact Apple support either on-line, by phone or going to an Apple Store.


    Print ordering through Aperture isn't something I've ever done so I can't help you and the lack of response to this indicates to me that this isn't a very common situation.


    Again you should contact Apple if you can't get the issue resolved here.




    In the meantime have you gone throught the normal troubleshooting steps (see: Aperture 3: Troubleshooting Basics ) Also a reinstall of Aperture would be a worthwhile step.

  • Mechmess Level 1 Level 1

    Sorry I came across as so snarky. I had been researching the issue for a long time and was a little more than frustrated.


    I ended up getting it solved- it aparently was an Apple ID keychain issue. A delete of the "NetServices" entry in the Keychain Access utility caused Aperture to forget my AppleID information. Once I re-entered it the order went through flawlessly.

  • Frank Caggiano Level 7 Level 7

    That's OK in the range of snarkynees that ocasionally shows up here yours was pretty low


    Glad you got your problem fixed. If I may suggest you could post your solution as a new non-question thread. It might help others having the same problem.



  • mollymoon88 Level 1 Level 1

    the netservices keychain governs the access to print order through your apple Id for iphoto and aperture. I was able to order the same prints in iphoto and still got the error on a system wide level in Aperture. that keychain removal isn't an end all fix for everyone

  • cloud.rider Level 1 Level 1

    I still have this problem after deleting NetServices and other keychain entries related to my Apple ID or Aperture. My Apple ID works in every other application, I am able to buy items in iTunes and AppStore with the same account.


    Does anyone have further tips?

  • Blind Slider Level 1 Level 1

    Wondering if anyone came back with a solution.  I'm still having the LOCALIZE problem and would like to purchase the book I created.  How frustrating is this???

  • MarkPek Level 2 Level 2

    I had this again/still as well.  After much futzing around with my basic AppleID account (I fiddled with the credit card numbers and the expiration dates, etc.), I finally got this problem to disappear.  This had NEVER worked and I finally got it to work.


    What was stopping me was the dialog box AFTER you log into the system that asks you to fill out some more stuff to CREATE an account.  Well, I wasn't CREATING an account, so I never did this.  But I bit the bullet and entered all my correct (current) account information, and I was actually able to make it work.  Maybe this is the same place that's been stopping you, too.

  • markjs12 Level 1 Level 1

    I was having the same issue as everyone else, but then I called Apple and my issue was that we do need to create a new account for Aperture (it can be the same as our iTunes/App Store/Etc.) but then the answer to the security question needs to be at least 6 characters long. 


    Hope this helps.

  • Blind Slider Level 1 Level 1

    I finally solved the problem and succeeded in ordering my book.

    After calling Apple Support, and re-installing the program, nothing worked.  Still got the LOCALIZE error.


    Apple suggested, when I called, to delete all my profile information and billing information in my Apple Account and re-entering

    For some reason, some information just didn't want to enter.  ie Credit Card information etc.

    Then I noticed in the ordering section of Aperture, you could create an Apple Account.  Heh, but I have an Apple Account..... so I figured ok, I'll ignore my current account and create a new one.

    So instead of my current email I submitted new information using my alternative account.

    Same billing address, same credit card except this time I used


    Success!!!  Aperture reconnized this new account and processed the book.  Don't know why, but problem solved. Easy-Peasy.  My original Apple account still exist and I use it for iTunes etc.  The new one though is for Aperture and I'll use it for ordering books or prints.

    Hope this works for others.

  • mauriciofromaustin Level 1 Level 1

    Let Apple know, even if you don't get a resolution, the more calls and noted cases with application issues the more Apple can gather info, document and have software engineers look at the problem. They do work on the problems if many people have the issue. It's good to give the developers of the software that we like to use some "ground zero" prespective.

Previous 1 2 Next