2 Replies Latest reply: Jan 22, 2012 5:06 AM by moornebel
NOYBUS Level 1 Level 1 (15 points)
Recently bought a Brother MFC 9970CDW printer/copier/scanner/fax. Installed it and everything worked like a charm, including scanning using Image Capture. My hard drive started making noise so I had it replaced under warranty and did a restore from Time Machine.

After that, I was no longer able to see the 9970CDW in the Image Capture list of "shared" scanners. I can still see another Brother MFC scanner that I have in the list, just not the new one.

I did have to reinstall the Brother Control Center application, just like I did when I upgraded from Leopard to Snow Leopard.

Brother support says that the CUPS driver must be used as it includes the scanner driver, and I did in fact have the 9970CDW CUPS driver selected.

When I selected the CUPS driver for another Brother scanner and rebooted, voila, I could see the scanner again in Image Capture.

As far as I can tell, when I had my hard drive replaced, the Snow Leopard install on the new hard drive must have had a newer set of printer drivers, and I see that Apple did indeed release a new package of printer drivers in January 2011. The 9970CDW CUPS driver must have been replaced with one for which scanning does not work for some reason.

To make a long question short, anyone have an idea how to go about finding older versions of printer drivers from Apple, determining which one is currently installed, and downgrading? Would these drivers come from Apple (did they write them) or are they simply distributed by Apple and supplied by the OEM?

Things work, as far as I can tell, but I'd rather have the printer driver for the exact model I am using.

MBP 17, Mac OS X (10.6.6)
  • NOYBUS Level 1 Level 1 (15 points)
    Looks like I solved my own problem, but perhaps this post will help someone else.

    Downloading the CUPS printer driver for the 9970CDW from Brothers website, installing it, and rebooting solved the problem, the scanner shows up in Image Capture again with the correct printer/scanner driver selected.
  • moornebel Level 1 Level 1 (15 points)

    Thanks for your help noybus. It didn't help directly though, because the (Swiss)German CUPS-Drivers don't seem to have been updated. I then downloaded and installed the US-Driver, which solved the problem for me.