12 Replies Latest reply: Mar 8, 2011 12:31 PM by KeaTX
KeaTX Level 1 Level 1 (0 points)
I have been trying to print wirelessly to a new Canon printer. I've read several of the posts here, but by no means all. I've tried several suggestions and still no luck. I apologize if this was answered somewhere and I didn't see it.

I am using:
MacBook G4 OS X.6.6
D-Link DPR 1260 print server
Canon D420 & MF 4250d
Also have various Windows computers as well as Lexmark & Brother printers.

Windows computers can print to all printers via USB & wireless. Exception is none will print wireless to Canon MF4350d (print server only "sees" fax driver). MacBook can print to all through USB & wireless to Lexmark & Brother. Lexmark has built-in wireless. Brother is connected to same D-Link print server.

Recently added the Canon D420 to the family. Installed CD. I was able to print to it through USB. Also able to duplex. I added the print queue for the print server and got the UFR II error 10322 ("Cannot communicate with printer....")

The Windows computers can print to it through USB & print server, so I know it isn't a print server error.

I have tried several suggestions from this forum and at this point don't remember the order of everything I've tried. However, most recently I have done the following:

Reset printer systems (right click on printer list in print & fax)
Rebooted
Added back all printers

Tried to print and got same error. So I did more searching and saw suggestion to delete certain files.

Deleted all 3 Canon queues (D420 USB, D420 wireless, MF4350 USB)
Deleted:
UFR2 folder
CNTDD450ZUS.ppd.gz
CNTDMF4350ZUS.ppd.gz
jp.co.canon.UR2.BG.plist

Rebooted & reinstalled UFR II v2.21 driver.

At this point I can print to D420 & MF4350 through USB, but not duplex on either. Still cannot print wirelessly to D420.

So I searched some more and found the suggestion to use the Printer Info Button. I did that and clicked OK. This time it looked like I was actually going to print (got a status bar). But then I got a new error message:
Canon UFRII Printer Driver. Printer open Failed - 9781.

I feel like I'm closer to printing. I'm not sure what to try next.

(Also, when I got the MF4350d, I had a problem duplexing from the Mac. I don't remember what I finally found to fix it, but I did get that working. After everything I've done recently, neither printer will duplex anymore. I've tried going to "Finishing" and setting it to 2-sided printing but it is still grayed-out on Layout.)

Would an older version of the driver work better? Perhaps a different driver completely? From what I'm seeing there seems to be a lot of problems with the UFR II drivers. The only feature I want to use wirelessly is print. So a more generic driver just for the printing function would be fine, as long as it will let me duplex.

Thanks so much,
Kea

MacBook G4, Mac OS X (10.6.6)
  • PAHU Level 6 Level 6 (15,540 points)
    Hello and welcome to Apple Discussions.

    With the Canon MF4250d connected via USB to the D-Link print server you won't be able to print from 10.6. This is due to a limitation of Canon's UFR2 driver for OS X.

    The D420 will have the same issue if it uses the UFR2 driver for OS X.

    The only chance you may have with the D420 is if it supports the PCL printer language. The MF series only supports the proprietary UFR2 language so you have no option for the MF4250d. But if the D420 does also support PCL then you can select the Generic PCL Laser Printer driver in the Print Using menu for when the printer is connected to the print server.

    With regards to the duplex function, you cannot use the Layout tab. You have to use the Finishing tab to select 2-sided printing.
  • KeaTX Level 1 Level 1 (0 points)
    Thanks Pahu for your response. I tried the generic driver for the D420. For the 1st test, it took about a half hour to spool a 2 page .pdf file and then the printer status disappeared without any error messages, but it didn't print.

    I tried again with a one page file and it spooled in just a few seconds, but still did not print. No error messages again.

    Any other suggestions?
    Thanks,
    Kea
  • PAHU Level 6 Level 6 (15,540 points)
    Well this result would suggest that the D420 does not support PCL. So I believe there is not much that you can do with the products you currently have. Over the years I've never had any success getting the UFR2 driver to work with any print server. And the latest versions for 10.6 don't work with Mac to Mac sharing either.
  • KeaTX Level 1 Level 1 (0 points)
    I was also looking at getting another print server (for another location), but I'm finding that fewer places are selling them now. I can find USB servers that would allow connections to any type of USB device. Someone suggested a bridge - but I'm not familiar with that.

    Do you have any recommendations of something that might work? I already have the D420 & computers. I can print with USB so the printer is not useless. But since this will be in a new location, I am open to suggestions of ways to print to it wirelessly.

    Thanks
  • PAHU Level 6 Level 6 (15,540 points)
    To confirm my previous posting, I found an old NetComm NP3680 USB print server. With it connected via USB to my MF4380dn I created a new print queue using the UFR2 v2.21 driver. The NP3680 provides several options for the connection, Bonjour, LPD and HP Jetdirect. However creating a print queue with any of these protocols did not allow a document to print. The print queue would pause and inspection of the cups error log showed backend (transport) errors.

    So your only hope with getting the D420 to connect via wireless is if the D420 has an Ethernet port. The Ethernet of the D420 can connect to the Ethernet port of the wireless print server or router. The UFR2 driver will work for this type of connection.

    If the D420 does not have an Ethernet port then I don't believe you will be able to print via wireless from the Mac's.
  • KeaTX Level 1 Level 1 (0 points)
    No ethernet port. I guess I'll just have to stick to USB. At least that connection works.

    Thanks.
  • KeaTX Level 1 Level 1 (0 points)
    You mentioned earlier about not being able to use Mac to Mac print sharing. I've never done any printer sharing with any of my computers.

    The Windows computers can print wirelessly to the D420 using the D-Link server. Could I print wirelessly from the Mac through one of the PCs? If so, how would I set that up? I've not ever done a wireless network between any of our computers. I will have a choice of PCs - one Win 7 (64bit), one Vista & one XP. If it's possible, which one is easiest to set up?

    Thanks again.
  • PAHU Level 6 Level 6 (15,540 points)
    KeaTX wrote:
    Could I print wirelessly from the Mac through one of the PCs?

    Some users have had success with connecting their Canon laser to their Windows XP computer and enabling the Unix print services. So you could try enabling the service using the following information.

    http://support.microsoft.com/kb/324078

    With this service running you can then share the printer on Windows, keeping the share name to one word such as D420. If you right click on the printer in Printers and Faxes you will see a Sharing menu. The same menu is available via the printers Properties pane.

    With the printer connected to Windows and shared you can then add the printer queue on the Mac using IP > LPD for the protocol. You then enter the IP address of the Windows XP computer in the Address section and the share name set in Windows for the Queue Name. The last key step is to select the UFR2 driver in the Print Using menu.

    Please note that the process above is not always successful with the UFR2 driver on the Mac. But it is about the only option you have to get this working on a network.
  • KeaTX Level 1 Level 1 (0 points)
    Thanks. I'll try this later today. I've dealt with routers & print servers but not much with networks.
    I'll see what I can figure out. I also haven't done anything with UNIX.

    Message was edited by: KeaTX
  • wildhorses Level 1 Level 1 (0 points)
    i can't get my mx860 to connect "wirelessly". been trying for over an hour. always same problem. the setup utility defaults to "wired" and no matter what i do it won't let me change to wireless in the "utility" dialog of the printer. how do i "uncheck" the "wired" check box in the network setup utility on the printer?
  • PAHU Level 6 Level 6 (15,540 points)
    You should be able to change the network connection via the machines control panel. Not sure if your MX860 has the same menus as my MP990 so there could some minor difference in the following instruction.

    Press the Home button to see all menu items
    Change the menu to Settings (the pliers and screwdriver icon) and press OK
    Scroll to Device Settings and press OK
    Scroll to LAN Settings and press OK
    Scroll to Change wireless/wired and press OK
    Scroll to Wireless LAN active and press OK
    Press the Home button to exit and turn the power off to the MX
    Turn the power back on. The device should be connected to your wireless network (assuming it was already configured to do so).

    Now you can add the network print queue.

    Open Print & Fax and click + to add
    Select the Default view and wait. The MX860 will appear quickly as a scanner and if you wait longer it will also appear as a printer (showing canonijnetwork). Select this entry and press Add to complete.
  • KeaTX Level 1 Level 1 (0 points)
    Well, I might be at a dead-end for now. The XP computer here doesn't have a wireless card. So I tried using those instructions on my Vista laptop. I found a link to a Vista setup on the page you linked to. I clicked the checkbox that they referenced, but then that stopped responding. So I'm not sure if it took the change, but the box is now checked. And I also got kinda lost during some of the set-up steps.

    I'll be in a different location in a couple of months (which is where the printer is going). That's where the wireless XP is. I'll try again there.

    At least the USB works & wireless works from the other computers. So, I can print to it one way or another!

    Thanks