2 Replies Latest reply: Mar 20, 2011 7:50 PM by Bertie the Beetle
Bertie the Beetle Level 1 Level 1

Creating my first automator thing. I want to open 1 file, then pause 2 seconds, then open another file. When I do this though, on the second Get Finder Items and then Open, it opens the first Finder item it already opened before. I guess cause it's still "Gotted"

Any way to drop this so only the second one opens? Or a better way to do this? It needs to pause because the first file is a batch file that connects to a server, second file opens RDP

iMac 27", Mac OS X (10.6), USB Hub
Solved by red_menace on Mar 1, 2011 7:39 PM Solved
When you get Finder items, they are added to the current input. If you don't want previous results to carry forward, use an action's *Ignore Input* option - you can set this by right-clicking in an action's header or from the Action menu. Setting the second Get Finder Items action to ignore any input from the previous action(s) should do the trick.

Note that this is the Tiger Automator forum - Snow Leopard's Automator is quite a bit different, so in the future you should post your Snow Leopard questions to the Snow Leopard forum.