Previous 1 2 3 Next 65 Replies Latest reply: Jun 7, 2015 10:25 AM by Alley687 Branched to a new discussion.
bayoukitty Level 1 Level 1 (0 points)
Apologies if this is addressed somewhere on this forum. I searched, but gave up after about 45 minutes.

I have 24 songs purchased through iTunes on my phone, all of which have been transferred to my iTunes library (and multiple backups). They've been synced to my iPod (not the phone one). I cannot delete these songs off my phone. I have been able to delete other songs on my iPhone and Purchased on iPhone playlists and the entire playlists. The only way I've been able to get these songs off the phone is by unchecking the "Sync Music" option altogether in iTunes and then syncing my phone. If I recheck "Sync Music," those 24 songs are still there. I made a new playlist for my phone with 35 songs and ended up with 59 songs on my phone.

I'm baffled by this. Not a huge deal, but it's very annoying, and I'd love to get an answer to how to delete them (or find out if it's just not possible). If I can't delete them, I'll know never to download anything from iTunes off my phone again.

Thanks much for any help!

iPhone OS 3.0
  • robinj Level 1 Level 1 (5 points)
    Bayoukitty

    I have started to experience this problem but only in the last month. I tried to reset the iPhone 4 and restore it but still get the same albums on the phone when I don't want them on there. I have tried all the playlist options as well. Like I say this has only happened in the last month so is probably related to a functional change in iTunes somewhere ?
  • bayoukitty Level 1 Level 1 (0 points)
    I'm not sure. My solution to the problem now is not to have any playlist on my phone. I intend to keep digging at it, hoping I find out the answer. It's become a quest.
  • Tfavor Level 1 Level 1 (0 points)

    I finally figured it out after a couple hours. The music is staying on because under your iPhone sync you have "back up to iCloud" clicked. Click backup to computer instead.

     

     

    I reread your post and saw that this wasn't an issue for iOS 5 so this might not help you

  • pajapi Level 1 Level 1 (0 points)

    If you go to iTunes on your iPad and in Album view, click and hold on the album. This will give you an X in the left top corner. Click on the X and it is gone.... This doesn't need to change the backup in iCloud settings.

  • oldsnwbrdr Level 1 Level 1 (5 points)

    Last month I had big problems trying to sync my iTunes music to my new iPhone.  I switched from AT&T to Verizon while upgrading from a 3GS to a 4S.  I could not delete undesired purchased music (music I bought from iTunes, wanted to retain in iTunes, but did NOT want to transfer to my iPhone), and some of the music that I did buy from iTunes and wanted on my iPhone would not transfer.

     

    After unresolved frustration trying to fix with Apple Care, I took the phone and my computer to the local Genius Bar.  He tried a few things that didn't work, and we finally just did a factory restore on the phone.  It's worked perfectly ever since...

     

    Until this morning.  On my iPhone (and my iTunes options, on my Mac) is an option to automatically sync iTunes purchases to all devices.  Unfortunately, I had this turned on.  I ended up buying about 40 songs on iTunes this morning, most of which are Christmas gifts for my wife.  I only want about four of the songs on my iPhone, but because of the setting, ALL of the songs are now on my iPhone.  Unchecking all of my playlists and resyncing my iPhone does not delete them.

     

    I will try a few more things tonight, but assuming that doesn't work, I am going to turn OFF the automatic sync feature, backup my iPhone, and do another factory restore.  I'll keep you posted.

  • oldsnwbrdr Level 1 Level 1 (5 points)

    EDIT:  This worked.

     

    First, I turned off the automatic sync of purchased music to my iPhone (did this both in iPhone store settings, and the iTunes preferences (store tab).

     

    I connected my phone to iTunes to allow it to back up.  I do all my backups to iTunes, not the Cloud.

     

    Then I plopped the phone in restore mode (while connected to iTunes via USB, hold both buttons on my phone, keep holding buttons as phone shuts off and the apple comes on the screen.  Count to 8 seconds, and the phone is now in restore mode).

     

    Restored from my iTunes backup.

     

    All of the purchased music that I did not want on my iPhone is now gone!

  • RJV Bertin Level 3 Level 3 (950 points)

    Me also I'd love to get rid of some of the songs I dl'ed last week, only to find out I can't stand them! The keep coming back off my iTouch, despite the warning iTunes on my Mac pops up each time I trash them. Curiously, some seem to have been deleted, but 3 remain.

    pajapi wrote:

     

    If you go to iTunes on your iPad and in Album view, click and hold on the album. This will give you an X in the left top corner. Click on the X and it is gone.... This doesn't need to change the backup in iCloud settings.

     

    Does this only work on the iPad? Can't seem to get it to do that on my iTouch ...

     

    If I'm still awake enough when I get home tonight, I'll try to clear all music off the pod, and then restore it. It'd be madness to have to do a restore to wipe a few songs (but then, a reboot is required to get rid of an unrecognised CD, so what can you expect :-/ )

  • lcamoir Level 1 Level 1 (0 points)

    After spending almost all night fiddleing with my iphone I have worked it out.  It's very similar to pajapi's instructions for ipad:

     

    Go into music and Album view.  Swipe your finger quite quickly across the album you wish to delete (from right to left seems to work best).  A red 'delete' button will appear.  After deleting it, it wont appear again unless you select in your itunes libury.

     

    This seems to work in 'Song' view and 'Artists' view as well.

  • B3NJ3 Level 1 Level 1 (0 points)

    Icamoir I cannot begin to thank you enough for this advice.

     

    It's been bugging me for ages!!

  • iHades Level 1 Level 1 (0 points)

    Always the same: Too easy to be true, I already went nuts because of it!!

  • Memo55CS Level 1 Level 1 (0 points)

    Thank you so much. Just so everyone knows this works for movies too

  • Ryan Hargrove Level 1 Level 1 (5 points)

    Great info.  I had two itunes free singles of the week that I downloaded, did not like, and could not get rid of.  I would delete them from itunes over and over again only to see them reappear each time I synced my iphone with itunes.   This was driving me nuts.  Hopefully, this will do the trick in getting rid of them for good (it sounds like it will).

  • DubTDub Level 1 Level 1 (0 points)

    I didn't read all the responses. (So sorry for a repeat answer) The easiest way to do it is- Go to your music on your phone, selecet albums at the bottom, and simply swipe your finger accross the album you do not wish to have and the delete prompt will come up. Then hit delete!

     

    Hope this helps!

  • marksimon Level 1 Level 1 (0 points)

    This didn't work for me. I have an iphone 4s. I've tried everything mentioned here I think. I deleted all the albums from my phone but then when I went to synch they automatically come back. I have my settings to only synch one playlist, it has 105 songs - but there are 128 invisible songs that automatically get synched. I delete all from my phone, try again. I'm beating my head against a wall.

Previous 1 2 3 Next