6 Replies Latest reply: Sep 3, 2013 5:03 AM by donalwho
drewmedia Level 1 Level 1
At our office, most everyone has a Macbook Pro. Though we all connect an ethernet cable each morning, we've found that if wireless is enabled, it will often pick up that connection first and stick with it unless wireless is disabled. This is despite the fact that ethernet is properly set to default above wireless in the network service order.

Is there no way to have this behave correctly and automatically besides having to remember to disable wireless every time we connect our machines without 3rd party location switching software? I would have thought this was the purpose of the network service order.

Macbook Pro, Mac OS X (10.6.6)
  • Beavis2084 Level 4 Level 4
    Are you booting the Mac with the network cable ALREADY plugged in?

    I've not had any issues with the order of network devices being used out of sequence but a thought:

    Open up the network control panel.
    Unplug your network cable.
    Does the wireless auto-connect?
    Once connected, plug in the cable.
    Does it go green (connect) and re-order the list so that it shifts to the top and the wireless slides just beneath it?
    If not, at that time, drag the order to it's proper sequence.
    Close the control panel.

    Re-open and test the operation again.
    Unplug cable - does it go red and does the wireless slide back up and turn green?
  • drewmedia Level 1 Level 1
    I'm opening my Macbook from sleep mode, so not fully booting down and back up every time I disconnect / reconnect.

    To your sequence, yes, I'm getting the expected behavior. When I plug in the ethernet cable, it changes from red to green and moves above airport (also green). But even while that's the case, I know that my connection isn't utilizing the ethernet over the airport because when I try to copy files to other local network devices, they copy slowly. Once I manually turn off the airport connection, the speed difference is immediately noticeable, as transfers happen over gigabit ethernet.
  • Atacama 80 Level 1 Level 1

    I'm experiencing the exact same behavior on my MacBook Pro Retina 15" (early 2013), running Mountain Lion. Network service order is properly set (ethernet is at the top of the list).


    The only way to force the system to use the faster ethernet connection is to turn Wi-Fi off.

  • donalwho Level 1 Level 1

    Yip, I have been having the same issue for years and now with 10.8.4 on both a 2011 MBP and 2013 MBA the issue is consistant. If the Ethernet and Wifi are on and the ethernet connection is in first place most of the traffic still goes over wireless. This can be easily seen using iStat Pro where you get a visual on both interfaces.

    And in both cases using netstat -rn the Ethernet interface is the first one in the list.

  • fibonacho Level 1 Level 1

    Go to your network settings and set up Locations. Make a "Desk" or whatever location, delete Airport from the left column, and move Ethernet all the way to the top. For your other location settings you can enable Airport.


    Also there are more complicated commands you can use to limit Wifi adapter's access to certain parts of the network. 


    I would stick to Locations. Plus it's better to have one of the two (wifi or hardwire) enabled at a time if you want max speed from one. both come from the same ethernet card as opposed to one dedicated to each.. and you get the idea

  • donalwho Level 1 Level 1

    We all realise that we can do that. What we are complaining about is the fact that OSx should take care of it for us and it is not. Back in 1999 I had a dell laptop that had overlay network controlling software that allowed for profiles to be created and you could choose which networks you wanted active depending on what networks were detected. I know apple has not got that far but at least this basic level prioritising should be respected..... 


    Maybe someday IOS will even allow Wifi networks to be proritised... IOS 8 or 9 maybe ???