Previous 1 2 Next 16 Replies Latest reply: Dec 14, 2012 11:24 AM by JohnnyMac66 Branched to a new discussion.
Scottie Pal Level 1 (0 points)
When I tried to send a photo from my newly updated iphoto 11 I got "password not recognized" support at Mac said it was caused by my service provider, as my e-mail works just fine I doubted that. re-entering my password in preferences did not fix the problem, but when I read all the info in preferences I noticed the port number had been changed, missed that one at first. I changed the port no back to the correct one at iphoto works well now. This is a solution posted, not a problem, wondering if anyone else has experienced this?

I Mac G5, Mac OS X (10.4.7)
  • Northern Survivor Level 1 (30 points)
    Have a similar problem.

    Email works fine in Mail. Trying to email photos using my ISP email account from iPhoto produces an error message "User name?Password combination not recognized by server". I've tried changing ports but error persists.

    Using my MobileMe account works fine.

  • thewondercat Level 1 (0 points)
    I can't send emails from iPhoto 11 either. Where do you find the preferences page for mobile me accounts. I'm so new at this. Thanks.
  • Donna Faye Level 1 (5 points)
    I can send photos from my gmail account, but not from my "Apple Mail" account. At first I got the error message that "password not recognized" so I changed the the port # to match my email as you suggested. I now get the error message "check your internet connection. If the connection is working properly, the email server may be down. Try sending your email later."
    Bottom line is that if I send from iPhoto, I will use the gmail account from the pull down options.
  • Tim Honnor Level 1 (0 points)
    When I try and send photos with my .mac address, using iPhoto 11, I get a message that my user name and password are not recognised. But I can send from other accounts with no problems.
    My mobile me all works well - except for this.
    What should I do?
    Tim Honnor
  • Stefan.KK Level 1 (0 points)
    same problem here with my mobile me account. any solution yet? I thought it might be because it's trying to use instead of
  • Donna Faye Level 1 (5 points)

    Still having the same problem. Can only send from my gmail account. I changed the ports, as earlier suggested, because they were different than in my shaw email account but still no luck. It first prompts me for my password, then an error message comes up -Check your Internet connection. If the connection is working properly, the email server may be down. Try sending your email again later.

  • rodolfodsantos Level 1 (0 points)

    You have to go into iphoto > preferences > Accounts and set up your email account.  Some of them like hotmail require an outgoing server like  "" ; Port 587; username and password.

  • Tahoe Yoga Level 1 (0 points)

    I just had this same problem too and realized I had changed my email password a few weeks ago after my yahoo account got jacked.  I did what rodolfodsantos said up above and changed the passworkd in iphoto preferences under accounts and it worked immediately.

  • Out of Africa Level 1 (0 points)

    Spot on!  I needed to enter the Outgoing Server/SMTP info which was not requested when I first linked iPhoto to an email account.

  • maylcyok Level 1 (0 points)

    Scottie Pal,


    Thank You for the solution.  I was having the same trouble, followed your advice on changing the port and now I can finally email pictures through iPhoto 11.  I used the port numbers that were under the advanced tabs in my mail preferences for each account.


    Thank You!

  • Toby T Level 1 (0 points)

    i set up an account to email from iphoto, but when i select e-mail it brings up my gmail account. how do i revert back to emailing right from iphoto?


  • JAGX Level 1 (0 points)

    The problem of sending from IPhoto seems to be cured by careful checking (provided all your email accounts work as they should).


    1) Are the passwords exactly the same? I found  one in my IPhoto account which  had been entered with one number incorrect.Without deleting passwords and carefully rentering it looks as if all is well when it is not.


    2) Are all the Ports the same ? Despite the fact that you can use several ports I found that whilst they all worked in email you must select the same one in Iphoto as you are using in email or nothing will send and you may well see a notice that the password is not recognised-it is in fact the port selection.


    3) On Gmail it seems you must tick the secure socket box. At least I could not send on my Gmail account until I had. My main provider was OK without this box ticked. Very odd.


    Provided all the other insruction on the IPhoto  instructions are the same as email you should be able to send without trouble but there is one last tip passed to me which  is worth knowing.


    It seems that sometimes the TO box has blue lines waiting for instructions but will will remain blank and will not react to clicking on the mouse. If this is the case hit the alpa key to start the receipient list and a full list of names appears as per address list in mail. According to Apple this should not happen but it does!


    Hope all this helps someone.

  • SparkyJ Level 2 (405 points)

    APPLE; What is the secret handshake to configure the "Outgoing mail server" in iPhoto 11?

    It is obviously pulling info from the MacMail configuration. All emails work fine in MacMall. I have tried to reconfig to allow for finiky outgoing servers, a la: 25, 465, 587. as well as checked passwords on the server. Reset passwords to be sure. opened the old MobileMe prefs and re ran a phoney tst name to clear the cache.


    We are getting this error:

    Your email did not go through because the server did not reply.

    Check your Internet connection. If the connection is working properly, the email server may be down. Try sending your email again later.


    What Pref file needs to be deleted in order to use iPhoto for this pesky outgoing mail idea?

  • LarryHN Level 9 (74,610 points)

    No apple here. Just users like yourself


    The best solution IMHO is to simply set Mail as the email client in the iPhoto preferences and use it



Previous 1 2 Next