5 Replies Latest reply: Mar 20, 2011 8:50 PM by MacWon
BZKL Level 1 Level 1 (0 points)
So, I downloaded Facetime yesterday on my mac but every time I try to call someone it rings, says "connecting", and then drops the call.

I already checked my Firewall and Port Connection so, I don't understand what's wrong?

Anyway, if you could help out that'd be great, thanks!

MAC, Mac OS X (10.6.6)
  • 1. Re: Facetime not connecting
    egreenwald Level 1 Level 1 (5 points)
    Same problem here. Beta worked fine, but the final version won't connect.
  • 2. Re: Facetime not connecting
    Harpo Marx Level 1 Level 1 (10 points)
    same here: call comes through but than it remains in 'connecting' for ever without actually connecting.

    i have applied all kinds of troubleshooting: switched languages from german to english - back and forth without success, eliminated caches and plists.

    apple care is helpless about it.

    this is a shame! seems as if apple is good in making profits.. good hardware we have to say that too.. but its software? and support?
  • 3. Re: Facetime not connecting
    Soujuk Level 1 Level 1 (5 points)
    Same problem. Cant solve it
  • 4. Re: Facetime not connecting
    dbrake79 Level 1 Level 1 (0 points)
    We had the same problem and fixed it with the following:

    Have a belkin wireless router:

    Under DMZ feature, we specificed the internal IP adress of the Mac that wanted to connect to facetime to be outside the NAT firewall. Had the Mac disconnect then reconnect to the wireless and then calls completed.

    We did try to do the port forwarding suggestions listed on the apple site, but at the time this did not fix the issue.

    I would say look to your firewall settings on your router and troubleshoot from there. Good luck!
  • 5. Re: Facetime not connecting
    MacWon Level 1 Level 1 (0 points)
    Solved it for my iMac. Facetime would not sign in using ethernet.
    So, I disconnected ethernet. Fired up wireless. Signed in fine.
    Turned off wireless and fired up ethernet again.
    Has worked fine since.
    Why did this work? No one at Apple knows, but it works!