Previous 1 2 3 Next 31 Replies Latest reply: Mar 10, 2011 3:49 PM by Diverds
Tony in Ottawa Level 1 (15 points)
I just installed iTunes 10.2.0.34 and it now takes about 15 minutes for my iPhone 4 (OS 4.2.1) to sync.

The problem seems to be step 5 (Syncing Photos). The window at the top of iTunes switches from "Syncing Photos" to "Preparing To Sync" then takes about 15 minutes to finish. I have 9,046 photos and 3,105 songs on my iPhone.

While syncing my iPhone my PC (Win7 64) is slowed to a virtual crawl!

iPhone 4, iOS 4
  • Craiggles Level 1 (0 points)
    I have the same issue - deselected photo syncing (leaving existing photos) for my iPad and it synced fine. Hooked up the iPhone - syncing only one folder with 14 pictures took about 20 seconds. Selected a second folder with about 130 pictures, and it's taking well over 5 minutes. Delselected photo sync - 90 seconds to back-up and complete the sync (nothing new added).

    I think the problem is in the photos - as long as they're not important, there's your work-around...

    -Craig
  • Ian Parkinson Level 6 (10,505 points)
    Same issue here, I have tried:

    Reinstall iTunes
    Repair Permissions
    Reboot Mac
    Reset iPhone

    No difference at all, still takes ages to complete step 5 of 5 preparing for sync
  • jason_mc Level 1 (10 points)

    Add me to the list. I have the same problem.

  • Ian Parkinson Level 6 (10,505 points)
    Not exactly a solution if you want photos on the phone though.
    Guess we will have to wait for a proper fix from Apple!
  • McHooper Level 1 (0 points)
    Yup, sounds familiar. Since the update it does take ages to sync, and it's at exactly the same spot that you mention...

    I think I'll try the deselect-photo-sync-option described above... yet I sure hope they fix this with 10.3 or what-not.
  • Tony in Ottawa Level 1 (15 points)
    Hopefully sooner. I rely on my iPhone to show my photos and it takes too long to sync the darn things.
  • Morac Level 1 (100 points)
    Apparently a work around is to delete the "iPod Photo Cache" folder on the computer. It's usually stored in the same folder as your pictures, but that varies depending on what folders you are syncing.
  • BoneFD Level 1 (0 points)
    Nope......does not work. Just tried that and it is sooooooo slow.

    Problem with itunes 10.2.0.34

    Message was edited by: BoneFD
  • toonz Level 7 (22,360 points)
    If you see "Preparing to sync" during photo sync, and you've let it fully complete once, and iTunes still does the same slow thing again on a second sync, send your photo database to our friend Roy at Apple: <royb@apple.com> The photo database is inside iPod Photo Cache, which is inside the photo library you're syncing from. For iPhoto, in Finder, right-click your photo library, Show Package Contents, and go into iPod Photo Cache and drag "Photo Database" to your email message. For Windows, iPod Photo Cache is just in whatever folder you're syncing photos from. (Or if you're syncing from Adobe Photoshop Elements, it's in something like C:\Documents and Settings\All Users\Adobe\Catalogs)
  • Tony in Ottawa Level 1 (15 points)
    I did as you suggested. My file Photo Database file was over 25MB, so I zipped it to 1.2MB.
  • jason_mc Level 1 (10 points)
    Also sent my iPhoto DB to Roy. Here's hoping there's a fix soon.
  • jimmci Level 1 (0 points)
    Just had this problem after cloning my HD to my shiny new WD 750GB drive this afternoon. I thought, oh gosh now what, or words to that effect. Thankfully a search brought me here, and after undoing photo synching - I'm back. I can live with that for a while--a whole lot better than a bad clone!

    I generally don’t do posts, but I’m glad the folks here took the time.It surely saved me, and I’d imagine a number of others, a bunch of time.
  • powdrackm Level 1 (0 points)
    Hi there got the same problem with music. Every song takes over 30 seconds. Don't have time to wait 2h for a hundred songs. This really annoys me!
    Anyone have a solution for this. iTunes 10.2.0.34, win7, iphone 4 (latest update)
Previous 1 2 3 Next