4 Replies Latest reply: Dec 28, 2012 12:10 AM by Lauren58
Steven Shmerler Level 1 Level 1 (60 points)
I'm trying to connect to a WiFi network with airport on my Mac Pro.

In prefs / Network, Airport says: Airport has the self-assigned IP address (address is here) and will not be able to connect to the Internet.

I can connect to this WiFi with my iPad and iPhone no problem.

I even tried using the IP address from my iPad, after turning the iPad WiFi off, and using DHCP with manual address and get the same message.

So whether I have the self assigned Airport IP, or manual IP, I can't get to the Net.

Why does the iPad IP address work, but using it on my Mac Pro doesn't?

PS: Airport says the IP address is self-assigned even when I have it set to manual, which I assumed would override the self-assigning as the IP address shown is the one I manually typed in so it is definitely not self-assigned.

Thx
S

Mac Pro 3.0 GHz Quad-Core, iPad WiFi + 3G (Yea!), Mac OS X (10.6.6), 30" HP LP3065 Monitor, 22" Cinema Display
  • Dj Steelo Level 1 Level 1 (0 points)
    I am having exactly the same issue with my macbook pro. I can connect rthrough my airport base with my iphone 4, my ipad, and two other pcs in teh house but my macbook keeps saying sef-assigned ip and wont let me on the internet.
    This is extremely frustrating since I have restarted several times. I also even did a complete restore from the time machine backup and still no luck.
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Steven Shmerler wrote:
    In prefs / Network, Airport says: Airport has the self-assigned IP address (address is here) and will not be able to connect to the Internet.

    I can connect to this WiFi with my iPad and iPhone no problem.


    It might help to reset the connection settings on your Mac using these steps one at a time until the problem is resolved, recognizing that, depending on your problem, not all of these steps will make sense:

    1) Use the AirPort menu bar item to turn AirPort off, then on again.

    2) Try to select your Wi-Fi network from the AirPort menu.

    3) In the Network panel of System Preferences delete the AirPort item from the left column, then add it back.

    4) In the same panel as (3), define a new location and see if you can make that work.

    5) In the same panel, select the AirPort connection item, click the "Advanced" button, select the "TCP/IP" tab, then click "Renew DHCP Lease".

    6) In the folder /Library/Preferences ( not <yourhomefolder>/Library/Preferences), move the folder SystemConfiguration onto the Desktop, then restart your computer. See if you can now make your AirPort connection work.

    These steps may not help, but they'll only take a couple of minutes to try. Before you try these, if you have any special network settings on your Mac for things like DSL credentials, note all your network settings, because the latter steps will destroy them. If you got all the way to the last step, if things don't work any worse than before, you can trash the saved SystemConfiguration folder.
  • mfb123 Level 1 Level 1 (0 points)

    I've had this problem for a month or so. Read and tried everything. I had a laser printer installed that used ethernet connection, and  bluetooth printer also. I deleted those and my macbook pro running Lion immediately got a correct ip address and is working ok. I haven't used Macs too long, I assume the printer could have been grabbing the IP address, or maybe it just picked that moment to fix itself. anyway if you have other devices hooked up that use a network connection, try it. Something else to try when you want to spend hours and hours on a stupid problem.

  • Lauren58 Level 1 Level 1 (0 points)

    just an FYI:   My airport wireless wouldn't connect to my motorola modem until I changed the ROUTER MODE from the Bridge mode to the DHCP and NAT mode.