4 Replies Latest reply: Dec 19, 2011 11:42 AM by MacNToes
Amos22 Level 1 Level 1 (0 points)
iMovie '11 seems to be losing the link to the source video clip at times. It happened in iMovie '09 as well.

It happens after I spend a while editing a project and close/open iMovie several times, then when I play the final video it doesn't play certain clips. The last frame from the previous clip stays on the screen for the duration of the clip. If I scrub over the clips they won't play either. The same thing happens in the event library as the project library.

I called tech support and they said to re-import the video clips, which solved the problem, but I shouldn't have to re-import the video clips after I get done with a project. If I right click on the video clip and select "reveal in finder" the clip plays fine in quicktime.

Has anyone else seen this issue? It really makes me not want to use iMovie if I have to spend an extra few hours at the end of every movie fixing clips that aren't working.

I just noticed something odd - the duration for the clip says 9:10 and the source duration is 8:10, even though the speed is 100%. The source value is correct, the clips is 8 seconds long.

Message was edited by: Amos22

iMac (late 2010), Mac OS X (10.6.6)
  • Mattias Fellenius Level 1 Level 1 (0 points)
    Hello Amos!


    I have a question, you wrote "I called tech support and they said to re-import the video clips, which solved the problem," How did you re-import the video so that Imovie connects it to the right project?

    Regards: Mattias
  • AndyGump Level 1 Level 1 (5 points)
    Reimporting video and having it connect to the movie project is something that I would like to know how to do too. I moved my Event Library and the links to the movie project were broken and when I returned the video event to the Event Library the link was still broken. Is there a way to save a project and its related Event Library so that links aren't broken???

    Andy
  • ConcreteMark Level 1 Level 1 (0 points)

    I have encountered a similar problem, that is loosing all the video links. It happened after one of the many crashes while working in iMovie. Considering the date of your post I don't have much hope for a solution. Reimporting every single clip is not just time consuming but shear misery. With all the problems I've had with iMovie I hardly think the program is worth the trouble. It seems the only hope is for Apple to get their act together and fix the myriad problems with this program. Otherwise it's just a dog.

  • MacNToes Level 1 Level 1 (0 points)

    I've noticed this as well with my most recent video. Did you find you kept encountering the issue AMOS22? I don't want to have to re-import the videos for each one I want to use.

    I did find that if I did a hard re-boot, the movies started working again...well, some of them...but then subsequent movies would "lose their link" I find I can tell which ones are not going to work if the sound file is missing.