7 Replies Latest reply: Feb 20, 2013 12:52 PM by Fymbscu
Michael Graubart Level 2 Level 2 (250 points)
I have spent all day on the Net searching for a version of Scribus that will run on my G4 (PPC) with OS X 10.4 (Tiger). I believe Scribus 1.3.3.14 should work on my system (though I am so confused by now that I am not sure). Can anyone please tell where I can find a compiled version or installer for this version?

I have found plenty of sources for the uncompiled collection of files comprising Scribus 1.3.3.14. I have also tentatively looked at Fink and at Darwinports with a view to compiling and installing Scribus 1.3.3.14 myself, but I am afraid it is all too complicated for me, and I am really dependent on finding a compiled version or installer.

Thank you in anticipation of some help.

eMac G4 (PPC), 1.25 GHz, Mac OS X (10.4.11)
  • Michael Graubart Level 2 Level 2 (250 points)
    Eureka! Since posting the above, I have found a source — not quite of v. 1.3.3.14, but of v. 1.3.3.10, which works well on my PPC & Tiger system. As I know that various people have posted questions like mine on various discussion sites, here is the website: <http://www.1-2-3printing.com/downloads/> (scroll down till you find Scribus 1.3.3.10). There is also a link to some useful instructional videos there.

    When starting Scribus 1.3.3.10 on my system, a message concerning missing Ghostscript software and the inability to use EPS images or Print Preview appears, even though I have tried installing Ghostscript and Foomatic. I don't think this will matter for most of the purposes for which I want to use Scribus, but I would be interested to hear from anyone who understands this message.
  • BDAqua Level 10 Level 10 (119,125 points)
    Great find, thanks, I couldn't find any myself!

    I found this...

    http://pages.uoregon.edu/koch/

    And from the About 8.7.1 distribution...

    2. What Is Installed
    Ghostscript binaries are installed in /usr/local/bin. Ghostscript support files are installed in /usr/local/share/ghostscript/8.71 and man pages are placed in /usr/local/share/man. Ghostscript fonts are installed in /usr/local/share/ghostscript/fonts.
  • Michael Graubart Level 2 Level 2 (250 points)
    Thanks very much, BDAqua. The link to the maths typesetting software is potentially very useful and I have bookmarked it, although my days as a maths and physics teacher are long past (I have been a musician and lecturer in music for the last 40 years, so it's music typesetting software I mostly use these days).

    As for Ghostscript, I did install Ghostscript 8.71 succesfully, but the error message still appeared when opening Scribus. It will not, however, stop me using Scribus with all the files and images I am normally interested in.
  • BDAqua Level 10 Level 10 (119,125 points)
    As for Ghostscript, I did install Ghostscript 8.71 succesfully, but the error message still appeared when opening Scribus. It will not, however, stop me using Scribus with all the files and images I am normally interested in.


    I finally got it & installed it, didn't work here either, same EPS error, no idea where it's looking for Ghostscript.

    If it ever turns out you have to deal with an EPS file, just drag it to Preview, from there you can Save as another format, or Copy & Paste.

    There's also EPStoPICT for Mac...

    http://download.cnet.com/Art-Age-EPStoPICT/3000-2193_4-480.html
  • Michael Graubart Level 2 Level 2 (250 points)
    Well, I'm glad it isn't just me! Thinking that it might be the PPC problem again, I even found an earlier version of Ghostscript (v. 8.61), which explicitly claims that it will work on a PPC-based computer, somewhere on the Net, but the same happened. Thanks very much, BDAqua, for taking all that trouble. It's annoying about the Print Preview, but not the end of the world.

    Thanks, too, about the information about Preview. I had no idea that it would open EPS files.
  • BDAqua Level 10 Level 10 (119,125 points)
    The first GS you mentioned & 8.7.1 both work via Terminal commands, but uhhhhgg.
  • Fymbscu Level 1 Level 1 (0 points)

    Thanks for the post about scribus for tiger. I just began looking for it myself. Based on your comments about ghostscript, I found this page, http://ppcluddite.blogspot.com/2012/10/scribus-for-powerpc-macs.html which has this to say about fixing the error you are seeing:

     

    "After installing, then go into Scribus's preferences in the External Tools section, and under PostScript Interpreter enter /usr/local/bin/gs for name of executable.  That's the path to Ghostscript.  Then you should be good to go."

     

    Hope this helps.

     

    Regards,

     

    Mark Harrison