Previous 1 2 Next 20 Replies Latest reply: Jul 25, 2015 9:13 AM by SeeHole
Tepe Level 1 (0 points)
I started having a strange problem with the mouse cursor. I started the computer, the mouse worked fine as always. Suddenly the cursor started fixating on a point on the lower right portion of the screen. I would move the cursor, it would move maybe halfway across the screen for a split second and then snap right back to the starting position.

I tried shutting down the computer and restarting. Didn't help. The cursor behaves the same way in the login screen too. The only difference is that now the "homing position" is somewhere in the upper right part of the screen.

I have a Kensington Expert trackball and a Magic Trackpad. I've removed the trackpad, in case it had started interfering with the trackball (never done that before though). Didn't help. I've unplugged and replugged the trackball USB-cable, no help.

Any ideas what is going on? I haven't yet checked the mouse settings in the system panel, a bit hard to get there with no mouse and I haven't yet figured out the key-combination to open the settings.

Apple Mac Pro, Mac OS X (10.6.6)
  • Tepe Level 1 (0 points)
    No help available to my problem? I had the Mac Pro unplugged for over a day as I was travelling and the Kensington Expert Mouse too. Behaved exactly the same when I switched on the computer again. I tried resetting the PRAM. Didn't help.

    I don't know where the problem lies. The mouse cursor keeps snapping to a position in both the login screen and my user screen. The snap-back position is different in the different screens. The cursor returns to its position when both the Magic Trackpad and the Expert Mouse are connected or when only one of them is. I can move the cursor half a screen, then it snaps back. Clicking functions, but I never have any time to click anything when the cursor bounces back to its spot.

    My final remedy would be reinstalling Snow Leopard, but before I try that I would like tro try something less radical. I would also delete the mouse .plist file, but I don't know where it is. I guess that probably would not help, as the cursor behaves crazy even in the login screen, so the user setting should not be the problem.

    Where should I turn to help? Is there a way to contact Apple directly?
  • Tepe Level 1 (0 points)
    I've come to the conclusion, that the problem is not a hardware one. The mouse cursor snaps to point on the screen when I use: 1) a Kensington Expert Mouse, 2) a Magic Trackpad, 3) the Magic Mouse that arrived with my computer and when I turned on 4) use keyboard as mouse. The problem also is not tied to a certain user because it appears 1) in the login screen, 2) my user account and 3) the sysop account. I can't figure out where to look for the problem or fix it.
  • Dale Weisshaar Level 6 (15,860 points)
    Maybe try some basic repairs?

    Try using Disk Utility to do a Disk Repair, as shown in this link, while booted up on your install disk.

    You could have some directory corruption. Let us know what errors Disk Utility reports and if DU was able to repair them. Disk Utility's Disk Repair is not perfect and may not find or repair all directory issues. A stronger utility may be required to finish the job.

    After that Repair Permissions.

    No need to report Permissions errors....we all get them.

      DALE

  • Tepe Level 1 (0 points)
    Thank you for replying. I tried what you suggested. When I booted from the DVD the mouse cusor worked perfectly.

    The Disk Repair said that the startup disk was OK. No problems. I tried also fixing the preferences, it found some stuff. Did not fix ARDagent. I was hopeful for a while when it found a problem in GlobalPreferences.plist and fixed it.

    When I booted from the harddisk again, the mouse cursor was acting up again. Could I boot from the Snow Leopard DVD and manually edit or nuke some offending preferences file? Maybe it would work if the system was forced to recreate the problem file.

    Anyway, hardware problem it is not. Something is globally wrong for all accounts and seems to affect only the mouse.
  • Dale Weisshaar Level 6 (15,860 points)
    You could try this;

    Mac OS X: Starting up in Safe Mode

    What is Safe Boot
    Safe Mode takes awhile to start, so patience is a virtue here!

    Does your cursor work correctly there also?

    Good Luck!


  • Tepe Level 1 (0 points)
    Thanks again. The mouse works perfectly in safe mode. How do I proceed from that, where do I find the origin of the problem?
  • Dale Weisshaar Level 6 (15,860 points)
    Does it still go to the corner in normal operation after using Safe Mode?

  • Tepe Level 1 (0 points)

    Thanks for your help. The mouse cursor started working fine (while using trackball only) and I was going to ask you how/why did the fix work. Last week, I brought the trackpad back to the setup. The cursor worked for a day and then started again snapping back to position.


    I tried the Safe Mode boot again, the cursor works fine in Safe Mode, but this time the problem is not fixed in normal mode. I tried repairing permissions, no help. I had the Disk Utility check the disk, and after a while the progress bar freezes and soon after that the mouse cursor freezes too. It has done that twice, so I don't know if there is something physically wrong with the disk itself. Is there some other way to check for it, besides the Disk Utility.


    At the moment, I removed the trackpad, the cursor works fine in Safe Mode, but keeps snapping to a point on the screen after a normal boot. I have all the newest updates installed to Snow Leopard. I was thinking of applying the latest combo upgrade, in case one of the incremental upgrades broke something. The system worked fine for months, after all.

  • Tepe Level 1 (0 points)

    I give up.


    I've tried everything I can think of, to fix the behavior of the mouse cursor. I've zapped the pram, I've fixed file permissions, I've removed all startup items, I've tried starting the computer in Safe Mode. No can do.


    The mouse cursor snaps back to a position on the screen when I try to move it. This happens within a second, so I might be able to move the cursor half-way across the screen, but that's it. It doesn't matter how fast I move the mouse. The cursor is dysfunctional in the normal user account, the administrator account and in the login screen. It works perfectly fine in Safe Mode.


    The mouse cursor misbehaves when using a USB track-ball, the Magic Trackpad or the keyboard with accessibility settings.


    After advise received at this site, I tried booting up in Safe Mode and after that the cursor worked for a month or so, but the problem returned. I see no rhyme or reason why the problem appeared for the first place, or why it reappeared. I had originally had two pointing devices the track-ball and the Trackpad connected to my Mac Pro at the same time. After the problem first appeared, I removed the Trackpad. I returned it to use a day before the problem reappeared, but I don't know if that is the cause of the problem. The computer had worked perfectly fine for some months with two pointing devices before the problem appeared.


    I've noticed that some other people have had the same problem. One had a feline related fix, which doesn't help me since I don't have a cat. Another fixed the problem by switching off the Internet, but that didn't help me.


    What I now would like is to make an official bug-report, so that the problem could be fixed someday. I hope Apple is listening. I also plan to reinstall Snow Leopard (I have 10.6.7) next weekend. I had hoped to install a new OS only when Lion got out, but I don't seem to have much choice not. I can either simply reinstall or make a clean reinstall by erasing the disk in the process. I'd like to avoid reinstalling my programs, but I feel it is safer to wipe everything and start from scratch. Even then, I have no assurance this doesn't happen again.

  • Leckie Level 1 (0 points)

    I know this is an old post but I'm having this exact problem in osx lion. It's driving me insane. Does anyone have a fix for it yet?

  • twrthe Level 1 (0 points)

    I had the exact same problem with the behaviour described and almost called techsupport. I aint saying that this was your problem too, cause its kinda dumb, but my problem was this:

    I have a wacom tablet and I left my pen on it. Id didnt do anything till restart, but then it woke up and started to reposition my cursor repeadetly, because the pen remained in the same position.


    So you might have a serious problem, or if youre dumb like me, it can be solved really fast: Check your tablet

  • zaiten2012 Level 1 (0 points)

    "I've noticed that some other people have had the same problem. One had a feline related fix, which doesn't help me since I don't have a cat."


    he's gotta be kidding! I though he was gonna write "since I don't have a tablet", but he actually attributed the fix to the cat (which -on that thread- bumped the magnetic pen away from the desk, solving the problem) I had the same problem and the "cat-fix" shed the light on the issue: having a pen on top of the tablet, that's how tablets work, by teleporting the cursor.

  • tady Level 1 (0 points)

    Thank you so so so so much twrthe. I had a real facepalm moment when I read your post. That was exactly my problem. I despaired reading the lengths Tepe went to cause I thought, dear lord, this is going to be a nightmare to fix. When I read your post, I lifted a screen cloth on my desk and found my pen on my tablet. What a stupid, stupid thing to do...


    Thanks again. Tepe, I hope you got this resolved as easily as this.



  • miteub Level 1 (0 points)

    OMG !  I have spent the last 3 hours attempting to fix this problem.  I even upgraded to Lion thinking it was a software issue.  As I read this post, I immediately looked up at my Wacom tablet and noticed that my pen must have gotten knocked onto it.  I moved the pen and Problem Fixed !!  Thank You.  Not sure if this is a fix for the OP but at least in our example we learned that a second device was conflicting the primary device.  So perhaps check to make sure there aren't multiple devices installed.  If there are, delete any secondary devices and see if that works.

Previous 1 2 Next