Previous 1 2 Next 28 Replies Latest reply: Apr 19, 2011 6:29 PM by Joe_1104
yozhbk Level 1 Level 1 (0 points)
I got the new MacBook Pro i5 2.3 the day it came out. So maybe a week and half ago.
I`m having intermittent wireless issues. I have done some testing and even replaced my older AirPort Base Station with the new Dual-Band one, but still seeing a drops from the network. I have a ping going to my router and to the ABSE. I tried changing the channel and using 5GHZ or 2.4GHZ. I also have a AirPort express and seen similar results. I tried reseting the PRAM, repairing permission, I did not reinstall the OS but I dont see how this would help. I think there is a hardware issue with the wireless card/antenna.

I did upgrade RAM and HDD was changed to SSD (intel G2 SSD). There are no other issues, machine is fast, no lock ups. Other devices on the network do not seem to drop any connections (ATV, ATV2, iPhone4, iPad etc..)

The network drop outs are short but are noticeable and if a ping is going I can see the drops



*-- 192.168.1.1 ping statistics ---*
*1527 packets transmitted, 1505 packets received, 1.4% packet loss*
*round-trip min/avg/max/stddev = 0.779/12.203/396.084/42.274 ms*



Any help is appreciated as I`m really frustrated but this issue.

MacBook Early 2011, Mac OS X (10.6.6), iphone 4 32GB
  • yozhbk Level 1 Level 1 (0 points)
    Some more testing and I`m pretty sure its the network card in the MBP, does apple swap this in the apple store ?
  • JMF Level 3 Level 3 (735 points)
    I don't think there is an actual AirPort card anymore. I think the wireless adapter is soldered directly into the motherboard and would require a new logic board. I don't believe there is anything the folks at the Apple Store could "swap" unless they had a spare motherboard for this model in the back. You may have to send it out for service, though since it is so new I'd suggest calling Apple to see if they can work out a replacement machine rather than service one that is brand new. Good luck.
  • yozhbk Level 1 Level 1 (0 points)
    You sure ?

    http://www.ifixit.com/Teardown/MacBook-Pro-15-Inch-Unibody-Early-2011-Teardown/4 990/1

    Based on the above there is a BCM4331 card in 15 inch atleast. Looks the same in 13... The issue with replacing the unit is the RAM upgrade I dont have the original RAM anymore....
  • wifiguru Level 2 Level 2 (235 points)
    yozbhk,
    Are these ping drops to your wireless router consistent ? If you ping it say 5 times ( ping -c 5 x.x.x.x ) where x.x.x.x is the Wireless router IP address, and you repeat this 5 time's are you seeing network drops consistently every time ?
    What signal strength is the Mac seeing the wireless router at ? ( Press the Option key and click on AirPort Menu Extra to look at the RSSI value ). A value between -35 and -75 is usually a very good value. Any value lower than that ( -76 to -90 ) is not very good.
    Run a throughput test at speediest.net and test your speed's ( pick the nearest location ).
    Are you seeing drops when you stream movies to the Mac ? Or is your download speed significantly lower ?
    Also make sure you pick a channel where there are fewer Access Points. If the 2.4 Ghz band is crowded, pick a channel in the 5 Ghz band.
  • yozhbk Level 1 Level 1 (0 points)
    Thanks for the reply wifiguru, here are the answers,

    no the pings are not consistently dropping, it comes and goes the signal shows to be good, but some time it does go to -76-75,the things is Im not moving this laptop, this usally happening when I`m in 1 place, I will try to catch it next time I see the drops. As far as the speed, the speed test is good, like I said it comes and goes. Another thing I noticed if I transfer a big file to the MAC from the network (AFP, SMB, FTP etc..) I start to see ping drops, but it doesnt seem to effect the transfer just ping get very inconsistent.

    I`m on 5GHZ but did try 2.4GHZ and same results I tried manually setting the channel based on my surroundings (istumbler) and it did not help, No one around me using the 5GHZ based on the istumler findings.
  • yozhbk Level 1 Level 1 (0 points)
    Ok a bit more testing, and I do see when the drops start, the signal goes closer to -80 and rate goes down 12-41 from usually showing 162 or something similar. Again this is stationary in the same place. And AppleTV (first one) is in the same room and I dont see this fluctuations or dropping out. the pings are steady to it from workstation thats wired.
  • yozhbk Level 1 Level 1 (0 points)
    Here are some of the pings.



    +*64 bytes from 192.168.1.3: icmp_seq=2190 ttl=255 time=1.138 ms*+
    +*Request timeout for icmp_seq 2191*+
    +*Request timeout for icmp_seq 2192*+
    +*64 bytes from 192.168.1.3: icmp_seq=2193 ttl=255 time=1.701 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2194 ttl=255 time=1.653 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2195 ttl=255 time=1.723 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2196 ttl=255 time=1.470 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2197 ttl=255 time=1.435 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2198 ttl=255 time=1.217 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2199 ttl=255 time=1.115 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2200 ttl=255 time=1.433 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2201 ttl=255 time=1.002 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2202 ttl=255 time=1.057 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2203 ttl=255 time=1.222 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2204 ttl=255 time=0.769 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2205 ttl=255 time=0.821 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2206 ttl=255 time=0.723 ms*+
    +*Request timeout for icmp_seq 2207*+
    +*64 bytes from 192.168.1.3: icmp_seq=2208 ttl=255 time=54.892 ms*+
    +*Request timeout for icmp_seq 2209*+
    +*Request timeout for icmp_seq 2210*+
    +*64 bytes from 192.168.1.3: icmp_seq=2211 ttl=255 time=1.313 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2212 ttl=255 time=0.936 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2213 ttl=255 time=1.839 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2214 ttl=255 time=0.879 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2215 ttl=255 time=63.446 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2216 ttl=255 time=24.384 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2217 ttl=255 time=105.923 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2218 ttl=255 time=41.322 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2219 ttl=255 time=1.853 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2220 ttl=255 time=0.811 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2221 ttl=255 time=0.721 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2222 ttl=255 time=0.791 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2223 ttl=255 time=3.816 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2224 ttl=255 time=1.052 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2225 ttl=255 time=0.688 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2226 ttl=255 time=89.272 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2227 ttl=255 time=49.459 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2228 ttl=255 time=15.891 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2229 ttl=255 time=0.745 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2230 ttl=255 time=0.724 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2231 ttl=255 time=0.680 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2232 ttl=255 time=1.950 ms*+
    +*64 bytes from 192.168.1.3: icmp_seq=2233 ttl=255 time=0.600 ms*+
    +*Request timeout for icmp_seq 2234*+
    +*64 bytes from 192.168.1.3: icmp_seq=2235 ttl=255 time=0.725 ms*+
  • yozhbk Level 1 Level 1 (0 points)
    Going to try to install Windows 7 on this laptop and see how it behaves, before I take it to the apple store, this is getting very annoying....
  • wifiguru Level 2 Level 2 (235 points)
    -80 is not a very strong signal. Can you move closer to the Base Station and test ?
  • yozhbk Level 1 Level 1 (0 points)
    I could be in the same room with the APBE and see the same results. Yesterday after your post I was checking signal every few minutes. and its usually -65 to -77... This morning its not happening, which is very strange and frustrating. I really dont think it has anything to do with a signal strengths, I actually tried moving the base station few days ago thinking it was a signal issue and that didnt help.
  • yozhbk Level 1 Level 1 (0 points)
    Ok so today I went to Apple Store and replaced the laptop, the only thing that is the same as the old one is the RAM. Hard Drive is still the Apple Stock HDD.

    I didnt get much testing with it yet. But I tried a transfer again from CIFS share and was able to replicated the drops once again. I`m not eliminating the possibility that RAM is bad, but this doesnt seem to effect anything, the transfer on the wired network are crazy fast and with out any drops. I was also able to show the same behavior in apple store with the old MacBook didnt try with the new one. I have to test if I`m getting drop outs like I did with the other one, that takes time. I wonder if any one else with the new MacBook Pros (Early 2011) can try this simple test of opening the terminal or network utility and starting a 100 pings to there gateway or even yahoo.com and then transfer a large file over the network how many drops do you get if any ?
  • yozhbk Level 1 Level 1 (0 points)
    Did more testing and its doing the same thing. I guess I`ll try to replace RAM and test again.........
  • wifiguru Level 2 Level 2 (235 points)
    Can you test pinging to the AirPort Base Station ? Or another machine in your wireless network ?
    That will tell you if the wireless network itself is seeing drop's or its the WAN side of the connection.

    Can you run:
    /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s

    and paste the output here ? That should tell you how good or bad the air around you is.
  • yozhbk Level 1 Level 1 (0 points)
    192.168.1.3 is my AirPort Station, I`m always running the pings to it.

    /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s
    +SSID BSSID RSSI CHANNEL HT CC SECURITY (auth/unicast/group)+
    +Lorabie-guest 68:7f:74:39:eb:f3 -81 1 Y -- NONE+
    +Buffalo 00:24:a5:6f:54:69 -87 2 N -- WEP+
    +timewarnercablewifi 00:0d:67:0e:ea:bb -79 11 N -- NONE+
    +optimumwifi 00:0d:67:0e:ea:b9 -79 11 N -- NONE+
    +xfinitywifi 00:0d:67:0e:ea:ba -77 11 N -- NONE+
    +wirelessp 00:18:f8:75:a1:3c -85 11 N -- WPA2(PSK/AES/AES)+
    +VASQUEZNET 00:09:5b:d4:f4:aa -77 11 N -- WEP+
    +32L75 00:18:01:85:8b:5e -73 9 N -- WEP+
    +MrFried 00:1c:df:a3:18:bb -80 6,-1 Y -- WPA(PSK/TKIP,AES/TKIP) WPA2(PSK/TKIP,AES/TKIP)+
    +Maddie 00:18:39:76:7f:e4 -84 6 N -- WPA2(PSK/AES,TKIP/TKIP)+
    +dlink 00:1e:58:41:26:99 -77 6 Y -- NONE+
    +Lorabie 68:7f:74:39:eb:f2 -82 1 Y -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)+
    +YozhN 10:9a:dd:83:0c:45 -58 1 Y US WPA2(PSK/AES/AES)+
    +YozhN5 10:9a:dd:83:0c:46 -74 149,+1 Y US WPA2(PSK/AES/AES)+

    I`m currently connected to YozhN5
Previous 1 2 Next