6 Replies Latest reply: Mar 6, 2011 7:08 PM by MaKee
MaKee Level 1 Level 1 (0 points)
2 Mac and 4 devices (iPad / iPod / iPhone) using the same network without any trouble, and a printer which can be used by both computers on the network.
Air Print on the devices gives me "No printer detected" all the time.

iOS is 4,2
Printer is HP CP1525nw (which is on the enable printers list)
Printer is linked by Ethernet cable to the Time Capsule - acting as the router.

What I'm doing wrong???

(Sorry if this was already answered - I browsed in many threads but still can't see the point.)

Many thanks

iMac / MacBook / iPad / iPhone /iPod, Mac OS X (10.6.6), iOS 4,2
  • Demo Level 10 Level 10 (82,785 points)
    From Apple's support article.
    http://support.apple.com/kb/HT4356

    *Avoid connecting AirPrint-capable printers to the USB port of Apple AirPort Base Stations or Time Capsules. Doing so can enable traditional AirPort printing from a Mac, but it will not enable AirPrint functions for iOS devices*. If you cannot use wireless networking to connect your AirPrint-capable printer, use an Ethernet connection to your Apple AirPort Base Station or Time Capsule.
    Wi-Fi printers can take several minutes to join a Wi-Fi network after being turned on. Ensure that your printer is connected to the Wi-Fi network before attempting to print.

    Message was edited by: Demo
  • MaKee Level 1 Level 1 (0 points)
    It was not connected by the USB port, but by Ethernet.
    Anyways, I restarted everything from the beginning:
    -Download the last driver version from HP
    -Reset the default config. on the printer
    -Install the printer in "true" wireless config (no cable)
    -Download and install the firmware upgrade from HP (for ePrint)
    -Check both computers with the new config (everything's ok)
    -But still "No printer detected" from iPad, iPod, iPhone...

    Perhaps my confusion comes from the fact that I can't figure the difference between Air Print and ePrint... (I didn't have inscribe my printer on the HP ePrint website yet.)
    Is AirPrint uses ePrint? Or if it is the Apple name for the same kind of application?
  • Demo Level 10 Level 10 (82,785 points)
    Sorry but when I saw the Time Capsule no no, I thought that may have been the cause. I don't use AirPrint but I print through another app WePrint from Save2pdf using my MacBook. Have you watched the video on this site?
    http://www.hp.com/united-states/campaigns/airprint/index.html
    Click on About AirPrint at the bottom and the next page has a video on it.
  • MaKee Level 1 Level 1 (0 points)
    (@Demo: thanks for your help)

    Well... I leave everything in state and get out for lunch. Getting back, Pages and GoodReader finally find the printer. Great! I succeeded to print one page.
    But few seconds after, trying to print another one, I got again "No printer found"...
  • Fred*M. Level 4 Level 4 (2,380 points)
    MaKee-

    AirPrint is not the same as ePrint. An AirPrint printer converts data to its native format, which happens to be ePrint in the case of HP.

    I think you are doing everything right, and everything should work together. I'd check to see if you might have another WiFi network nearby. It could either be interfering, or your iPad/iPhone device might be reconnecting to the wrong network without your knowledge. I've had that happen, and had to tell the iPad to "forget" the second WiFi network to keep it from reconnecting.

    Fred
  • MaKee Level 1 Level 1 (0 points)
    I think I'm joining the "No printer found" gang...
    I've seen my printer one time, and succeeded to print one page (with Pages, from the iPad). Since, nothing, "No printer found".
    I've tried from two different iPod, one iPhone and again with the iPad many times. Same result.
    I made a couple of cold resets of every device (printer, modem, router, computer, portable devices...). Same result.
    There is only one Network for the devices to remind of.
    Everything's look OK in my network, and computers have correct access to the printer.