Previous 1 2 Next 27 Replies Latest reply: Oct 2, 2012 3:44 AM by foo__
ntroglin Level 1 Level 1 (0 points)
Hello,

I have 2 Macbook Pros, 2 iPads, and a Windows 7 Desktop. I recently purchased Apple TV 2. It was working fine for the first month or two. I was able to use AirPlay from any device. They are all connected with a Time Capsule Router. Recently we upgraded to the new i5 and i7 Macbook Pros. Right around that time, I started getting the error message "Error occurred loading this content, please try again later" when trying to do AirPlay from either Macbook Pro. They will both stream music, just not videos. I have tried videos that I have ripped and ones straight from iTunes. I have rebuilt my iTunes library, reset the router, disabled the firewall, reset Apple TV, etc. Nothing will work. It will still stream video fine from my iPad. Any ideas?

Thanks for your help.

Macbook Pro i7
  • BenniCrow Level 1 Level 1 (0 points)
    Wow, I am having the same exact problem. Everything was working great for the first month, but I just got my new macbook pro i7 and now I can't load any movies. The streaming of music works fine but not the digital copies of movies or even the ones bought from iTunes. And I've gone through all the steps of reseting the router, apple tv, itunes, and I disabled the firewall. Please if some other people have some ideas this would be great.
  • Unicum Level 1 Level 1 (0 points)
    Hello.
    I have almost the same problem.
    I can not stream on the appleTV2 any movie encoded on by my new MacbookPro quad-core i7.
    But I have no issues with movies encoded by my old macbook core2duo, even if I stream them with the corei7.
    I've used the same settings on Hanbrake, same appleTV2, same settings on my wifi !
    Weird.
    Very frustrating also.
  • swoopersf Level 1 Level 1 (0 points)
    Same problem here... it's really annoying to buy a new mbp and atv2 and have it not work...
  • leitchy Level 1 Level 1 (0 points)
    I have a similar problem, last night I removed iTunes and re-installed it. Then the Apple TV2 streaming worked. Videos in my movies folder that weren't showing were. I played a couple a went to bed.

    Tonight I tried to watch one of those movies, started the MBP up to run iTunes and connected the apple TV. No luck. No movies displayed in the list. When I attempt the airplay thing I get the error mentioned. Music works fine.
  • leitchy Level 1 Level 1 (0 points)
    Just a quick note, I read on another post something about turning IPv6 off. Gave it a go and the movies now appear and stream.

    Haven't restarted anything so there is a good chance it was just lucky, I'll try it a few times over the next few days and see how it works.
  • sandler77 Level 1 Level 1 (70 points)
    Same problem. Along with the metadata and flickering issue after the recent Applet TV 2 update, maybe this too is related to the continuing issues with iOS updates. Maybe if enough of us post here and complain to apple (http://www.apple.com/feedback/appletv.html), they might work out a fix for us...

    Interesting how movies that I have already played on my Apple TV before that were already imported into iTunes before the last iOS Apple TV update are now not working. They worked before. I really wish someone could explain these hardware/software bugs to Apple...
  • acon234 Level 1 Level 1 (0 points)
    I had this same error and was able to fix. In my case it seems it was something with my original itunes library. A good way to see if this is your issue is to create a new itunes library as a test. Create a new test library by holding down option then launching itunes from the dock, create a new fresh library. Add some music, use a music cd and import a song or two as a test, don't just drag in music from your drive. Then go and try to stream the music to your Apple TV. Downside is if it works you will have to rebuild your library but it did work and my Apple TV is now streaming music and videos from my iMac and MacBook Pro!
  • Capt Rat Level 1 Level 1 (0 points)
    I have the same problem but only when trying to play movies rented via Apple TV. If I rent via iTunes I can play them fine from the MBA. I also have tried resetting Apple TV, the Time Capsule and the modem with no luck.
  • Techdogg Level 1 Level 1 (0 points)
    Same problem here, but only on some movies. All were encoded using handbrake. Some were encoded using the old ATV preset, while newer imports were encoded using the ATV2 preset. Have not tried any remedial measures, but was going to try re-encoding the trouble movies only using the new presets.
  • sandler77 Level 1 Level 1 (70 points)
    Problem continues, however it only shows on movies for me that are 4.0 GB or larger in size (a portion of my imported HD, 1280 x 720, movies). Not sure why this is still happening, but it sounds like it is a software bug with either the new iTunes and/or AppleTV iOS software just updated... Let's hope Apple reads these discussion boards and looks into things.
  • MichelIV Level 1 Level 1 (0 points)
    Ditto. Created a new iTunes library and imported the movies into that library. Streamed to AirPlay with zero issues. I'm using the latest iTV software and have the 2011 17-inch quad processor. Prior to creating a new library, I would get the error loading movie warning. No matter what I did, wouldn't work until I created the new library.

    I did de-authorize all computers in iTunes a week prior but have since reauthorized my laptop. Not sure if that would really have anything to do with it.
  • ntroglin Level 1 Level 1 (0 points)
    Hey Guys,

    Has anyone figured out a way to get it to work? This is getting really frustrating. Apple support has no idea what to do either. I have updated everything, rebuilt the libraries, de-authorized and re-authorized, turned off and on home sharing... nothing works.

    Let me know if you figure anything out! Thanks
  • mpupp Level 1 Level 1 (0 points)
    I am having the same troubles. Heres my tale:

    Just purchased a new Pro (Mar16), reinstalled and de/authorized all itunes accounts. Apple TV worked fine for about a day. Now content won't load, streaming does not load and movie contents only shows about 1/10 of my movies titles.

    There are times when everything will display but cannot play. I can exit out and return 10 seconds later and nothing will be available or will receive an error message.

    I have tried multiple combinations, ext HrdDrv connected to Pro, ext HrdDrv connected to Air Play, nothing is working. Of course Netflix and iTunes is fully functional.

    Sorry I can't assist anyone, I am just as lost. GREAT FUN
  • MichelIV Level 1 Level 1 (0 points)
    Just a quick update on my end. I thought creating a new iTunes library had solved the problem. It didn't. Every time I disconnect from the Apple TV, put my laptop to sleep, etc...I must create a new iTunes library and import the movie I want to watch. That's the only way to get anything to play via AirPlay. Each and every time. Let's go Apple, get your act together.
Previous 1 2 Next