6 Replies Latest reply: Mar 8, 2011 12:39 PM by Esfinne
DCmasta Level 1 Level 1 (0 points)
I have a 2nd Gen iPod touch that I've always synced with my Windows 7 computer. Up until about a week ago, everything was fine. Now I plug in my iPod and the computer won't pick it up at all. The iPod doesn't charge and there are no new devices under My Computer.

Odd thing is, the iPod and USB Sync cable work fine. They both charge and work perfectly on my little brothers computer (with the same OS and version of iTunes). What's more, the USB port on my computer works as well, as I found out when I plugged in my cell phone.

I've tried nearly everything. From resetting the computer to restoring the iPod back to factory and nothing has changed....help?

iPod 2nd Gen, Windows 7
  • Weeone Level 1 Level 1 (0 points)
    Hi there - I have exactly the same problem. Gen 4 iPod Touch worked wonderfully on my Windows 7 laptop. Updated to latest version of iTunes and all of a sudden it won't recognise my iPod at all. My work laptop recognises it and will charge the battery and my old PC with the previous version of iTunes recognises it as well but this is so slow, it freezes when trying to sync which is why I moved everything to my laptop.

    So bloody frustrating also cos it doesn't recognise the 10 new tunes just bought on iTunes on my laptop (should have bought them direct to my iPod I guess).

    So how do you go back and get the old version of iTunes or what is a fix for this?

    Many thanks.
  • lllaass Level 10 Level 10 (164,820 points)
    Try this article and the second related article on the left side.
    http://support.apple.com/kb/TS1495
  • xlouie Level 1 Level 1 (0 points)
    I got the same issue as well....done the apple trouble shooting, but to no avail....search the web and no resolution...my PC won't recognized my ipod 2G but my ipod is charging...need help..
  • DCmasta Level 1 Level 1 (0 points)
    You guys are better off than me. My iPod won't even charge. According to the computer (and iPod) there's nothing plugged in. BUT...everything works on other computers. Cable, iPod, newest iTunes, everything. So frustrated. There's nothing to troubleshoot because as far as I can tell, nothing's wrong!
  • dwd40 Level 1 Level 1 (0 points)
    I'm experiencing the same issue. My 4th Gen iPod touch worked fine until the latest iTunes update on the day the iPad 2 came out. I've been troubleshooting for 2 days. Uninstalling all Apple software and reinstalling but no luck. Seems like it must be an Apple mobile driver issue.
  • Esfinne Level 1 Level 1 (0 points)
    I have simular problems
    After updating itunes a few days ago my ipod touch 2.gen won't sync at all. It started with it not wanting to add music to the ipod. I got the message "file can't be found" even though I could play the song in itunes.
    I started trying a "hard restart" of the ipod, with no result.
    I then tried to re-install itunes, with no result.
    I then tried to restore the ipod to factory preset, with the result that the ipod won't read at all in itunes.

    I've had a long history with sync-problems. And it always shows up after an itunes update. I tried sending the ipod to Apple service last summer but they found "nothing wrong" with the ipod. Apple won't take responsibility under warranty anymore and i'm left with a glorified, overpriced product that doesn't work because of firmware updates from Apple that I can't refuse.
    Apple makes products that looks nice and are easy to use, but their customer service is non-existing when their products break down.
    Last Apple product I'll ever buy!