Skip navigation

Canon MF4570dn (MF4500 series) scanner problems

31641 Views 40 Replies Latest reply: Oct 30, 2013 7:20 AM by aircihan13 RSS
  • ErichInVermont Calculating status...
    Currently Being Moderated
    Mar 6, 2012 9:06 AM (in response to nxnw)

    Thanks for the clarification - excellent points that forunately aren't so much a factor in my setting where I just need to scan a document or receipts once and a while - looks like the defaults on the printer should work. I'm just relieved the thing isn't a complete brick for me.

     

    I certainly agree that Canon seems not to invest in their software development with anything like the resources they should.

  • tharlam Calculating status...
    Currently Being Moderated
    Apr 29, 2012 11:30 AM (in response to doogles)

    Wish I had found this thread before I spent hours setting up my new MF4570DN. It is actually quite simple to do, as it should be with a mac. Ignore the supplied manual and CD's (only for Windows) once you have the MF running as a standalone copy machine. The above posts should provide the needed info. Basically, download the latest drivers from the Canon website (3 of them), install them, connect ethernet cable to router (Airport Extreme in my case), install TWO printers on Bonjour (regular one and the "fax" one if you want to fax), follow the Mac intructions when you try to do something, and follow tips in posts above on how to set the MF control panel. I have my MF printing and scanning fine over the network on two macs, an old Macbook intel running 10.4.11, and a MB Air running 10.6.8. The MF Toolbox works on both of them. I have to agree that the Canon "instructions" are the worst I have ever encountered. The MF4570DN device itself however is quite impressive, especially considering the price I got it on closeout. Since it is now discontinued, perhaps no one else will need to set one up!

  • piccherroll Calculating status...
    Currently Being Moderated
    Oct 31, 2012 4:32 AM (in response to doogles)

    Just to say that I love you all like anybody else before: I had no more hope to scan anything with this machine, THANKS A LOT!

  • JETNZ Calculating status...

    I own the MF4370dn and have the latest MF toolbox v1.60. (on OSX 10.6.8). This app just does not see the MF4370dn despite it being set to "Scan USB". (connected via USB). Earlier versions of MF toolbox rarely worked but the latest version is a dead duck. Why did Canon make this so complicated? Anyone else found a workaround? Thanks.

  • RedpointRik Calculating status...
    Currently Being Moderated
    Dec 2, 2012 7:02 PM (in response to JETNZ)

    As I've said before, this is the worst interface I have ever experienced on an all-in-one scanner. I have an Epson WorkForce in my summer home and this Canon in my winter home. The Epson works like it should, open the scan program and press scan. Period! With this printer, you have to go back and forth from the computer to the printer - an absolute piece of garbage as far as I am concerned. No thought was given to usability at all!

     

    So I had the same problem with the new version, and finally just gave up. I uninstalled and reverted to the previous version, which only worked part of the time, it would not allow me to scan multi-page documents. What garbage. So I finally gave up on the Mac software: I loaded the windows version of MF Toolbox on Parallels, and although it still requires me to go to the printer for each and every scan, it at least works. I would never buy another Canon laser. 

  • tharlam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 8:45 PM (in response to JETNZ)

    JETNZ,

     

    Yes, terrible instructions from Canon for Mac. See my message above. But I got my scanner/printer/fax functions all working over airport (and also from USB direct) from two Macbooks. It can be done, and in my case was done simply once I ignored Canon's instructions and did what one normally does with Mac stuff.

     

    Good Luck!

     

    Tharlam

  • JETNZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 9:15 PM (in response to tharlam)

    Tharlam, thanks for your answer. I'm keen to try your methods. I have the latest drivers installed, and added to the printer list in System Preferences (as a printer via Bonjour, there is no option to add as a scanner). Then I connected the printer via Ethernet as you suggested straight into Airport Extreme. Switched printer to SCAN/NETWORK but MF Toolbox says "No available scanner found. Follow the instructions in the Scanner Driver Guide to add the scanners you are using". I'd like to know where the Scanner Driver Guide is, because it ain't on my system... That's where I am anyway. Have I missed a vital step maybe...

  • tharlam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 10:43 AM (in response to JETNZ)

    JETNZ,

     

    The "Mac_ScanGear_V160.dmg" downloaded from Canon contains several files: the .pkg to install the driver, a "readme" that has lots of tips and bug reports (esp. osx 10.5 is a problem it seems), and ""Canon Scanner Driver Guide" in the "guide" folder (html files, open it in your browseer by clicking on the "index.html" file).

     

    If you installed any other driver than the latest one just downloaded from Canon, I would uninstall that first and do a new install of the latest one.

     

    The Driver Guide not only has the instructions for installing the driver, but then shows how to "add a network scanner" from the MF Toolbox. This seems to be where you are stuck at the moment. This all worked for me.

     

    tharlam

  • JETNZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 9:01 PM (in response to tharlam)

    Found the manual. It seems you have to "Register the Scanner to the MF Toolbox". So I tried this.

    However, despite the printer being connected via ethernet to a router and set to "Network Scanning" there is nothing coming up under Bonjour as described in the manual. That's as far as I can get unfortunately. Thanks for your help, but there must be something different that prevents the printer from being seen on the network.

  • tharlam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 10:11 PM (in response to JETNZ)

    Jetnz,

     

    I'm puzzled too. The "register the scanner" is what I was describing. I just opened my MF Toolbox. It could not find my scanner as it was in sleep mode. I woke it up and used the panel to put it in "remote scanner" mode. The MF Toolbox then saw it OK.

     

    Are you seeing the printer over the network OK, as a Bonjour printer? I was assuming you had the printer function working before you tried to get the scanner function added.

  • aircihan13 Calculating status...

    Hi ErichInVermont

     

    I follow the step you said.

    On things that are confusing: On the printer, when confronted with the choice between network and computer, counterintuitively, select computer. When I do that (connected over ethernet) I see the Mac with the driver software installed, I select it, set options, and press go.

    Unfortunatly when i press go an error happens. "MF Toolbox was interrupted unexpectedly".

     

    what do you think about that. i reinstall the driver.

     

    Thank you

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.