Previous 1 2 3 Next 43 Replies Latest reply: Feb 18, 2016 9:15 PM by McBiker Go to original post
  • Avalies Level 1 Level 1

    Edit: It does work after all!!! The only thing is: you have to restart your Mac. Don't forget that, it's not described in the instructions from Paul but for me it was necessary to get my printers back!


    Hurray, Paul, you're my absolute hero!!!

  • b166er Level 1 Level 1

    Paul, you're a legend!  Thanks:)  I also agree that the warning should be more dire &/or explicit.

  • candace8itall Level 1 Level 1

    YOU ARE AMAZING. Thank you so much for posting your solution and such detailed instructions on how to fix it! So many people post "solutions" that are extremely complex and completely un-followable for us normal folk who are NOT computer geniuses...your instructions wer crystal clear and you even thoughtfully put the paths in there for us like Macintosh HD>etc>etc>etc. Thank you thank you thank you again!!

  • Macincrash77 Level 1 Level 1

    Paul in LA,


    You are a beautiful person, my friend.  Well done. 


    This worked for me on 10.5.8.

  • filthy D Level 2 Level 2

    Thanks Paul in LA that got my printer back but it's showing up as offline, any idea how to get that corrected?

  • Juergen B Level 1 Level 1

    Hello Paul,

    You made my day!

    I jsut right clicked on one specific printer to 'reset' but it removed me everything, even network printers etc.

    Very good instruction and I got my printers back.


    Thank you



    Juergen Boenisch

  • pajcksn Level 1 Level 1

    (A few months later....) I've done exactly the same thing with regards to accidentally 'resetting the print system'. I've read through your instructions which look invaluable. However I've got the slight extra problem of not having Time Machine backup on that side of things. I've only been using Time Machine to back up my external drive of files. Now I include the MacHD drive too but the horse has already bolted.

    My Kodak 5250 printer won't show up in my Preferences when I try to add it. It shows up as being plugged in via USB but at Print Using:.. Choose a Drive or Printer Model, I just get options for Select Printer Software which takes me to an empty box, or Other which then leaves me stuck as to what to select.

    Can you or anyone help me out here? What has Resetting Print System actually done and how can I get repair it? Many thanks Paul J

  • Paul in LA Level 1 Level 1

    pajcksn wrote:


    What has Resetting Print System actually done and how can I get repair it?

    Resetting the printer system has deleted your printers. Without a time machine backup, you can either reinstall your printer, or you can attempt the instructions of member @ncprius2 on the first page of this thread. I dunno if that will work or not, because like I said before, I'm not an expert by any means. But if his instructions work, then you won't need the time machine backup of the printers. Let us know how it goes. Good luck!

  • pajcksn Level 1 Level 1

    Thanks Paul. I have reinstalled the software/drivers from Kodak but it doesn't seem to have worked. I will try the instructions as suggested.

    Thanks for getting back to me


    Paul (in Kent)

  • pajcksn Level 1 Level 1

    Well it's finally sorted. Chatted with someone from Kodak who suggested one very simple little procedure.

    After installing the Kodak software... I then needed to Reset The Printing System again. And then it appeared and now works as normal.


    Thank you for your response anyway.




  • lanhamm Level 1 Level 1

    I had used Migration Assistant yesterday from 2011 MacBook Pro to brand new 2013 Retina MacBook Pro, and though I had selected everything to be transferred, I noticed when looking at the new computer that none of the printer information was there.  Your post allowed me to pull what I needed off the most recent backup and get them set up again without having to go find IP addresses in 5 different buildings!


    Thank you!

  • sjoobn MBP Level 1 Level 1

    Paul in LA, you are a Saint! Your instructions were super clear and easy to follow, everything works. Thank you.

  • Tahtee Level 1 Level 1

    I can't even put into words how grateful I am for your help!!!!!

  • kaszkristi Level 1 Level 1

    Paul, thanks a lot for writing all of this. You are really great! I used your instruction on OS 10.7.5. It works here too! I got my printers back again. For me it was very important because Canon, producer of my printer seemed to forgot to update drivers to the next OS level. So I tried to delete it and anstall again. It was wrong! It turned out there was no new printer driver (MG2550) to newer OS. And I lost a pretty few hours trying to get it back. But - thanks to you - I did not loose not my printer. Cheers!

  • Dex18 Level 1 Level 1

    This completely worked!!!  Thank you so much!  Just fyi I have a late MacBook Air purchased in January 2012 (I think), Mac OS X 10.7.5.


    Just a note on some things I did a bit differently:


    1. I moved the cupsd.conf.O file over from my backup to my HD and just left it there, no special temporary folders.


    2. I also moved over cupsd.conf and cupsd.conf.bak files but because I did already have them in my HD (they were never deleted), I was asked if I wanted to replace the files or add them additionally.  I chose the latter (you never know).


    Then I checked my printer folder and . . . nothing.  So I was worried this wasn't going to work for me.  I just kept opening my preferences but within about five minutes, all the printers popped back into the queue.  Like magic!  So just have more patience than I had.


    I haven't tried printing anything yet but I'm so thrilled to have found this posting since so many posts on here don't seem to quite inform you what to do next.  With this step by step process, I found this pretty easy, especially for those of us that aren't quite Terminal savy.  So thanks again Paul in LA!!