Previous 1 2 3 Next 41 Replies Latest reply: Jan 20, 2015 3:03 AM by chelsea1515 Go to original post
  • ofalandon Level 1 Level 1 (0 points)

    I'm having difficulties following your instructions on my computer. I found everything up until the "etc" folder. And my Macintosh HD isn't found under "Devices". Is there another way about it? Or am I doing something wrong? Please help!!!

  • ofalandon Level 1 Level 1 (0 points)

    Nevermind! I did it! THANK YOU PAUL!!! YOU'RE AMAZING!!!

  • jimhicks8 Level 1 Level 1 (0 points)

    Awesome! I did the same thing afrter installing Mavericks. The only difference is you need to turn on the hidden files earlier, because Mavericks now hides files that were show in Snow Leopard. Thanks Paul in LA!

  • JessicaFromNZL Level 1 Level 1 (0 points)

    Please help! I think I've broken everything even more

     

    I followed you (brilliant and well laid out) instructions and got stuck at the etc. file part. Instead, I reinstalled all the printers files from my time machine back up, but still nothing in the printers.

     

    I've gone to the Brother website, downloaded all the drivers and apparently done the set up wizards fine, but still nothing. I've restarted my Mac 3 times, and nothing.

     

    Is there a crucial file that I could search for that I need to link all these together? If so, where do I put it? When I am in my time machine, I have to select the files and manually choose where to put them (rather than 2 finder windows open at once) so I can't find the correct paths easily.

     

    This is driving me crazy, I've been trying to fix this for weeks, it's 1am where I am and I'm so ready to give up!

     

    Any help would be greatly appreciated.

     

    Thanks!

  • Charles-TT Level 1 Level 1 (0 points)

    Paul, your a star... you may have written this up over 2 years ago but I just followed your specific instructions and it worked.  I have about 10 printers some very complex to get working correctly, all restored.  I have copied your notes in case I am ever stupid enough to, do this aggain.

     

    Thank you

  • Gurumaster Level 1 Level 1 (0 points)

    A couple of days ago I accidentally deleted all printers installed on my computer. I first tried the simple solution suggested by "ncprius2", but it didn't work on my machine. Then I followed the solution given by "Paul in LA" (requiring the TimeMachine backup), and everything got back to normal in a few minutes. Thank you very much - it was most useful. Best wishes.

  • Paul in LA Level 1 Level 1 (20 points)

    Hello all,

     

    I haven't been on here for awhile - but I'm glad to see that my instructions have helped many of you. Thanks for the nice comments!

     

    Paul

  • DeVa959 Level 1 Level 1 (0 points)

    Hi Paul, bought my iMac (OS X 10.9.4) only last week and today i've managed to make the same mistake :-/  I've started following your instructions but didn't get very far since i've discovered that my Time Machine is OFF...Any advice??? Thanks

  • ncprius2 Level 1 Level 1 (0 points)

    The steps in my earlier posting Restore Deleted Printers do NOT rely on any time machine backups. The cups system keeps a copy of your previous list of printers in the  printers.conf.O file in /etc/cups folder. So I would think you have nothing to loose by trying the steps in earlier posting (copied here again):

     

    Utilities -> Terminal.  In the terminal paste in, one at a time, each of the one-line commands in bold below.

    • Stop the CUPS daemon with the following command:

    sudo launchctl stop org.cups.cupsd   

    NOTE: Just type your password blindly when asked (no * echo), and hit enter key. You must logged into account with admin privs.

    • Assuming printers.conf.O is bigger (1st line), ovewrite the empty printers.conf with it (2nd line):


    ls  -l   /etc/cups/printers.conf.O   /etc/cups/printers.conf


    sudo   cp   -p   /etc/cups/printers.conf.O   /etc/cups/printers.conf


    • Optionally (I did not need to do this myself) restore cupsd.conf from the O (older) one:

    sudo   cp   -p   /etc/cups/cupsd.conf.O   /etc/cups/cupsd.conf

    • Restart the stopped CUPS daemon with the following command:

    sudo launchctl start org.cups.cupsd

     

    That's all folks. Should work with almost any mac-os-x version 10.10, 10.9, 10.8, 10.7, 10.6, even 10.5, 10.4...

  • DeVa959 Level 1 Level 1 (0 points)

    Thanks for your reply, problem is solved :-)

  • astrid71 Level 1 Level 1 (0 points)

    I don't know if anyone's still looking at this thread but things on my mac have gone from bad to worse with the printer.

     

    I had a complete destruction of my data when the power blinked on and off again a couple of times yesterday. I am on an iMac from 2011 but it had been upgraded to Yosemite.

     

    I did the safe boot, tried a disk repair but that revealed that I needed to erase the hard drive and start over.

     

    Luckily I had everything backed up on Time Machine.

     

    I have tried everything mentioned in this thread to solve my printer problem after trying everything apple says to solve the problem. I have another computer than can print to the same printer just fine, everything's connected through my wireless modem/router.

     

    I have unhidden all the folders and tried to restore the backed up CUPS files, but a dialogue pops up that asks where to put them, and the hidden folders are not shown there.

     

    I tried the second set of instructions another person suggested which was the sudo commands in the terminal, that didn't work either.

     

    At first I was getting error/inkjet 3 driver errors. Whatever I've done got rid of that but now it's just stuck in eternal pause.

     

    Is there another way to open up the files in Time Machine? I am unable to copy them or move them the only option seems to be restore but as I mentioned that doesn't allow me to move anything to hidden folders.

     

    My last hope before calling in a repair person.

  • chelsea1515 Level 1 Level 1 (0 points)

    For anyone not very techie, I too lost my printers the same way others misunderstood the deleting of the print queue.  I was too scared to play around so phoned Kodak.  They took control and I was up and running in no time at all.  Great for you guys who know what you are doing but for a senior newby to Mac  this was good for me.

Previous 1 2 3 Next