Previous 1 2 Next 18 Replies Latest reply: Oct 24, 2012 4:41 PM by CamilloL
CamilloL Level 1 Level 1 (0 points)
Where the characters should be, blanks are displayed. This is a serious problem for me because, while I use Monaco in my terminal, the fallback font for Japanese characters is Hiragino, which is an OpenType font: as a result, Japanese text is not visible in my terminal.

Here is a screenshot: http://i.imgur.com/wlNPV.png
Note that, since I set the system's language to Japanese, most of the text in Terminal's preferences is also invisible.

The problem only seems to occur in Terminal.app, and does not affect other users on the same machine (I tried logging in as guest). It occurs with all OpenType fonts I tried, not just Japanese ones.

Strangely, if I delete Terminal's preferences, the problem almost disappears (except that it still says ル in the window's title bar instead of ターミナル); however, if I close and relaunch Terminal, the problem immediately reoccurs, even though the preferences file is pristine.

I tried resetting the ATS cache (atsutil databases -remove) and restarting in safe mode, but the problem still occurs. I've tried googling around, and I found some other people mentioning the same problem, but no solution. Can you help?

MacBook, Mac OS X (10.6.6)
  • Linc Davis Level 10 Level 10 (153,365 points)
    You seem to be saying that everything is completely normal in the guest account, but not in your account. Do you have any fonts installed in your home Fonts folder that might conflict with the system fonts? If not, move your entire Library folder aside. Log out and back in. Recreate your font preferences in Terminal and verify that it works. Then start adding back the stuff you removed, testing as you go along until you find the culprit.
  • CamilloL Level 1 Level 1 (0 points)
    I have some fonts in my home, but none that conflict, according to Font Book. To be honest, I am a bit concerned that resetting the entire Library might cause additional problems, even if I later attempt to set it back. :/

    BTW, I just noticed that it's not entirely true that only Terminal.app is affected. As you can see in the picture linked below, the ー character in キーチェーン is not visible in the title bar of Keychain Access, though the same word is displayed correctly in the line below. Very strange.

    http://imgur.com/bz4fK
  • Linc Davis Level 10 Level 10 (153,365 points)
    +I am a bit concerned that resetting the entire Library might cause additional problems, even if I later attempt to set it back.+

    Then create a new user account and copy your Library folder (and whatever else is needed to reproduce the problem) to it, changing the ownership to the new user. Don't do anything in the test account besides launching Terminal.
  • CamilloL Level 1 Level 1 (0 points)
    Hmm, interesting. I just installed GPGTools (http://www.gpgtools.org/, version 2011.03.02) and the problem now occurs in Mail.app too. I had also installed Xcode 4 just before. Let's see if removing GPGTools fixes it.
  • CamilloL Level 1 Level 1 (0 points)
    Removing GPGMail.mailbundle solved the problem in Mail.app! Now to find out how it caused it in the first place...
  • rémi Level 1 Level 1 (0 points)

    Hi,

     

    I have the same problem. Japanese fonts in terminal don't work any more in my account, but they work correctly in the guest account. I tried removing com.apple.Terminal.plist and re-logging as advised elsewhere on this board, but it did not work.

     

    I also installed Xcode 4 recently.

     

    The suggestion of moving my Library folder sounds really scary. If anyone has a better solution, that would be welcome.

     

    Rémi

  • Tom Gewecke Level 9 Level 9 (74,655 points)

    The suggestion of moving my Library folder sounds really scary.

     

    You can try moving your folder Home/Library/Fonts to your desktop.  No harm can come from that.  Same for Home/Library/Preferences.  If no improvement, just put them back.

  • CamilloL Level 1 Level 1 (0 points)

    Apple has just released a Snow Leopard Font Update. It sounded promising, but after installing it I am sad to report that nothing has changed. OpenType fonts still don't work in Terminal.

  • mathieufromchambery Level 1 Level 1 (0 points)

    I've got the same problem with my new MBP 2011 with Snow Leopard and it really annoys me as I'm dealing with multilingual texts every day.

     

    What surprises me is that I had no problems at all since MacOs 10.1 and now it appears in 10.6 !

    Back in the old days I had to put a .inputrc file for displaying Japanese characters but that was not a big deal.

     

    When I create a new account, it works for a few hours (Japanese characters display well even with menlo or courier fonts set as default). But after a few manipulations here and there (that do not seem related to terminal or fonts like setting my iTunes account) and a couple of reboots, the problem reappears again, ie the Japanese characters do not display again.

     

    I can temporarily solve the problem by using the Osaka font but 1 it is not nicely displayed with irregular spaces between characters and 2 when I want to display other characters (thai, khmer or whatever), I have to change the default font again. This is a real pain in the neck.

     

    I read in another thread that there is a solution to convert the OpenType Font you wish to use into a TrueType font but it is not a solution for me neither as there is no existing font that covers all the unicode characters.

     

    Is Apple aware of this bug? Did they acknowledge that there is a problem?

     

    If someone finds a solution, I'll be really happy.

  • CamilloL Level 1 Level 1 (0 points)

    Apple is aware of the bug; I submitted it last year (rdar://8724546). They have not reacted to it so far. Posting more reports to bugreport.apple.com would probably help them devote some engineering resources to this problem. I don't think we're ever going to see a fix for Snow Leopard, but at least I hope we won't have to suffer the same bug in Lion!

  • rémi Level 1 Level 1 (0 points)

    Tom Gewecke wrote:

     

    The suggestion of moving my Library folder sounds really scary.

     

    You can try moving your folder Home/Library/Fonts to your desktop.  No harm can come from that.  Same for Home/Library/Preferences.  If no improvement, just put them back.

     

    Thanks for your suggestion. I tried it, and moving Preferences solves the problem. But, of course, I lose all my preferences, which is very annoying, and not really acceptable. I tried moving only com.apple.Terminal.plist, but it does not work. Now, I have 389 files in my Preferences directory, and finding the culprit among them will be very tedious. I know binary search should take only 9 iterations, but that is still very annoying to do.

     

    I wonder if anybody has made progress with this bug.

     

    Thanks,

     

    Rémi

  • CamilloL Level 1 Level 1 (0 points)

    I am sorry to announce that the problem is still present in Lion. This is really disheartening.

  • rémi Level 1 Level 1 (0 points)

    One year later, this bug is still making me crazy. Has anybody made progress? Can anybody suggest a solution?

     

    Thanks.

  • etresoft Level 7 Level 7 (26,140 points)

    rémi wrote:

     

    One year later, this bug is still making me crazy. Has anybody made progress? Can anybody suggest a solution?

    Can anybody even reproduce it?

     

    Screen Shot 2012-03-30 at 9.21.15 PM.png

Previous 1 2 Next