Previous 1 2 Next 18 Replies Latest reply: Oct 24, 2012 4:41 PM by CamilloL
CamilloL Level 1 (0 points)
Where the characters should be, blanks are displayed. This is a serious problem for me because, while I use Monaco in my terminal, the fallback font for Japanese characters is Hiragino, which is an OpenType font: as a result, Japanese text is not visible in my terminal.

Here is a screenshot:
Note that, since I set the system's language to Japanese, most of the text in Terminal's preferences is also invisible.

The problem only seems to occur in, and does not affect other users on the same machine (I tried logging in as guest). It occurs with all OpenType fonts I tried, not just Japanese ones.

Strangely, if I delete Terminal's preferences, the problem almost disappears (except that it still says ル in the window's title bar instead of ターミナル); however, if I close and relaunch Terminal, the problem immediately reoccurs, even though the preferences file is pristine.

I tried resetting the ATS cache (atsutil databases -remove) and restarting in safe mode, but the problem still occurs. I've tried googling around, and I found some other people mentioning the same problem, but no solution. Can you help?

MacBook, Mac OS X (10.6.6)
Previous 1 2 Next