Previous 1 37 38 39 40 41 Next 962 Replies Latest reply: Sep 15, 2014 6:52 AM by miroslavfromprague 9 Go to original post
  • mfwells Level 1 Level 1

    Thanks for the follow up.


    Did provide Apple feedback, a few posts ago. I will copy and paste my latest post to the feedback form and send it as well.


    I will consider doing a clean install and update. I am on 10.6.7 now. I am very concerned about the amount of time this is going to cost me, as I have an XP environment set up to run in a Parallels environment, a few apps. there, which get used rarely but are critical to my needs. Restoring that to the system might become problematic. Before going to this extreme, I would want to know for certain that it would fix the problem Nothing I've read in the forums as yet gives me comfort that this is going to fix it.



  • noahfrommissoula Level 1 Level 1

    All I can say, Mike, is that I talked to a tech yesterday in Wisconsin. He ran into the same issue I had an a manual migration worked for him. Thusfar, it's working for me to.


    I also cost me a lot of time and probably hundreds of dollars. If I had known that I could not use the usual fail safe migration assistant I probably not have made the purchase yet.  Good luck; I'll report back on the forum if my wifi connection goes again.


    Good luck,


  • ThExSenatoR Level 1 Level 1

    Hey guys,

    I suggest not to rush into a complete system reinstall. My macbook pro came with a clean system as all of your machines, and I didn't migrate anything, just copied all my stuffs by hand back. My wireless network consists of 2 Airport Extremes (AEBS 1: Router Dual-Band, AEBS 2: Simultaneous Dual-Band II as Wireless Bridge), everything connected to Linksys Gigabit Switches. Take a look to my ping stats from MacBook Pro:


    Pinging my NAS which is a Mac Pro wired to the Gbit ethernet switch:

    MacBook-Pro:~ senator$ ping naspro

    PING naspro.local ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=64 time=0.858 ms

    64 bytes from icmp_seq=1 ttl=64 time=1.274 ms

    64 bytes from icmp_seq=2 ttl=64 time=1.054 ms

    64 bytes from icmp_seq=3 ttl=64 time=1.656 ms

    64 bytes from icmp_seq=4 ttl=64 time=1.125 ms

    64 bytes from icmp_seq=5 ttl=64 time=1.138 ms

    64 bytes from icmp_seq=6 ttl=64 time=4.760 ms

    64 bytes from icmp_seq=7 ttl=64 time=1.033 ms

    64 bytes from icmp_seq=8 ttl=64 time=3.686 ms

    64 bytes from icmp_seq=9 ttl=64 time=1.001 ms

    64 bytes from icmp_seq=10 ttl=64 time=3.643 ms

    64 bytes from icmp_seq=11 ttl=64 time=1.092 ms


    --- naspro.local ping statistics ---

    12 packets transmitted, 12 packets received, 0.0% packet lo



    MacBook-Pro:~ senator$ ping

    PING ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=56 time=17.232 ms

    64 bytes from icmp_seq=1 ttl=56 time=19.878 ms

    64 bytes from icmp_seq=2 ttl=56 time=19.720 ms

    64 bytes from icmp_seq=3 ttl=56 time=19.884 ms

    64 bytes from icmp_seq=4 ttl=56 time=21.854 ms

    64 bytes from icmp_seq=5 ttl=56 time=20.226 ms

    64 bytes from icmp_seq=6 ttl=56 time=20.022 ms

    64 bytes from icmp_seq=7 ttl=56 time=22.838 ms

    64 bytes from icmp_seq=8 ttl=56 time=19.869 ms

    64 bytes from icmp_seq=9 ttl=56 time=20.805 ms

    64 bytes from icmp_seq=10 ttl=56 time=24.267 ms

    64 bytes from icmp_seq=11 ttl=56 time=20.088 ms

    64 bytes from icmp_seq=12 ttl=56 time=19.906 ms


    --- ping statistics ---

    13 packets transmitted, 13 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 17.232/20.507/24.267/1.638 ms


    These ping were horrible before the software and efi update released several weeks ago.


    Now here comes the surprise!


    Pinging my MacBook Pro FROM THE NAS:

    naspro:~ serveruser$ ping

    PING ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=64 time=0.846 ms

    64 bytes from icmp_seq=1 ttl=64 time=0.961 ms

    64 bytes from icmp_seq=2 ttl=64 time=262.469 ms

    64 bytes from icmp_seq=3 ttl=64 time=1.012 ms

    64 bytes from icmp_seq=4 ttl=64 time=1.889 ms

    64 bytes from icmp_seq=5 ttl=64 time=1.043 ms

    64 bytes from icmp_seq=6 ttl=64 time=293.299 ms

    64 bytes from icmp_seq=7 ttl=64 time=280.435 ms

    64 bytes from icmp_seq=8 ttl=64 time=204.397 ms

    64 bytes from icmp_seq=9 ttl=64 time=124.082 ms

    64 bytes from icmp_seq=10 ttl=64 time=315.377 ms

    64 bytes from icmp_seq=11 ttl=64 time=274.558 ms

    64 bytes from icmp_seq=12 ttl=64 time=195.525 ms

    64 bytes from icmp_seq=13 ttl=64 time=44.231 ms


    --- ping statistics ---

    14 packets transmitted, 14 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 0.846/142.866/315.377/125.363 ms


    Interesting... isn't it? Pings do not depend on which wireless network I use (2.4 GHz or 5GHz)


    However I never noticed a single drop in the connection (since 3 months I have the machine), and I used previously Linksys Wireless Access Points.


    Card Type:                     AirPort Extreme  (0x14E4, 0xD6)

    Firmware Version:          Broadcom BCM43xx 1.0


         Boot ROM Version:          MBP81.0047.B0E

         SMC Version (system):     1.70f3

  • Tagecho Level 1 Level 1

    Test  When i connect my Access Point D-link DAP1360 to the ethernet port as a wireless client mode the wifi connection is normal and watching youtube video without problem.



  • Power.User Level 1 Level 1

    I had the same problem since January but I think I found a solution (at least to my MBP, so yours might work as well). It's been over a month and no random drops like before. I still experience occasional drops once a week or so. The internet speed feels still a bit slow to me but this may be my ISP's problem.


    Here's what I found as my 'solution':

    By default, in your System Preference > Network > AirPort > Advanced > TCP/IP, the setting for configuring IPv6 (Internet Protocol version 6) is set to "Automatic". I turned this to "Off".


    Simple and it works great!


    Please let us know by posting your result.


    FYI, here's an interesting article about IPv6:

    It looks like Apple took care of IPv6 too early while most of our routers don't support IPv6 yet.


    Happy WiFi-ing!

  • mfwells Level 1 Level 1

    Well I tried your suggestion. And it seems like it would be something that could cause this sort of behavior. But NOOOOO. NO JOY! And I was so hopeful too. Same behavior as before. Darn.


    This problem is just so darn flakey. Can't seem to find a a specific set of circumstances, environment, etc. that is identifiable, repeatable. Only thing that remains constant is that this is annoying the heck out of me.

  • justinfromegham Level 1 Level 1

    New to Macs, with a MBPro 13 i5 purchased 2 weeks ago.


    Wireless connections at home appalling--it kept dropping off.  I dispensed with the ISP's own router (BT homehub2) and bought a DrayTek Vigor 2710n (pretty much all singing and dancing).


    Still the same issue.  Tried different channels, avoiding the other locally-used channels.


    Today, I switched off the n-mode at the router, to use b and g only.  Sorted.  There is a high noise level locally, and my instinct is that the Mac can't cope with this for some reason in n-mode.  I could avoid interference by using channel 13, but of course that is inhibited in the MBPro as the AirPort country code is set as TW!!!

  • noahfrommissoula Level 1 Level 1

    My problem is back after a few days running a fresh system with updates. My iPad works flawlessly. This really does seem to be an issue that needs to be addressed.

  • mfwells Level 1 Level 1

    I kinda thought that would be the outcome. Too many others are having problems right out of the box from the Apple store in order for this to be a wipe/restore problem. I was reluctant to apply this though early-on it seemed promising.


    I have downloaded a tool iStumbler, which gives me a readout on signal and noise levels in a histogram for any channels the airport card sees. It will be interesting to see if there is any correlation between the times my WiFi connection goes south and the signal/noise levels on my channel and adjacent channels.


    It's worth a try, I am running out of ideas and bits to twiddle on the MBP.



  • mfwells Level 1 Level 1

    I've been running only b/g router, so problem seems unrelated to n.


    I am running iStumbler now to monitor my channel and adjacent channels for signal and noise levels. I am going to try and correlate poor link performance period when I drop connections with other activities on WiFi channels that might be causing interference.


    One thing we know from prior posts is that other WiFi devices, iPad, Iphone, PCs, etc. sitting right next to each other work fine and the MBP fails. So, if this is a signal/noise problem that can be correlated with the histograms, it would seem to indicate the MBP has problems working in noisy environments that other devices do no. This would lead to the assumption that the MBP has a hardware/firmware/software bug. Now, given that my system worked reliably until OS updates a few revs ago - we conclude this rules out hardware, leaving firmware/software as the culprit.

  • noahfrommissoula Level 1 Level 1



    What system were you working on when things worked? I'm currently enroute to Nigeria, Sri Lanka and Amdagascar and I might have an assistant mail me an older os install. I went to the apple store twice and now I'm out on assignment and with no wifi. It's nearly disastrous to my work.  If anyone from apple is listening, please give us a fix for this. I'm happy to pay to download from my sat phone. I just need a working system; I'm missing deadlines and trying to send files from my iPad.



  • mfwells Level 1 Level 1

    To my best recollection, last time this worked reliably was back at version 10.4. But to be honest with you, I wasn't really thinking about this problem much until the past couple months. Anyway, I do know that it worked quite well at one time, and now it doesn't.

  • noahfrommissoula Level 1 Level 1

    Thanks, mwells. I'm really hoping for a fix when 10.7 comes up. If so, there is a strong case for many of us to receive a free update but, honestly, with all the hassle, I can't be bothered with that. I'm on deadline constantly and the solution of sending files to my iPad and then sending them out that way - to ftp servers and elsewhere - is just ridiculous and time consuming.


    It would be interesting to see if anyone else with the issue has rolled back, doing a clean install to 10.5. It might be worth it.



  • mfwells Level 1 Level 1

    I feel you. I spent some time between other chores today trying to get some correlation to the behaviors and measurements I'm seeing with iStumbler and by clicking "option-click" on the airport icon. Some conclusions:


    1.     I can be sitting in exactly the same location, getting 54 mbps bit rate on a -60 RSSI level. Minutes later, exact same location, nothing else changes, and the link can go to -70 RSSI or lower (e.g. -75 etc.) and the bit rate can go to 1. Connections for email and Safari are useless.


    2.     I can turn airport off/on/off/on several times and eventually (some times) get back a reasonable connection with reasonable RSSI and bitrate. Sometimes no amount of doing the off/on/off works. I just reset the computer and start again.


    3.     The "bars" on the airport icon are pretty much useless. I've had all bars showing and the link rate only reporting 1 mbps. Go figure.


    No rhyme or reason to the above. No reason for it to occur.


    I have noticed that even when the connection being reported by the "option-airport icon" click gives me these readings, the iStumbler histogram barely budges. It shows signal at 43% and noise at 10% TO 15%. Sometimes there's other networks that show up, but they are on different channels. I have channel 4, they are on 7 and 11 when they show up (which is rare).


    I agree with you this is getting very frustrating and has been going on far too long. Just wishing Apple would do something someday. I'm in no position to rollback to earlier versions of OSX and see if it reverts to good operation, so only my recollection on my end.




    So even when the airport connection goes down and option click on the airport icon reports lousy RSSI and bitrate, the iStumbler reports statistics that indicate the connection should be working.

  • thorsten_79 Level 1 Level 1

    I had exactly the same problem with an 2007 MacBook white. But I was able to "solve" it by using the kext-files related to the wifi card from 10.6.4. Unfortunately this is not possible with 2011 MacBook Pros, because the wifi driver for them was introduced in 10.6.6 ...

    So roll back to 10.5 is definetely not possible ...

    I have now a new router which seems to deliver a stronger signal and works better, but still not perfect. I use the 450 Mbit Linksys E4200 now.


    I start to loose my hope that apple will ever solve this! So I can just recommend to everybody that if you have a problem like this and you are still in the 2 week period, give your macbook back!!! And buy something different or a Macbook air which does not have this problem.


    Very bad support from Apple!!!

Previous 1 37 38 39 40 41 Next