Previous 1 2 3 Next 68 Replies Latest reply: Apr 17, 2011 2:55 PM by danel k
a Mac user Level 3 (715 points)
I was originally using this on the day the GM was released to developers, I used it for a few hours that day and after that it has not worked. I have tried on different wifi networks and tried removing all the settings for it on both my iPad and MBP and restarting the process and it still does not work. I get the message "Cannot connect to media library". I was really excited for this because now my 16GB iPad is more useful anywhere on campus instead of just in vicinity of my MBP.

I have also tried reinstalling iTunes and the iPad firmware, nothing seems to change. Turned off firewall settings and that did not change anything either.

Anyone else running into this problem?

16MHz Mac LCII, Mac Clones, 1.8Ghz iMac G5, MBP 2.53Ghz Late 2008, iPad 3G, Mac OS X (10.6.6), Mac Developer
  • BanditoB Level 1 (70 points)
    I'm seeing it too. I first upgraded my iPhone to 4.3 and then tried Home Sharing on it and everything seemed to work just fine. I then upgraded my iPad and tried Home Sharing and got the "Cannot connect to media library" error. Next, I tried to connect the iPhone to my iTunes library again and it got the same error message.
    I then restarted iTunes and both the iPhone and iPad connected, but when attempting to play media it would appear to start playing and then immediately stop. Any attempt to stop home sharing and then reconnect gets the media library error.
    When I get a chance, I'll reboot my MacBook Pro to see if that makes any difference, but it seems pretty flakey right now. It'll be interesting to see how it goes with my iMac at home this evening.
  • Johnathan Burger Level 6 (15,882 points)
    Do you have the newest version of iTunes-10.2.1(released the .1 version yesterday)?

    Homesharing is working well for me, no issues at all.
  • Richey112 Level 1 (0 points)
    I am having a similar issue. I can connect to my Imac library with both my Ipad and Iphone and the thumbnails populate. When I first accessed a movie from my library it played. the second movie and every one since then wont. I get a message one my ipad that states "This movie could not be played". on my iphone I get, "the movie format is not supported". If I sync the moveis to either device they play fine and they also play fine when streamed to my appleTV. Any help would be appreciated.
  • a Mac user Level 3 (715 points)
    Yep, installed it after it stopped working.
  • Kosimo Level 1 (10 points)
    I'm having exactly the same issue. I'm using iTunes 10.2.1 and iOS 4.3 in my iPhone 4. My MacBook Pro is connected thru an ethernet cable to the Airport Extreme base, and the iPhone 4 wireslessly to the same Airport Extreme base. Once configured in the iPod settings in the device and in the advanced menu in iTunes I get the Shared option inside the iPod app, but once i tap the option I get the message:

  • a Mac user Level 3 (715 points)
    I've tried via ethernet and via wifi on my MBP. Like I said now neither work, but when it was the first day it was both on wifi.
  • Kosimo Level 1 (10 points)
    I could make it working: This is what I did.

    1) Open the iPod App without opening iTunes. (You won't see the Shared Option)

    2) Open iTunes

    3) You'll see that the Option Shared appears

    4) Hit it and wait 'till it connects.

    I don't know if this can help you, but at least I've got it working.

    Regards from Barcelona
  • a Mac user Level 3 (715 points)
    that seems to have done it. Going to try a reboot and connecting without having to open iPod app then launch itunes.
  • a Mac user Level 3 (715 points)
    Whatever wizardry was involved in that process it seems to work now. I swear I have tried this before.
  • Kosimo Level 1 (10 points)
    We're probably suffering from an unpolished feature. I'm sure that this will be fixed in future revisions of iTunes or iOS... Anyway, I'm glad to know that at least is working for both of us
  • Fred Tedsen2 Level 1 (45 points)
    Here' what I get:

    I have two computers on the network that I have enabled for Home Sharing. My iPad will see each of them, but only one at a time. Furthermore, if it sees #1 but I want it to see #2, I have to quit iTunes on both #1 and #2, then restart iTunes on #2. The only way I can get it to use #2 is to have iTunes off on #1 when I run iPod or Videos apps on the iPad.
  • zwei Level 2 (265 points)
    I had to turn off home sharing and re-enable it in iTunes. Started working after that.
  • Richey112 Level 1 (0 points)
    this has been marked as solved, but none of the solutions here have worked for me. I still get the message that this movie can not be played when accessing home sharing from my ipad. any other ideas?
  • Terpdog Level 1 (0 points)
    I'm not having any luck either. Works for Music fine for I see nothing for video's. The interesting thing is that my iTouch sees the video's fine but the iPad does not.

    It works great on my iTouch but my iPad is not even seeing any videos. iTunes is running on a Windows XP machine and all of the videos I've actually synced to the iPad and they run from the iPad w/out any problem. But the video share is FUBAR.
Previous 1 2 3 Next