Previous 1 2 3 4 5 Next 68 Replies Latest reply: Apr 17, 2011 2:55 PM by danel k Go to original post
  • canitrustmac Level 1 Level 1 (10 points)
    By "iPod App" are we talking on the iPad or desktop / MBP? This is driving me insane I even tried turning off firewall completely, no dice. I typically run Skype / Transmission / DropBox, is there a way to reset all firewall defaults, get iOS 4.3 to share my iTunes library without further glitches. My iPad is laughing at me after weeks of anticipation. Help!

    Mac OS X 10.6.6, iMac 20" 2.4 Ghz / 4gb RAM
    iPad 1, 16gb Wi-Fi iOS 4.3 + all iTunes / Java / iOS updates
  • PhantomApple Level 1 Level 1 (0 points)
    I'm having the same problems ever since I updated to 4.3 on my iPhone, 4.2 on my Apple TV, and 10.2.1.1 on iTunes. I think there is a bug here.
  • David Bernier Level 1 Level 1 (10 points)
    PhantomApple, I thought I had the same problem with the iPod App, no video shows up. However, at least in my case, starting the Videos App provides the capability through the Shared tab at the top of the first screen. Under that tab all of my video appears
  • Terpdog Level 1 Level 1 (0 points)
    One I select the share from videos nothing shows on the iPad but it works on the touch.
  • canitrustmac Level 1 Level 1 (10 points)
    Yes, yes, yes- and I'm pulling my hair out over it. Shut off my firewall, no dice. Restarted iTunes on the iMac, rebooted the iPad 4.3. Can get on web / email on iPad, but get the same error message. I open the ipod app on ipad, even tried the 'Remote' app on the iPad, still nothing. Does having both apps have any thing to do with it? Which would I be expected to use on iPad for results? iPod or Remote?
    The long / short of it is I can connect to web / email / updates on iPad, but "Cannot Connect to Media Library"
  • Dah•veed Level 7 Level 7 (32,795 points)
    Have you signed into your iTunes account in Home Sharing on both your Mac and on your iPad?


    Dah•veed

  • inshany Level 1 Level 1 (0 points)
    I am encountering the same issue both on my iPhone 4 and iPad (1st gen) both with iOS 4.3. iTunes on both of my macs is 10.2.1 — the odd thing is that I see both macs using Home Sharing on my Apple TV (2nd gen).

    Also could someone please remove the “Solved” mark from this topic. It is not resolved and none of the solutions offered worked.

    Cheers.

    EDIT: I just launched the remote app on both my iPhone 4 and iPad. All my Home Shared macs show up in it. So why is it not working with the iPod (on iPhone 4) and iPod/Videos (on iPad) app? Very, very strange.

    Message was edited by: inshany
  • a Mac user Level 3 Level 3 (715 points)
    User requested I mark this back as unanswered. My problem has been resolved, I am leaving this open and will continue with any suggestions I might have to help.
  • dmbfan Level 1 Level 1 (0 points)
    Same problem here. Cannot Connect to Media Library. I've tried all the tips in this thread, no luck. iPad and iPhone 4, + iTunes, all fully patched/up to date.

    I keep my media on an external drive...any chance this has anything to do with it? What are your experiences?

    I was looking forward to this feature...I'll be annoyed if I can't use it.
  • Terpdog Level 1 Level 1 (0 points)
    I have same issues but my drive is not external
  • dmbfan Level 1 Level 1 (0 points)
    Okay, I got it to work. I rebooted (again), after first turning off home sharing. Deleted my credentials from iPad and iPhone (Apple ID and Password). Turned off local sharing and Home Sharing updating playcounts on the Sharing tab.

    After rebooting all devices, I signed back in to Home Sharing on iTunes, re-enabled local sharing and playcount updating. Then, updated iOS devices with username and password again. That seemed to work for me.

    Good luck!
  • Dah•veed Level 7 Level 7 (32,795 points)
    I have my media library on an ext HDD with no issues.

    Tell us the steps that you have taken;
    1. On the Mac
    2. On the iOS devices
  • Demo Level 10 Level 10 (85,655 points)
    *By the time I finished this post, the star was removed.* SORRY BUT IT DOESN'T WORK THAT WAY BECAUSE YOU ARE STILL HAVING A PROBLEM. Please let me rant here David.Austin.Allen - I know that you know the ropes. Users get a little snitty when they encounter a problem, Nobody has the patience to sit down, think it through and do a little work on their own. The OP was nice enough to remove the star so kudos to him. I am not that forgiving.
    inshany wrote:
    Also could someone please remove the “Solved” mark from this topic. It is not resolved and none of the solutions offered worked.

    Yes the question IS answered as far as the OP is concerned. None of the issues worked for you but you didn't post the question so you can't make the assessment that the issue is not resolved. This discussion site doesn't revolve around you. Only the OP can mark the question as answered so if the issue is resolved to his or her satisfaction, the OP marks the question answered. Frankly, I am more put off by questions that are answered to the satisfaction of the OP, but never marked as such.

    If you are still having an issue, post another question. Just change the wording to be more specific to your needs.

    However, It worked flawlessly for me no problems at all. and here what I did after updating to iOS 4.3 tonight.

    Make sure that you have downloaded the most recent update to iTunes 10.2.1. (You did say that you have but just making sure) Launch iTunes on your computer. Select preferences from the drop down menu. Then click on sharing in preferences. Select Share my library on my local network and select either -Share Entire Library or any of the items that you want to share. Also make sure you have Home Sharing enabled in iTunes on your computer. (I assume you do if your Apple TV is using this function.)

    On your iPad, tap settings then, tap iPod and enter your Apple I.D. and password on the right side and you should be good to go.

    When you open the Videos App there is a Shared Button at the top. Tap that and your library will appear. Tap on your library and all of the videos, TV shows etc in your iTunes library should appear. In the iPod app, tap Library at the top left and you have the option to select my iPad or your library. If you select your library, all of the media in iTunes on your computer should be available.

    If it still isn't working, reboot your iPad and your computer and try again.
  • Dah•veed Level 7 Level 7 (32,795 points)
    You may call me Dah•veed.
  • Mark Levine Level 1 Level 1 (0 points)
    I was having the exact same issue at the beginning. A simple close/open of iTunes on the computer, then a hard reboot of the iPad did the trick. I'm guessing that just the hard reboot of the iPad was really what was needed. Good luck to everyone - it's very cool when it works!