Previous 1 2 3 4 5 Next 68 Replies Latest reply: Apr 17, 2011 2:55 PM by danel k Go to original post
  • derek ryba1 Level 1 Level 1 (95 points)
    Same problem! No matter what I do, 4.3 Home Sharing does not work with my iPhone4. This is ridiculous. Apple should have tested this silly feature on Windows 7!
  • Terpdog Level 1 Level 1 (0 points)
    Yep, everything works great on my iTouch but my iPad I see the library where the videos should be. I select that and no videos. It's weird how the iTouch worked flawlessly but the iPad which would be a better way to watch videos did not.

    XP machine with iTunes(latest) all home sharing turned on(otherwise the iTouch wouldn't work) iPad(latest) update. Music works fine on the iPad just not video.
  • iPadKisser Level 1 Level 1 (10 points)
    Me2..

    Obvious bug or a software update issue....
  • David Lounsbury Level 1 Level 1 (0 points)
    Have the problem "Cannot Connect to Media Library" to my MacBook Pro running 10.6.6 from both iPad and iPhone 3GS, both freshly upgraded to 4.3. I've re-entered the ID and password on both the iDevices, done hard reboots, and disabled and re-enabled Home Sharing on the MBP - no luck.

    The network connectivity is fine - the Remote app works and the devices can see each other - they just can't connect.

    Looks like a fix for this will need to come from Apple.
  • maury Level 1 Level 1 (5 points)
    Go to security settings in system preferences and make sure firewall is turned off. That is what fixed my issue!
  • a Mac user Level 3 Level 3 (715 points)
    Doing that actually made my problem worse.

    I am guessing you have turned off your iPads, then quit iTunes, turned the iPads back on and then opened the iPod app, then opened itunes?
  • Richey112 Level 1 Level 1 (0 points)
    I am giving up on this. I have tried everything. Firewall etc and nothing works. I can see the movies in the library but I get an error that the movie cant be played. I guess I will wait for an update.
  • canitrustmac Level 1 Level 1 (10 points)
    I think if Appl could code a utility that will reset all firewall settings, sharing etc. to fix this issue, that would be great. A one-shot tool that runs a routine and solves this once and for all.
  • BDHTX Level 1 Level 1 (0 points)
    My issue may be along these lines...

    I can connect and find my shared library, but whenever I access it, it takes forever to load the content. This happens with videos and or music. (I have a lot)

    Many times it hangs and nothing comes up.
  • sparkus Level 1 Level 1 (10 points)
    I have the exact same issue, but my iPhone 4 connects just fine and even loads quickly. It is only the iPad which freezes when trying to load the library. In fact, often I have to reset the iPad because it becomes unresponsive, but only when trying to load the library via AirPlay.
  • prettyvexed Level 1 Level 1 (0 points)
    Does anyone know if I can use the Remote App instead of the iPod App to have music streamed to my iPhone?

    When I tap "Shared" under "Settings" in my Remote App, it takes me to a house with a music symbol in it, and the print below it reads: "Remote will automatically find the iTunes libraries and Apple TVs that have Home Sharing turned on using the account...." and then it gives my account name.

    Well ok then. But I don't think it's finding the library.

    Home Sharing works fine when I use my iPod App. I get my entire library delivered straight to my phone. However, it doesn't shuffle by Album, which is the shuffle I prefer. Instead, it only shuffles by song.

    I've always had the capability of shuffling by album when using the Remote App. That's why I want to use the Remote App.

    I have home sharing turned on in the Remote App. It asked me for account name and password, just like it did for the iPod App. Isn't this functionality also built into the Remote App? And if note, why is it giving me the option to turn Home Sharing On in the first place?

    I've got all the latest updates.
  • David Lounsbury Level 1 Level 1 (0 points)
    I have been trying to get this debugged, and while I don't have an solution, I thought I'd at least post my debug steps in case it helps others eliminate possibilities. There's an interesting hint on Mac OSX Hints at <http://hints.macworld.com/article.php?story=2011031019381274> that I may try next.


    Home Sharing debug

    Environment:

    Laptop: MacBook Pro 2011, i7, Running OS X 10.6.6. iTunes 10.2.1 (1)
    Server: G5 Running OS X 10.5.8, iTunes 10.1.2 (17)
    iPad 3G 64GB, iOS 4.3
    iPhone 3G 16GB, iOS 4.3
    Apple TV (v2) running 4.1.1

    All Home Sharing IDs set the same.

    *Problem Description*: Connecting to Laptop library shows up in Home Sharing, but attempting to connect from either iPad or iPhone always yields "Cannot Connect to Media Library". 100% reproducible.

    (Connecting to G5 yields "Cannot Connect to Media Library" - Home Sharing requires iTunes 10.2 or better". This is expected behavior after 4.3 update.)

    *Remedies tested*:

    Re-entered ID an password on all devices (unlikely since the libraries show up in home sharing) - no change
    Disabled and re-enabled Home Sharing on laptop - no change
    Restarted iTunes - no change
    Hard reset on iPad - no change
    Laptop, iPad and iPhone all on same physical WifI neterok (remove router from consideration) - no change
    Firewall off - no change
    Firewall on - no change

    *Apple TV testing*:

    Apple TV can see and connect to G5 library. Sees Laptop library but connection attempt gives spinning gear of death for 2+ minutes - gave up.

    Note: Apple TV software update released & installed 3/11/11. Retested.
    Apple TV can still see and connect to G5 library. Connection to Laptop library immediately fails with "Could not connect to 'Laptop Media' - Make sure computer has iTunes open and that it's on the same network as the Apple TV"."

    Did Software Update on G5 - installed iTunes 10.2.1. iPad can now connect and play all media. Apple TV can still connect to G5 per above..

    Conclusion: Successful test with G5 and Apple TV results eliminate iDevices, network, and iTunes 10.2.1 itself as source of problem. Problem is something unique to laptop install/setup. Possibilities are bad iTunes install, 64 bit kernel mode, permissions, others?

    iTunes Install: Re-downloaded and reinstalled. No change.

    Permissions: (OK this is voodoo but always worth a try.)

    64 bit:

    Rebuild iTunes library ID XML:
  • rigormortis Level 2 Level 2 (225 points)
    im having some trouble with home sharing.

    selecting the computer will not retrieve the library, on occasion have to hard reboot the ipad

    my own files i encoded and dragged in movies on the share sometimes show up on the ipad as the wrong file name/ and wrong thumbnail, and if you scroll up or down on the ipad a couple times, that issue goes away. and you have to keep repeating scrolling up and down to get the correct filename/thumbnail

    in the itunes library i have 97 movies, 2 days, 20 gigabytes



    using ipad 1, ios 4.3, windows 7 ultimate, itunes 10.2.1

    Message was edited by: rigormortis
  • rigormortis Level 2 Level 2 (225 points)
    the iphone does not seem to have this issue. btw
  • canitrustmac Level 1 Level 1 (10 points)
    Dah•veed- Yes both are signed in. To clarify, iPod actually show's 'library' by name in iPod app, but 'cannot connect to library' is the condition. Is there a plist file that can be deleted, then recreated for a fresh start?