Skip navigation

4.3 HomeSharing

30814 Views 68 Replies Latest reply: Apr 17, 2011 2:55 PM by danel k RSS
1 2 3 ... 5 Previous Next
a Mac user Level 3 Level 3 (715 points)
Currently Being Moderated
Mar 9, 2011 12:21 PM
I was originally using this on the day the GM was released to developers, I used it for a few hours that day and after that it has not worked. I have tried on different wifi networks and tried removing all the settings for it on both my iPad and MBP and restarting the process and it still does not work. I get the message "Cannot connect to media library". I was really excited for this because now my 16GB iPad is more useful anywhere on campus instead of just in vicinity of my MBP.

I have also tried reinstalling iTunes and the iPad firmware, nothing seems to change. Turned off firewall settings and that did not change anything either.

Anyone else running into this problem?
16MHz Mac LCII, Mac Clones, 1.8Ghz iMac G5, MBP 2.53Ghz Late 2008, iPad 3G, Mac OS X (10.6.6), Mac Developer
  • BanditoB Calculating status...
    Currently Being Moderated
    Mar 9, 2011 2:35 PM (in response to a Mac user)
    I'm seeing it too. I first upgraded my iPhone to 4.3 and then tried Home Sharing on it and everything seemed to work just fine. I then upgraded my iPad and tried Home Sharing and got the "Cannot connect to media library" error. Next, I tried to connect the iPhone to my iTunes library again and it got the same error message.
    I then restarted iTunes and both the iPhone and iPad connected, but when attempting to play media it would appear to start playing and then immediately stop. Any attempt to stop home sharing and then reconnect gets the media library error.
    When I get a chance, I'll reboot my MacBook Pro to see if that makes any difference, but it seems pretty flakey right now. It'll be interesting to see how it goes with my iMac at home this evening.
    iMac, MacBook, Mac Mini, Apple TV, iPhone, iPhone 3G, Mac OS X (10.5.4)
  • Johnathan Burger Level 6 Level 6 (14,430 points)
    Currently Being Moderated
    Mar 9, 2011 2:39 PM (in response to a Mac user)
    Do you have the newest version of iTunes-10.2.1(released the .1 version yesterday)?

    Homesharing is working well for me, no issues at all.
    20" iMac Core 2 Duo 2.66Ghz;4GB RAM;Nvidia 9400, Mac OS X (10.6.4), 4G iPhone-Mac Mini Core2 Duo 2Ghz; 2GB RAM Eyetv w/USB HYbrid
  • Richey112 Calculating status...
    Currently Being Moderated
    Mar 9, 2011 2:40 PM (in response to a Mac user)
    I am having a similar issue. I can connect to my Imac library with both my Ipad and Iphone and the thumbnails populate. When I first accessed a movie from my library it played. the second movie and every one since then wont. I get a message one my ipad that states "This movie could not be played". on my iphone I get, "the movie format is not supported". If I sync the moveis to either device they play fine and they also play fine when streamed to my appleTV. Any help would be appreciated.
    Imac, Mac OS X (10.6.6)
  • Kosimo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 9, 2011 2:46 PM (in response to a Mac user)
    I'm having exactly the same issue. I'm using iTunes 10.2.1 and iOS 4.3 in my iPhone 4. My MacBook Pro is connected thru an ethernet cable to the Airport Extreme base, and the iPhone 4 wireslessly to the same Airport Extreme base. Once configured in the iPod settings in the device and in the advanced menu in iTunes I get the Shared option inside the iPod app, but once i tap the option I get the message:

    CANNOT CONNECT TO MEDIA LIBRARY
    MacBook Pro 2.4Ghz, Mac OS X (10.6.6), iOS 4.3
  • Kosimo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 9, 2011 2:51 PM (in response to a Mac user)
    I could make it working: This is what I did.


    1) Open the iPod App without opening iTunes. (You won't see the Shared Option)

    2) Open iTunes

    3) You'll see that the Option Shared appears

    4) Hit it and wait 'till it connects.


    I don't know if this can help you, but at least I've got it working.

    Regards from Barcelona
    MacBook Pro 17'' i7 2.3 SSD512, Mac OS X (10.6.6)
  • Kosimo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 9, 2011 3:02 PM (in response to a Mac user)
    We're probably suffering from an unpolished feature. I'm sure that this will be fixed in future revisions of iTunes or iOS... Anyway, I'm glad to know that at least is working for both of us
    MacBook Pro Sandy Bridge i7 2.3, Mac OS X (10.6.6)
  • Fred Tedsen2 Calculating status...
    Currently Being Moderated
    Mar 9, 2011 3:25 PM (in response to a Mac user)
    Here' what I get:

    I have two computers on the network that I have enabled for Home Sharing. My iPad will see each of them, but only one at a time. Furthermore, if it sees #1 but I want it to see #2, I have to quit iTunes on both #1 and #2, then restart iTunes on #2. The only way I can get it to use #2 is to have iTunes off on #1 when I run iPod or Videos apps on the iPad.
  • zwei Calculating status...
    Currently Being Moderated
    Mar 9, 2011 4:01 PM (in response to a Mac user)
    I had to turn off home sharing and re-enable it in iTunes. Started working after that.
    24" iMac - Core 2 Duo 2.16, Mac OS X (10.6.6), iPad, iPhone 4, and iPod Touch 4
  • Richey112 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2011 4:35 PM (in response to a Mac user)
    this has been marked as solved, but none of the solutions here have worked for me. I still get the message that this movie can not be played when accessing home sharing from my ipad. any other ideas?
    Imac, Mac OS X (10.6.6)
  • Terpdog Calculating status...
    Currently Being Moderated
    Mar 9, 2011 5:37 PM (in response to Richey112)
    I'm not having any luck either. Works for Music fine for I see nothing for video's. The interesting thing is that my iTouch sees the video's fine but the iPad does not.

    It works great on my iTouch but my iPad is not even seeing any videos. iTunes is running on a Windows XP machine and all of the videos I've actually synced to the iPad and they run from the iPad w/out any problem. But the video share is FUBAR.
    64GB wifi, iOS 4
1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.