6 Replies Latest reply: Mar 10, 2011 9:52 AM by sstyle
sstyle Level 1 Level 1 (0 points)
Hello. Today I bought pre-owned MacBook pro late 2009. Everything is fine except Wi-Fi network. It shows only one network instead 5-6 around me and doen`t connect with error "connection timeout". I tried 3 routers, Reinstall Mac OS X, Update it to 10.6.6, reset NVRAM & SMC..nothing helped (((

My Log

09.03.11 22:42:17 kernel Auth result for: 00:14:d1:6f:9d:ae No Ack
09.03.11 22:42:23 airportd[73] Apple80211Associate() failed -3905 (Timeout)
09.03.11 22:42:24 kernel AppleUSBMultitouchDriver::validateChecksum - 512-byte packet checksum is incorrect (expected 0x96ce, checksum bytes were 0x742)
09.03.11 22:42:24 kernel directed SSID scan fail
09.03.11 22:42:31 kernel Auth result for: 00:14:d1:6f:9d:ae No Ack
09.03.11 22:42:38 kernel Auth result for: 00:14:d1:6f:9d:ae No Ack
09.03.11 22:42:38 airportd[73] Apple80211Associate() failed -3905 (Timeout)
09.03.11 22:42:38 Apple80211 framework[143] airportd MIG failed (Associate Event) = -3905 (Timeout) (port = 29955)
09.03.11 22:42:38 Apple80211Agent[143] Error joining BYX32: Время подключения истекло (-3905 timeout connecting)
09.03.11 22:43:44 /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedSupport/TISwitcher.app/Contents/MacOS/TISw itcher[130] CPSGetCurrentProcess(): This call is deprecated and should not be called anymore.
09.03.11 22:44:37 com.apple.launchd.peruser.501[95] (com.apple.AirPortBaseStationAgent[128]) Exited: Killed

MacBook pro late 2009, Mac OS X (10.6.6)
  • yomichee Level 1 Level 1 (10 points)
    could you please provide the Router model(s) you are trying to connect to, the authentication method (WEP or WPA ... quickly if it is WEP change your router to WPA / WPA2 accordingly)
    Wifi channel it is set to ?... try 11 if possible turn off automatic ...
    As well confirm protocol on router for both 802.11 b and g mode ... not one or the other .
  • sstyle Level 1 Level 1 (0 points)
    Trendnet TEW-634GRU, Linksys WRT-160NL and other.
    Authentication is WPA Personal, but I tried disable it completely.
    Wi-fi Channel set to 6, but I also tried to change it to another.
    Screen: http://img220.imageshack.us/img220/2840/20110310153512.jpg
    And my another MacBook pro mid 2010 shows me about 6-7 wi-fi networks...But subj macbook shows only one...
  • yomichee Level 1 Level 1 (10 points)
    Hello I think that you may have MAC auth issues and it should be WPA2 - try changing on Mac re:

    In System Preferences, remove the network if it's remembered. You'll need to go to Network, Airport, Advanced, and then find it in the list, and hit the little minus. Now try connecting. I've seen networks that were set to WPA2 come up as WPA-Personal, since the laptop sometimes has trouble figuring it out.

    For these, I've had to set them up manually, by going into the system preferences, network, airport, advanced. Add a new network (plus at the bottom), put in the name EXACTLY, and the password, and WPA2-Personal.

    You can also try to change the wifi protocol on the router to b only and see if that helps... if you think that it will slow down your network etc you can improve network functionality by using a better DNS server, I use the following software to find the best DNS server in the area: namebench

    Hope this helps.
  • sstyle Level 1 Level 1 (0 points)
    Thank you for namebech, it`s very useful app.

    I tried to connect with WPA2...all the same ((
    I think it`s hardware issue. macbook should show all networks around me...
  • yomichee Level 1 Level 1 (10 points)
    It is highly likely I have a new MBP 10.6.6 no no issues at all - right out of the box ...
  • sstyle Level 1 Level 1 (0 points)
    My mid2010 too...
    Well..I will try to go to service provider