Previous 1 2 3 Next 40 Replies Latest reply: Oct 31, 2013 10:27 AM by foster2
Brice Unland Level 1 Level 1
Just upgraded my iPhone 4 to iOS 4.3. When I turn on the personal hotspot feature and connect to the phone via Wifi on my laptop (Macbook) and/or my iPad, they start to connect (accept the password) but then the connections cut in and out. On the iPhone the blue bar at the top continues to appear and disappear, as if it is dropping and starting the connection. Neither iPad or Macbook remain connected to the iPhone, despite it saying 2 connections. The MacBook will say in network settings that is connected (breifly) and has an IP, but will be dropped shortly after as the iPhone goes back to starting and stopping the sharing.

Thoughts? Anyone else have this?

iPhone 4, iOS 4, upgrade to 4.3
  • BGraceTFaith Level 1 Level 1
    Same here. Except I can't connect to my hotspot more than once. Then the connection drops from the iPad but my iPhone tells me it's still connected. Now every time I turn the wifi off and on on both devices, the iPad sees the hotspot, but won't connect, but the iPhone says it's connected. It's really quite frustrating.
  • Murali Narayanan Level 1 Level 1
    yes, i see the same issue when i try to connect my wifi only ipad to the iphone4.
  • mcoleyase Level 1 Level 1
    Same problem here. I already had the AT&T tethering plan, and had used the USB tethering previously without problem. Installed iOS 4.3 (no probs), flipped on the personal hotspot, and tried to connect my Dell laptop. It connects for a few seconds, blue "hotspot tethering" bar shows on phone, laptop gets an IP address, then drops out on both ends. I can repeat the process as many times as I want, but it won't stay connected. Rebooted the phone, still no soap. Hope someone has a cure for this.
  • mcoleyase Level 1 Level 1
    I read a couple of suggestions on a Verizon iPhone hotspot thread.

    1. Phone is too close to laptop (within a foot or so). So I moved it 10 feet away. No love.

    2. Phone name (which is also the SSID) has spaces or apostrophes in it. So I changed the phone name to a short string with no spaces or punctuation. Still no love.

    I then tried it with my wife's newer Dell, running Vista. Ta-da! After a minor bit of futsing around, it connected and stayed connected. But still could not connect (or stay connected) with my older Dell. So now I am thinking hardware or drivers.

    Wifi adapter is internal on this old lappy, rather than an external USB stick. I went to the dell site and downloaded the latest Intel drivers for the WiFi hardware and installed. Still no soap. It tries to connect, hangs on authentication, and eventually gives up and cycles.

    So now I think it is a compatibility issue with old hardware/software that doesn't properly support the WPA2 security, even though it says it is supposed to. Anyone come up with anything else?
  • Bernardo314 Level 1 Level 1
    Well, for what it's worth, I jailbroke my iPhone 4 when it was running iOS 4.1 and installed MiWi (the only way you could tether via wi-fi prior to 4.3). It worked FLAWLESSLY. For the 3+ months I was using MiWi to tether, it never dropped. I primarily use it to stream internet radio in my car using my iPhone 4 and an iPod touch. (as an aside, Apple should consider allowing MiWi on the app store, since it's a fantastic product!!)

    I upgraded to iOS 4.3 a couple of days ago and changed my plan with AT&T to include the tethering option. I am now 100% a victim of the same thing you guys are all complaining about. I can connect to my iPhone 4 from the iPod Touch and it will stream for 6-8 minutes, and then the connection is dropped and, unless I restart the Personal Hotspot on the iPhone 4, it won't connect again. You'd think that the Apple solution for wi-fi tethering would be better than one intended for jailbroken iPhones...think again!

    I'm experiencing the identical issues when I connect with my laptop, or my older iPhone 3GS. In all instances, it will connect for a few minutes, and then drop the connection.

    So this only leads me to conclude that this is ENTIRELY a software issue and not a hardware one. Since I was able to use the same hardware flawlessly before, and now it fails 95%+ of the time.

    I'm sure you'll be hearing TONS of these complains and Apple will be forced to come out with some sort of hotfix for this. I'm convinced (because of my own experience) that this is a software issue.
  • JohnnyG178 Level 1 Level 1
    Same issue here as well.
  • Inhouse007 Level 1 Level 1
    I have the same problem here. None of my laptops can connect, they keep trying to acquire a network address but unsuccessful.
  • BGraceTFaith Level 1 Level 1
    Well, after resetting the network settings on both my iPad and my iPhone, all connections seem to be strong as an ox. Try resetting network settings on both devices.

    I was jailbroken before iOS4.3 and MyWi worked great until the last few updates, then it got super flaky and would only work 1/4 of the time. It was enough of an annoyance that I decided to pay for tethering and upgrade to 4.3, losing my jailbreak.

    After a couple 0day hiccups, all seems to be well. Been using my iPad and MacBook both on the hotspot for the last 4 hours and still haven't seen the connection drop.
  • Roedmario Level 1 Level 1
    Hi, I have no problem with my laptop running Vista, but on my laptop running XP pro connection did cut in and out, UNTILL I tethered the Iphone via USB. I think this allowed the Laptop to register the IP of the Iphone. When I removed the USB tether, and tried to connect wirelessly to the Iphone hotspot, it worked, and did so even after reboot. Could work...
  • mcoleyase Level 1 Level 1
    The story continues - Dell Latitude D510 with Windows XP SP3, I updated the Intel 2200BG wifi drivers. Nope. I changed wifi power management on the driver from default (minimum) to maximum. Nope. I reset network settings on the iPhone. Nope. I tethered through USB. Hardwire tethering worked before, and still works, but when I disconnect the USB and try to connect via wifi, NOPE.

    But I am glad to hear that some people are having success. Keep those ideas coming, and I will keep trying different stuff. The software on the laptop can see the iphone wifi hotspot, but it fails after 10 - 15 seconds of trying to establish a connection. I really believe it has something to do with the WPA2 security. I think. Maybe.
  • Jerry Barrow Level 1 Level 1
    Same here!

    I have the AT&T Tethering plan. My iMac sees my iPhone's wi-fi hotspot network, connects but can't connect to internet.

    Doesn't connect to internet via Bluetooth (yes, my machines are paired) nor does it connect to internet via USB.
  • thaboss Level 1 Level 1
    Same here but for me it looks like the connection is lost when the devices go into sleep mode.
  • emlaatan Level 1 Level 1
    When i connect to PC via iphone 4 hotspot, it'll last only max 10mins after that the signal will drop and connection become idle. i cannot connect to internet at all after that. if i connect using USB cable, it lasts much longer but the signal will drop when the phone goes to sleep. Can anyone help...please.
  • Invisible-bob Level 1 Level 1
    Seems doing the network reset worked for me. I was getting the cutting in and out too. So far so good.
Previous 1 2 3 Next