Previous 1 2 3 Next 40 Replies Latest reply: Oct 31, 2013 10:27 AM by foster2 Go to original post
  • grasshoppertrekker Level 1 Level 1 (0 points)

    Not sure if this was ever resolved, but I had the original issue with iOS5, iphone4 and ipad2. I resolved it by setting a static IP address on the iPad for the Wifi connection. Hope this helps.

  • Graham J Level 1 Level 1 (0 points)

    It does, thanks! I was getting really frustrated with connecting my iPad to my 4S via Personal Hotspot. After a fresh boot of the phone it would work as expected but if the connection was terminated (say by switching hotspot off and on) or after the two hadn't been connected for a while it got into this state where I could see and connect to the hotspot but it would drop a few seconds later then try again over and over.

     

    After a lot of experimenting I finally figured out that there seems to be a pretty serious bug in the hotspot's DHCP server. AP discovery and WPA authentication work great but in this weird state the iPhone will not give the connecting device an IP. The only solution to fix the DHCP server is to reboot the phone.

     

    That being the case, grasshoppertrekker's advice is bang on - you need to give the connecting device a static IP address. This gets around the DHCP issue.

     

    For the less technically inclined, here's how to do that with an iPad:

     

    - Reboot your phone and connect to the hotspot as usual and ensure the connection works

    - On the iPad go to Settings - WiFi and tap the arrow to the right of your iPhone's name

    - Write down all the values you see under the DHCP tab

    - Tap the Static tab

    - Enter in the same values you just write down

    - Hit "WiFi Networks" at the top to go back

     

    The iPad will now reconnect using the same settings as DHCP would have given it, but without relying on the broken DHCP server.

     

    Optional extra: Instead of using whatever DNS values the DHCP server (and by extension your mobile data ISP) gives you, use OpenDNS IP's instead. This will speed up YouTube due to their partnership with Google and prevent your ISP from traking your web usage via DNS interception. To do this enter the following into the DNS field under the Static tab: 208.67.222.222,208.67.220.220 (note the comma)

     

    Cheers,

    Graham

  • frankiefrank Level 1 Level 1 (0 points)

    it seemed to work for a few mins then it dropped again

  • smbjerke Level 1 Level 1 (0 points)

    Hello Kezafog and others,

     

    I've had this enjoying problem forever with all sorts of devices using my iPhone as personal hotspot. I finally decided to se if others had similar troubles, and guess what, loads of people had. I then found one advice that I wanted to try:

     

    TURN OFF BLUETOOTH on the iPhone

     

    Whereas I've often been disconnected after a few minutes, I now have had it running for hours without disruption.

  • Kazafog Level 1 Level 1 (0 points)

    Pleased to see someone is reading the entire post, turing the BLUETOOTH OFF fixed my connection to my wifi router via dhcp, fixed multiplayer games via wifi and fixed the otherwise useless hotspot feature from 4.3.3 -5.01. I am glad someone else is benefitting from this.

  • gregfountain Level 1 Level 1 (0 points)

    Yep, resetting the network connection works, everytime you have to do it, because I have had to perform that inconvenient solution several times and I still end up losing the connection on a regular basis.

  • P 10 19 Level 1 Level 1 (0 points)

    I also have encountered this problem many times. I have an Iphone 4 and have downloaded the latest ios software. I have carried out various resets, turned off bluetooth and even been issued with a new device and yet the constant personal hotspot disconnection issue never goes away.

     

    Having said that, I am glad to say that I have discovered a solution. The solution has worked for the last 14 days without any disconnection and without any finger crossing.

     

    Step 1 - whenever you intend to use your hotspot, turn off your bluetooth first

     

    Step 2 - prior to connecting via your hotspot, set your screen auto lock to "NEVER" by going into the settings app, then selecting general followed by the selection of "Auto Lock" and then selecting "never". Always set it to never prior to and throughout your hotspot connection but turn it off after you finish as it takes alot of power.

     

    Step 3- turn on your wifi and leave it on permanently even when not connecting

     

    Step 4- turn on your personal hotspot and leave it on permanently even when not connecting

     

    Step 5- keep your device on the personal hotspot screen thoughout your sessions and NEVER depart from it whilst you are connected

     

    Step 6- from henceforth, NEVER EVER turn off your wifi or hotspot and dont reset the network settings either, EVER

     

    Step 7- continue to connect (use the net) without turning off your wifi or hotspot, despite the diconnections. provided that you permanently leave both the wifi and personal hotspot on even when not connected, your constant disruptions and disconnections will cease after a month.

     

    I discovered that each time you turn off the hotspot, for some reason, its memory erases completely and it takes about a month to get back to its normal state. Please dont abort your hotspot from henceforth, just leave it and the wifi on permanently, after about a month your connection will be crystal and even after that, dont turn them off ever again.

     

    you can still use the bluetooth but only when not using the hotspot to connect otherwise you will confuse the hotspot.

     

    Step 8- be prepared to exercise patience for about a month and throughtout this period and beyond, whatever you do, "DO NOT TURN OFF YOUR WIFI OR HOTSPOT"

     

    the success of the hotspot is kind of like a pregnancy except its duration is a month. if within that month you abort the baby (hotspot) by turning it and the wifi off, you will kill it. if however you let it grow, it will be born after a month and provided that you NEVER EVER turn off your wifi and hotspot, your baby will grow to a grand old age.

     

    Step 9- dont use your iphone for other agendas whilst connecting apart from if you recieve a call or an important/expected text message

     

    Step 10- if you follow these instructions from today (2/12/12), by the 30/12/12, you will finally have joy in your hotspot but whatever you do, "PLEASE DONT TURN OFF YOUR WIFI OR HOTSPOT EVER", eventually (after a month), your diconnections will disappear.

  • d.g.hall Level 1 Level 1 (0 points)

    This is still an issue for me. Quite a pain. You would think Apple might have rectified it after some years have passed?

  • sacwa Level 1 Level 1 (0 points)

    Go to windows device manager > network adapeters > advanced > wireless mode > pick value "g" mode and click ok

  • gregfountain Level 1 Level 1 (0 points)

    Graham, I mant to reply sooner, but adding the DHCP and Static IP values did the trick! Thanks!

  • foster2 Level 1 Level 1 (0 points)

    just got off the phone with apple support and they fixed the problem for me. i was using my iphone to hotspot my macbook and i did find that hard coding an ip address on the macbook fixed things for me but that was a pain.  the fix they had me try which worked, is to go into system pref (on the macbook) - networking - find your wifi connector and hit the minus sign to rip it out.  then, reinstall it, then reboot the macbook.  this fixed me right up and it works perfectly now without having to hard code or goof around.

     

    thanks apple!

Previous 1 2 3 Next