Previous 1 2 Next 27 Replies Latest reply: Mar 16, 2011 6:26 PM by Fitzbew
WhiplashDG Level 1 Level 1 (0 points)
I just updated to 4.3 today and enabled Home Sharing on my computer immediately afterwards. The account showed "On, no users connected" under iTunes preferences on the computer, and iTunes was open and running the entire time I attempted the following:

When the update finished on the phone, I found the Home Sharing section under Settings > iPod, and I entered the appropriate username and password for the Home Sharing account (correctly, I might add - I've fat-fingered many passwords in the past, so I took extra care this time). After connecting my iPhone to my home wifi network (the same one as the computer in question), I opened the iPod app and went to "More," but the "Shared" option did not appear at all. I hard-reset my phone to no success, so I then restored my phone to factory settings through iTunes and attempted to just connect to wifi and enter the AppleID and password for Home Sharing, but it still will not populate the "Shared" option. I am now very confused.

Help?

Asus EeePC, Windows XP
  • ParagJ_11 Level 1 Level 1 (60 points)
    I had the same issue; few things I did and got connected.

    - Ensured that iTunes is updated to 10.2
    - Logged out from Home sharing in itunes first, and then re-enabled it with my apple id.
    - Entered the same credentials on my iPhone 4 and yes, ensured that the id's matched at both the ends including case-sensitiveness.
    - After enterning the home sharing id in iPhone i left the phone in settings screen for about a minute and then jumped to iPod and get the sharing option.

    Hope the same steps helps to you as well.
  • WhiplashDG Level 1 Level 1 (0 points)
    Thanks for the quick reply, but I followed your recommended steps from top to bottom and got the same result: no "Shared" option. I'm glad it worked for you, but it has done nothing to change my state.

    As a follow-up, I also have tried rebooting my computer and restoring my phone from a forced recovery mode, but those also did not help. Anyone have any other suggestions out there?
  • noonch Level 1 Level 1 (0 points)
    I'm having the exact same problem. iPhone's updated to 4.3. iTunes is updated to 10.2.1. I have Home Sharing on, on both my Win 7 box and MacBook Pro, and I don't see "Shared" on the MORE tab in the iPod app.

    Home Sharing does work, however, between Win 7 and the MBP in iTunes.

    Out of curiosity, what brand WiFi router do you run on your home network? I have a Belkin.
  • flickerman Level 1 Level 1 (5 points)
    @WhiplashDG Have you read this support article?.
    @noonch You have to enable Home Sharing in your iPod settings also. Then go to More from iPod player menu and select iTunes library. I am using a Belkin Play Max router and this tutorial worked for me.
  • noonch Level 1 Level 1 (0 points)
    Thanks for the suggestions. Yes, I had it enabled in Settings > iPod > Home Sharing. I've also tried various permutations of hard reboots, turning off/on Home Sharing, etc., with no luck.

    I just finished updating my wife's iPhone4 to 4.3 and it's exhibiting the same issue with "Shared" not appearing in the iPod app.

    Perplexing, but I suspect it's my network. Running an N300 here.
  • ParagJ_11 Level 1 Level 1 (60 points)
    I am using a combination of Airport Express and Airport Extreme.
    An update to my situation below;

    Home sharing is not happening with iMac. However, its working perfectly fine with my macbook only.
    And yes, homesharing is working fine between my iMac & macbook.

    using 2008 version of iMac & unibody book.

    hard to explain, but that;s how it is at the moment
  • Adam McMaster Level 1 Level 1 (0 points)
    Make sure you've selected "Advanced -> Enable Home Sharing" in iTunes. It's not enough to just enable Sharing in Preferences.
  • blark Level 1 Level 1 (50 points)
    On the iPhone 3Gs, iPhone 4, iPod Touch 3rd Generation, and 4 generation, and both the iPad, ipad2,

    First on you mac or PC you have to enable Home Sharing in iTunes, then next thing is go to the one of the devices listed above and go to settings, iPod, then you will see Home sharing you need to enter the same apple ID that you used on the mac or PC, then after you do that then you go to the iPod then you need to tap on more then after where it says podcasts you will see Shared, then you click on that and you will see all of the shared.
  • Andreas Scahefer Level 1 Level 1 (0 points)
    Had the same issue. Nothing seemed to work. Eventually I just disabled the Home Sharing on my iTunes (on my MacBook Pro) and then re-enabled it right afterwards. Terminating iPod on the iPhone and restarting did the trick to bring up the "Shared" entry.
  • OzJMan Level 1 Level 1 (0 points)
    i found that you need to turn on wi-fi on your phone for it to work! it might sound silly but have you checked that its on?
  • WhiplashDG Level 1 Level 1 (0 points)
    Thank you all for your replies, but the problem is still unresolved - I still do not have access to the "Sharing" option on my iPhone 4.

    As to the question about the router, it is a Cisco router. I just now tried disabling the "SPI Firewall" from its settings menu, and my iPhone now has the "Processing" pinwheel spinning constantly when I open the iPod app, as though it is trying to connect, which it was not doing before. When you guys got Home Sharing set up on your devices, did it process and connect instantly, or did it take a while?
  • richrichie Level 1 Level 1 (0 points)
    **OMG THIS WORKS* TURN WIFI ON AND OFF ON THE IPHONE
  • Mukund R. Level 1 Level 1 (35 points)
    Thank you for that. The interface designer from **** who decided to add a menu for "Turn on Home Sharing" under Advanced menu - while leaving the iTunes preferences "Home Sharing" as it is - needs to be shot.
  • ambientfox Level 1 Level 1 (0 points)
    I was having the same problem as this but got it working now thanks to this suggestion. Because I had previously (over a year ago) copied my itunes library when I got a new hard drive, I had to recreate my itunes library.

    Home sharing is working fine now, but it does seem to have got rid of any changes to the ID3 tags I'd made. For instance some artist info I'd changed to match the album artist has reverted, and some TV shows were labelled as movies, so I changed them, but now they're back in the movies section.

    JUST HAD A LOOK AROUND ITUNES AND IT SEEMS TO HAVE SCREWED A LOT OF THINGS UP. Lost all my apps, ringtones, etc. and when I go to my iphone in itunes nothing's syncing and if I mark the checkboxes for it to sync, the bar at the bottom seems to suggest it's going to delete pretty much everything. Time to see if I can restore it as it was. Home sharing isn't worth this much hassle...

    Message was edited by: ambientfox

    Ok, so I've now got my iTunes library back (by dragging the file I'd trashed when following the advice above back to the iTunes directory) and everything seems to be syncing properly, and once again home sharing isn't working.

    It looks like the problem is with the library ID, but the only way to fix it screws up a whole lot more.
Previous 1 2 Next