Previous 1 2 3 4 Next 55 Replies Latest reply: May 4, 2012 3:06 AM by MittWaffen Go to original post
  • nicj26 Level 1 (0 points)

    Exact same problem running win 7 64bit.

    Just bought new 2011 MBP with the 6750m 8gb RAM and even got a SSD drive and it starts running super slow periodically.  I use photoshop and 3DS max.  When I turn off the open GL function in photoshop it runs smoothly, when I turn it back on I can barely draw a line. 

    I have reinstalled all the bootcamp drivers that came on the disk.  Tried the AMD drivers with no luck.  Says I don't have the supported hardware on my machine even though my device manager recognizes it.

    Called AMD with no luck.  They said it would need to be a driver from Apple for Bootcamp.  Called apple and the tech support guy had not heard of the problem and was of no help because I am running windows....

    I ran a benchmark program and my GPU was in the 7-8 FPS range. 

    One odd thing is that it will be working great for a bit then just suck.  And like some of the others on here it seemed great for the first week then without any changes that I know off just stopped working correctly.


    Anyone have an idea of what this is yet?  I am going to return this thing if I can't get it working this week.

  • ds store Level 7 (30,325 points)

    Look under your Energy Savings and turn off Graphics Switching. Should use dedicated graphics from now on.


    Unless you didn't install Windows according to Apple's Bootcamp instructions, it sounds like it's not using or don't have the video drivers.

  • nicj26 Level 1 (0 points)

    Thanks for fast response...

    Is there an option to do that within Windows on the Mac?

      I have gone to the enegry control panel (in windows) and there are no options for graphic switching.  In my windows device manager I only show the 6750 card and nothing else.  Not sure that means anything tho.

    Also I can chose to disable the driver that was installled when I went through the bootcamp CD.  When I do, the integrated card shows up as my only card and my resolution goes really bad etc.

  • Deefective Level 1 (0 points)

    FYI: When you disable the discrete AMD GPU in windows, you are not seein the integrated SNB i7 GPU - just windows using the most basic interface to the AMD graphics hardware (standard VGA driver).

    You cannot (at this stage) use the integrated Intel HD 3000 GPU on the Sandy Bridge series CPUs when bootcamping windows.

  • ImacNate Level 1 (0 points)

    I'm having the same issue.  mid 2011 Imac i7 3.4ghz 16gb ram AMD Radeon HD 6970 2gb.  fps 8-15 in bootcamp.  no problems in lion.  I have searched all over the internet with no results.  Hope they fix the issue soon!

  • Balfa Level 1 (0 points)

    ok I've found the solution:


    It is a Powerplay issue, the GPU get stuck @ 100MHz while gaming, verified with GPU-Z.


    Just download Catalyst Control Center from AMD and enable PowerPlay and save.

    Now it doesn't shows any infos but this action has 'defrozed' my GPU clock to its rated 600MHz on my 2011 MBP 6750m.

  • NatoCannon Level 1 (5 points)

    I just solved this with what was posted above, I have a new 2011 15" with all the bells and whistles, 6750M etc.


    Once you get the catalyst control centre installed, whether it's from an older or a newer version of the ATI drivers, make sure you go into the power settings and ENABLE powerplay.


    It seems like the default powerplay setting is to throttle the graphics card...! You can't select anything in the power options, but when you enable it and the macbook is plugged in, the graphics performance is restored to what it SHOULD be which is blazing fast.


    Hope this helps someone else...!   I was pulling my hair out but am now relieved, thanks to other posts. Gotta get my LoL fix in...

  • itsnipon Level 1 (0 points)

    I too am having this problem. On a fully loaded 6750 2011 MBP I am getting stuttering on LoL on medium settings. I tried to go into CCC and enable powerplay but it won't let me. The apply button is greyed out and if I restart CCC it doesn't save the setting. Any ideas?

  • NatoCannon Level 1 (5 points)

    DISCLAIMER: If you mess up this stuff you might bork your Windows 7 installation and have to reload it, so... at your own risk, not my fault, yadda yadda yadda.


    I'll re-post what I did to fix it - or at least, the major steps I took so that I have access to that function... unfortunately I can't tell you specifically what fixed it as I took the "shotgun method" approach to IT sleuthing for this, figuring I could always nuke the bootcamp install and reload it if necessary.


    So - following directions from another post, I first downloaded and installed this:



    That MAY be enough for you, it's a newer driver than what's included with bootcamp and should enable what you need to fix the problem. I was reading however that people weren't able to get the new Deus Ex to work unless even later drivers were installed (wouldn't know, haven't tried it), so, after installing that one, this one will install like a charm:



    Hope that helps you out.


    My League of Legends performance was kick-butt after this, following the enabling powerplay stuff I posted above. Again, important to note that I think powerplay is still enabled in a way, in that you're going to get poor performance if your laptop isn't plugged in... at least, that's what it was doing for me. (Powerplay is an AMD/ATi windows function that down-clocks a laptop's discrete graphics solution when the laptop is in battery mode - or can set it to NOT do so, normally)

  • bluez_ps Level 1 (0 points)

    This worked for me thanks!


    Enable Power Play options in Catalyst Control Center worked for me.

  • itsnipon Level 1 (0 points)



    I am still having issues enabling powerplay. When I check the box for "enable powerplay" it does not allow me to Apply the settings. The "Apply" button is greyed out. If I exit CCC my "enable powerplay" setting does not save.


    I have tried for about an hour now with no luck. Have you got any ideas as to why it is not letting me enable powerplay? Thanks bud.

  • bluez_ps Level 1 (0 points)

    Hey itsnipon when I enabled PowerPlay it didn't let me change any settings (both boxes are blank and empty) but it did let me apply and save the changes.


    Maybe try checking the PowerPlay box change other settings so the apply button becomes active.


    Performance in Photoshop and games dramatically improved in bootcamp for me.

  • itsnipon Level 1 (0 points)



    Here is a screenshot of what I am talking about. It seems that CCC is not recognizing my battery. Let me know what you think:



    Also, this thread seems to be what I am referring to:


  • NatoCannon Level 1 (5 points)

    Hey there, as bluez_ps mentioned, basically if your window looks like that and you're able to hit "ok", then, that's pretty much it. Likewise for myself, it doesn't recognize anything in either dropdown menu for the "plugged in" and "battery" section, but just enabling powerplay as a whole (the box you have checked) then ensuring my computer is plugged in when doing anything that needs some graphical oomph is enough to get the better performance.


    TL;DR - If you're able to check the powerplay box and hit ok, then that should do the trick.


    If you're not able to hit ok: then, did you install BOTH drivers as I listed above? One and then the other on top of that one? If Windows kicks you a "this driver is unsigned, install anyway?" message, then the answer to that is yes. Again: specifically download and install the drivers I listed, don't go straight to AMD's website. Their stub installer doesn't recognize the 6750M for some reason.


    If that doesn't help: can you post a step-by-step of what you've done so far to get to the point where you're at now?


    To be crystal clear:

    Enabling powerplay as shown here will restore performance to good levels but will NOT fully enable powerplay the way ATi has support for it on other Windows 7 laptops.


    The only way that's ever going to happen is if Apple works with them to get the whole catalyst software suite up and running - which, would be awesome but I am for sure not holding my breath...


    If you're wanting genuine powerplay support - like the downclocking the GPU when not doing anything intensive, then AFAIK the only way to actually do that is to be actively checking and un-checking the powerplay box. While it seems counter-intuitive: the GPU is downclocked when powerplay is unchecked, and clocked normally when powerplay is checked...

  • MultiplePerspectives Level 1 (50 points)

    Apple provided drivers for the GPUs are out of date, buggy and unoptimized.


    Unfortunately Steve Jobs has established a environment of complete control over it's hardware.


    Besides, Apple rarely provide good GPUs on their laptop.

    The AMD 6750 is slow in todays standards.


    I have given up in 2011, finally got myself a gaming rig.

    State of the art GPU, CPU and SSD. Costs less then a MBP, but far better.

    I recommend the same for any gamer or graphics intensive user.